1. Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING) Click the link to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This message will disappear after you have made at least 12 posts. Thank you for your cooperation.

TS3500/3584 library firware upgrade questions with ALMS and transparent encryption

Discussion in 'Tape / Media Library' started by rvillano, Nov 5, 2012.

  1. rvillano

    rvillano New Member

    Joined:
    Nov 10, 2004
    Messages:
    128
    Likes Received:
    1
    Location:
    michigan
    Hello to all the members of this great Forum!

    I have a new customer who wants to use the TKLM software to do encryption with a TS3500/3584 library.

    The customer has purchased TKLM, ALMS and transparent LTO encryption keys.

    This library currently has 2 frames L32 and D32, 10 lto2 drives and 10 lto4 drives.

    The current firmware for the library is 7420 and the drive firmware is 73v1 for the lto2 drives
    and A232 for the lto4 drives.

    The customer wants me to replace the existing lto2 drives with lto4 drives in a 2 partition library for use by the TKLM
    software encryption application while the other partition will be used with the existing lto4 drives using server side
    encryption until the tapes can be re-read and encrypted using TKLM in the 2nd partition.

    I am concerned about the library firmware and drive firmware upgrades that may be required to do this project and
    the issues I may run into trying to install this firmware where usually all my current customers have an
    IBM CE do this type of work.

    Questions:

    1. How do I find out if this library uses enhanced node cards?
    2. Will firmware upgrades for the library and drives be required?
    3. Do I have to do the firmware upgrade before or after installing the ALMS and transparent keys?
    4. Do I have the correct firmware code?

    I was planning to use the ITDT software installed on AIX to do the firmware upgrades if needed and I have the
    8980 library firmware which contains the "B710" tape drive firmware but I am still not sure this is the right code
    for doing this project and I don't want to mess this up for any reason.

    If anyone who has experience in doing this upgrade and who knows if the firmware I have downloaded is correct,
    I would really appreciate your assistance.

    Best Regards,

    bob...
     
  2.  
  3. moon-buddy

    moon-buddy Moderator

    Joined:
    Aug 24, 2005
    Messages:
    6,207
    Likes Received:
    279
    Occupation:
    Electronics Engineer, Security Professional
    Location:
    Somewhere in the US
    My two cents - ask IBM to do this work.

    I had a TS3500 with 3 bays, a library manager and a VTS (the latter 2 referenced as TS7700 by IBM), and was always updated by IBM.

    The risk is high for customers to do upgrades UNLESS you have all the tools needed plus some basic training to do this.
     
    rvillano likes this.
  4. Trident

    Trident Senior Member

    Joined:
    Apr 2, 2007
    Messages:
    287
    Likes Received:
    26
    Occupation:
    IT operations
    Location:
    Oslo, Norway
    I agree with moon-buddy.

    I have a ts3500 that did not have the enhances cards. When IBM updated (preparing for ALMS) the firmware, they fried the accessor card. I had to replace all the cards, and that took about 1 day to complete. The firmware you want, needs the enhances cards. Contact IBM, and have them check and probably replace all cards within the TS3500.
     
    rvillano likes this.
  5. rvillano

    rvillano New Member

    Joined:
    Nov 10, 2004
    Messages:
    128
    Likes Received:
    1
    Location:
    michigan
    Thank You Ed & Trident,

    I guess my next question is:
    Can the ts3500 library with lto4 drives do drive level encryption on its own without TKLM? by using just the transparent encryption FC installed?

    I think this customer is really only concerned with getting rid of the server side encryption for better performance and they are not thinking of the administration of the TKLM software and any issues during DR testing at another site.

    And that brings another question, Disaster Recovery... what impact/issues will need to be addressed during a DR test using TKLM or if just drive level encryption is used and then will this be an issue at the DR location.

    Thanks again

    Bob...
     
  6. Trident

    Trident Senior Member

    Joined:
    Apr 2, 2007
    Messages:
    287
    Likes Received:
    26
    Occupation:
    IT operations
    Location:
    Oslo, Norway
  7. mikeymac

    mikeymac Moderator

    Joined:
    Jun 20, 2003
    Messages:
    905
    Likes Received:
    27
    Location:
    Syracuse, NY
    The 8980 firmware is the latest firmware (and perhaps the last) that DOES NOT require the enhanced node cards. Anything 9XXX and up requires that feature code 1700/1701 be installed for L52 machines.
     

Share This Page