• Please help support our sponsors by considering their products and services.
    Our sponsors enable us to serve you with this high-speed Internet connection and fast webservers you are currently using at ADSM.ORG.
    They support this free flow of information and knowledge exchange service at no cost to you.

    Please welcome our latest sponsor Tectrade . We can show our appreciation by learning more about Tectrade Solutions
  • Community Tip: Please Give Thanks to Those Sharing Their Knowledge.

    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.

  • Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)

    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

storage pool is currently in use, but no process or session active

daviddeleeuw1

ADSM.ORG Member
Joined
May 11, 2019
Messages
20
Reaction score
0
Points
0
Dear TSM admins,
We use a container directory based storage pool.
For a few days now activities on the storage pool are refused because the storage pool is "currently in use".
There are no active processes or sessions. Seems like an "in use flag" was not turned off.
Q stgpool f=d
everything is normal.
The container directories look fine.
Any ideas how to get out of this state ?
---------------------------------------------------------------------------------------------------
protect stgpool cpool type=local

Session established with server XXX: Windows
Server Version 8, Release 1, Level 7.000
Server date/time: 11-05-2019 23:33:54 Last access: 11-05-2019 19:01:08

ANR3658E PROTECT STGPOOL: Storage pool CPOOL is currently in use by
replication, repair, protect, encrypt, move operations or remove
stgprotection.
ANS8001I Return code 12

---------------------------------------------------------------------------------------.
David de Leeuw
Ben-Gurion University of the Negev
Beer Sheva
israel
 

daviddeleeuw1

ADSM.ORG Member
Joined
May 11, 2019
Messages
20
Reaction score
0
Points
0
Definitely a bug in TSM.
Restarting the TSM services on our windows server solved the problem.
David
 

RecoveryOne

ADSM.ORG Senior Member
Joined
Mar 15, 2017
Messages
323
Reaction score
74
Points
0
Have you looked at actlog for the past few days?
Might be useful to see what was running or trying to run.
Since your post indicated you were on 8.1.7, I'd suggest getting a PMR opened to IBM. May have found an issue that needs to be addressed!
 

daviddeleeuw1

ADSM.ORG Member
Joined
May 11, 2019
Messages
20
Reaction score
0
Points
0
Pretty hard for me to find out, as the error continued a number of days, so it is difficult to find the root and what happened there. Also I am not the site admin here, just using an instance of the server. I don't have an IBM customer number.
At least now this is reported here, I assume some IBM maintainer also keeps an eye on the forum. And if anyone gets stuck, please report to IBM...
Thanks
David
 

RecoveryOne

ADSM.ORG Senior Member
Joined
Mar 15, 2017
Messages
323
Reaction score
74
Points
0
No worries. I've yet to make the jump to 8.1.7 on the server side.
Just nice to know things!

Take care
 

daviddeleeuw1

ADSM.ORG Member
Joined
May 11, 2019
Messages
20
Reaction score
0
Points
0
Two years later, our server is on 8.1.11 and still the same problem. Sometimes we miss checking this for a long time, as the problem is buried in zillions of messages in the actlog. Today the server finished protect stgpool (with a few extends missing).

05-03-2021 11:48:32 ANR4002W The protect storage pool process for CPOOL on
TSMMED to TAPEPROTECT on TSMMED is complete. Some
extents might not have been protected. Extents
protected: 1870022 of 1870145. Extents failed to
protect: 123. Amount protected: 125 GB of 125 GB. Amount
failed to protect: 35,477 KB. Extents deleted: 208721 of
208721. Extents failed to delete: 0. Extents moved: 281
of 281. Extents failed to move: 0. Amount moved: 79,376
KB of 79,376 KB. Amount failed to move: 0 bytes. Elapsed
time: 0 Days, 1 Hours, 27 Minutes. (SESSION: 4477,
PROCESS: 41)
05-03-2021 11:48:32 ANR0986I Process 41 for PROTECT STGPOOL (SUMMARY) running
in the FOREGROUND processed 1,870,022 items for a total
of 134,340,661,624 bytes with a completion state of
WARNING at 11:48:32. (SESSION: 4477, PROCESS: 41)
05-03-2021 11:48:32 ANR1892W Process 41 for PROTECT STGPOOL (SUMMARY)
completed with a completion state of SUCCESS but warning
or more-severe messages were issued. (SESSION: 4477,

PROCESS: 41)
I tried this a few hours later
protect stgpool cpool type=local
and .... got the "currently in use" message again. No processes are running.

ANR3658E PROTECT STGPOOL: Storage pool CPOOL is currently in use by replication, repair, protect, encrypt, audit
container, move operations or remove stgprotection.
ANS8001I Return code 12.

I did not find any interesting processes in the actlog.
Restarting the server usually solves the problem, but there definitely is some hidden bug here....

David
 

marclant

ADSM.ORG Moderator
Joined
Jun 16, 2006
Messages
3,735
Reaction score
618
Points
0
Location
Canada
Website
www.ibm.com
Restarting the server usually solves the problem,
Restarting never solves anything, it just makes the symptoms go away until the conditions that caused the error occur again.


ANR3658E PROTECT STGPOOL: Storage pool CPOOL is currently in use by replication, repair, protect, encrypt, audit
container, move operations or remove stgprotection.
That's the cause of your problem.

Check the summary table to see what process may have run concurrently with protect:
SQL:
select start_time,end_time,activity,entity,number from summary where activity like 'PROCESS%' and date(start_time) >= '2021-03-04' and date(end_time) <= '2021-03-06'
Are the options DEFRAGCNTRTRIGGER and DEFRAGFSTRIGGER set at 90 and 95 respectively? It could trigger too many automatic move containers if set too low which could interfere with protect.
 

daviddeleeuw1

ADSM.ORG Member
Joined
May 11, 2019
Messages
20
Reaction score
0
Points
0
Hi Marclant,
The DEFRAGCNTRTRIGGER and DEFRAGFSTRIGGER were set to 80 . I fixed that now,

You are right that I did not solve the problem. At present when trying "protect stgpool" there are no active processes, but again I get the same error.

I tried the SELECT

Digging through the actlog I found:

08-03-2021 15:01:31 ANR0511I Session 645 opened output volume BGU349L7.

08-03-2021 15:01:57 ANR9999D_1141691781 BfOpenCopyPools(bfswcrt.c:1564)
Thread<216>: Invalid attempt to create a copy of a new
bitfile in copy storage pool TAPEPROTECT detected.
(SESSION: 644)
08-03-2021 15:01:57 ANR9999D Thread<216> issued message 9999 from: (SESSION:
644)
08-03-2021 15:01:57 ANR9999D Thread<216> 7ffa1b889b42 OutDiagToCons()+b2
(SESSION: 644)
[...]
08-03-2021 15:01:57 ANR0530W Transaction failed for session 644 for node
MEDBACKUP (TDP VMware) - internal server error detected.
(SESSION: 644)
08-03-2021 15:02:01 ANR0514I Session 644 closed volume BGU348L7. (SESSION:
644)
I cant really follow why a client process opens the "copy storage pool", while it is supposed to work with the "container directory pool".
I don't know if this triggers the problem.

Our Spectrum Protect Manager does not like to file a customer report with IBM, but now I think it is about time...
David
 

Advertise at ADSM.ORG

If you are reading this, so are your potential customer. Advertise at ADSM.ORG right now.

DigitalOcean $100 Credit

Support ADSM.ORG and get DigitalOcean FREE credit. DigitalOcean currently offer a $100, 60-day Free Credit for new accounts. Sign-up here:

DigitalOcean Referral Badge

The Spectrum Protect TLA (Three-Letter Acronym): ISP or something else?

  • Every product needs a TLA, Let's call it ISP (IBM Spectrum Protect).

    Votes: 20 18.7%
  • Keep using TSM for Spectrum Protect.

    Votes: 65 60.7%
  • Let's be formal and just say Spectrum Protect

    Votes: 13 12.1%
  • Other (please comement)

    Votes: 9 8.4%

Forum statistics

Threads
31,871
Messages
135,906
Members
21,786
Latest member
london
Top