• Please help support our sponsors by considering their products and services.
    Our sponsors enable us to serve you with this high-speed Internet connection and fast webservers you are currently using at ADSM.ORG.
    They support this free flow of information and knowledge exchange service at no cost to you.

    Please welcome our latest sponsor Tectrade . We can show our appreciation by learning more about Tectrade Solutions
  • Community Tip: Please Give Thanks to Those Sharing Their Knowledge.

    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.

  • Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)

    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

Illegal instruction(coredump) : After upgrade from TSM 7.1 to SP 8.1.5

#1
Hello all,

being having this nasty problem ; after upgrade from TSM 7.1.3 to SP 8.1.5, cant start the server anymore, it always hangs at this step
---------------
ANR0900I Processing options file /home/tsminst1/dsmserv.opt.
ANR7811I Using instance directory /home/tsminst1.
Illegal instruction(coredump)
---------------
OS is AIX 7100-05-03-1837

Any feedback is much appreciated, As I cant find anything regarding this issue anywhere ! thanks !
 

RecoveryOne

ADSM.ORG Senior Member
#2
Did you perform an OS update recently?
7.1 TL5 SP3 is pretty new (in my eyes).
If so, how was it performed? Is /home/tsminst1 on vg outside of rootvg?
I ask, because my /home/tsminst1 is on the rootvg so I couldn't do an alt_clone while tsm was running. I had to stop tsm, perform aix upgrade, start tsm.

If it helps my env is AIX 7.1.5.2 TSM 8.1.5.100
Upgraded AIX from 7.1.3.3 and TSM went though several revisions. 7.1.7 to 8.1.1 then after a week or so to 8.1.5.
 
#3
Thank you for your prompt feedback !
Yes, indeed OS updated from AIX 6.1TL9 to AIX 7.1 TL5 SP 3, it was performed in-place ( halting TSM, rebooting the LPAR on AIX iso), and like in your case, my /home/tsminst1 resides on rootvg.
After the OS upgrade, TSM 7.1.3 was brought back up and running , then I proceeded with the upgrade to SP 8.1.5
P.S. To give you a bigger picture, this is all done in a test env before replicating on prod
The existant TSM 7.1.3 LPAR was duplicated using mksysb for rootvg and V7000 flashcopy clones for db+logs VG, the new env came up OK, OS upgrades follewed then (I actually tested AIX 7.2 TL3 first, it threw same error then tried with AIX 7.1 TL5 SP3), then SP upgrades (I tested with SP 8.1.5.1 and SP 8.1.5 same results), I use the console mode and the "Update" option (the "Install" option complains about already existing packages), also I answer YES to the question "Do you want to update this instance?" and provide credentials wich are verified successufuly

Much obliged for any help you can think of, as I said this is a test env, so I have liberty to test with any scenario if it could help !
 

RecoveryOne

ADSM.ORG Senior Member
#4
Welp, you have more resources than I when it came to testing! Never had the ability to test out flashcopy clones for the db/logs its always been a rebuild on what hardware I have on hand with local storage to 'prove' it out. Heck not even same CPU types either... Oh well.

Anyhow, I did find a thread on here that may be of help:
https://adsm.org/forum/index.php?th...mksysb-restore-of-tsm-server-db2-error.29976/
 
#5
Thanks mate!
Yeah, pretty unconstrained about resources now !
I took a look at that thread, not sure it is the same situation though, as I could successufuly bring my new env up and running , TSM 7.1.3 on my new LPAR is ok ( dsmadmc can connect, DB2 backups are possible)
I only come up against that exception after I upgrade to SP 8.1.5

Can I ask you if you chose "Update" or "Install" when upgrading, also did you reply "Yes" to "Do you want to update this instance" ?

Thanks.
 

RecoveryOne

ADSM.ORG Senior Member
#6
From the install.sh script I chose Update - Find and install updates and fixes to installed software packages, then Update All

Don't have my logs/console output in front of me. Heck, not sure if I saved them...
 
#7
For the record, the problem occured using media from ibm ftp for SP 8.1.5 and SP 8.1.5.1,
Today I tested with SP 8.1.6.1 from ibm ftp, and the upgrade went smoothly , I used console mode, chose update this instance.
 

Advertise at ADSM.ORG

If you are reading this, so are your potential customer. Advertise at ADSM.ORG right now.

UpCloud high performance VPS at $5/month

Get started with $25 in credits on Cloud Servers. You must use link below to receive the credit. Use the promo to get upto 5 month of FREE Linux VPS.

The Spectrum Protect TLA (Three-Letter Acronym): ISP or something else?

  • Every product needs a TLA, Let's call it ISP (IBM Spectrum Protect).

    Votes: 14 17.3%
  • Keep using TSM for Spectrum Protect.

    Votes: 51 63.0%
  • Let's be formal and just say Spectrum Protect

    Votes: 9 11.1%
  • Other (please comement)

    Votes: 7 8.6%

Forum statistics

Threads
31,381
Messages
133,669
Members
21,495
Latest member
patbel
Top