• Please help support our sponsors by considering their products and services.
    Our sponsors enable us to serve you with this high-speed Internet connection and fast webservers you are currently using at ADSM.ORG.
    They support this free flow of information and knowledge exchange service at no cost to you.

    Please welcome our latest sponsor Tectrade . We can show our appreciation by learning more about Tectrade Solutions
  • Community Tip: Please Give Thanks to Those Sharing Their Knowledge.

    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.

  • Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)

    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

File Device Class Status Critial for no reason

ivandem

ADSM.ORG Member
#1
I'm running SP 7.1.7.200 on AIX. I've got three file device classes that are showing as "Critical" under status in the OC. The security is set as "drwxr-xr-x tsminst1 tsmsrvrs"

Is there something else I should be looking at?

TIV.
John
 

marclant

ADSM.ORG Moderator
#2
Hover over the critical symbol next to the device class for more info.

If that doesn't give enough information, check the activity log for messages regarding the devclass:
query actlog search={device_class_name} begindate=-7
 

ivandem

ADSM.ORG Member
#3
Hovering displayed nothing, and i tried everywhere on the each line. There is also nothing in the act log that give any clue.

Here is the output for actlog query for one of the devices..
  • ANR2017I Administrator JOHND issued command: DEFINE DEVCLASS VMCTLDEV DEVTYPE=file MAXCAPACITY=10G DIRECTORY=/dcp1/vmctl (SESSION: 29992)
  • ANR2203I Device class VMCTLDEV defined. (SESSION: 29992)
  • ANR2017I Administrator JOHND issued command: DEFINE STGPOOL VMCTL VMCTLDEV POOLTYPE=PRIMARY MAXSCRATCH=100000000 DESCRIPTION='FIle pool for VM control files' (SESSION: 29971)
  • ANR2200I Storage pool VMCTL defined (device class VMCTLDEV). (SESSION: 29971)
  • ANR2017I Administrator JOHND issued command: QUERY DEVCLASS vmctldev F=d (SESSION: 31164)
  • ANR2017I Administrator JOHND issued command: UPDATE DEVCLASS vmctldev DIR=/dcp1/vmctl,/dcp1b/vmctl (SESSION: 31163)
  • ANR2205I Device class VMCTLDEV updated. (SESSION: 31163)
No errors; nothing to indicate an issue.

I should also mention that there is not problem accessing any of the directories. Nothing has been impacted, other then the seeming false Critical status
 

DanGiles

ADSM.ORG Senior Member
#7
I am seeing a similar issue, but I am running db2 commands to try to clean up orphaned chunks. The storage pool is marked critical, but when you drill down to the directory level in the OC everything is green.
 

DazRaz

ADSM.ORG Senior Member
#8
Lower your maxscratch down to the amount of disk space you have. I don't believe you have space for 100,000,000 x 10G virtual tapes. I believe it lets you over allocate by up to 30% but I suspect you are way over that.
 

ivandem

ADSM.ORG Member
#9
Thanks for the reply DazRaz. Your suggestion worked for the two device classes that had a storage pool associated with it. Who would have thought the IBM default would cause this.

The one remaining device class is used only for DB backups - this still remains as "Critical". It was out of space as the backup files were not being deleted. I have resolved the space issue this morning but it still has not changed. perhaps this just take some time?
 

DazRaz

ADSM.ORG Senior Member
#10
I have one TSM server which uses a FILE device class for the DB backups. It ran out of space and we fixed by cleaning up old backups with "del vohist tod=-5 t=dbb" and scheduled this to run daily. Just had a look and it also is showing as critical however the filesystem is only at 59% full. I think it may be a bug.
 

droach

ADSM.ORG Senior Member
#11
We had the same issue for a FILE device class that was only used for TSM's DB backups. The volume that was defined to the DEVC was a 1TB volume with 800GB free. So, plenty of space on the volume. The problem was that we/(I) had a the Device Class's setting 'MAXCAPacity' set to 100GB and the MOUNTLimit set to 20. Doing a little math 100GB x 20 = 2TB. Hmmm, no wonder Spectrum was complaining about a 50% threshold exceeded.

Kudos to my coworker for figuring this out and finding this article: http://www-01.ibm.com/support/docview.wss?uid=swg21696240
 

Advertise at ADSM.ORG

If you are reading this, so are your potential customer. Advertise at ADSM.ORG right now.

UpCloud high performance VPS at $5/month

Get started with $25 in credits on Cloud Servers. You must use link below to receive the credit. Use the promo to get upto 5 month of FREE Linux VPS.

The Spectrum Protect TLA (Three-Letter Acronym): ISP or something else?

  • Every product needs a TLA, Let's call it ISP (IBM Spectrum Protect).

    Votes: 9 20.5%
  • Keep using TSM for Spectrum Protect.

    Votes: 23 52.3%
  • Let's be formal and just say Spectrum Protect

    Votes: 8 18.2%
  • Other (please comement)

    Votes: 4 9.1%

Forum statistics

Threads
31,055
Messages
132,235
Members
21,274
Latest member
ctauber
Top