1. Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING) Click the link to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This message will disappear after you have made at least 12 posts. Thank you for your cooperation.

Fastback CDP restore doesn't work

Discussion in 'TSM Fastback' started by Bambino, Apr 14, 2009.

  1. Bambino

    Bambino New Member

    Joined:
    Dec 14, 2006
    Messages:
    4
    Likes Received:
    0
    Location:
    Russia
    Description of current situation:
    CDP configured properly according to FastBack Installation and User's guide, I see data going to Fastback server every time I work with protected file system (network activity is also seen every time when creating or deleting files). I see right icons in Snapshot monitor (green with green "c" letter). CDP restore option is available, CDP timescale is black with blue lines of consistency points (without red lines and green lines) but such error appears after pressing restore button:
    "FBSG7313E Time value is invalid. Adjust time value."

    I really can't find valid time value, even using "Restore to consistency points" option.
    I made a lot of experiments with different servers and file systems, I reinstalled fastback server, I tried to change Windows Locale and time setting and time format. Also during that experiments i never saw green line on timescale (event). Nothing helps.

    What is the possible cause of such behaviour?
    What are the correct rules for using CDP restore?

    Thank you.
     

    Attached Files:

    Last edited: Apr 15, 2009
  2.  
  3. Harry_Redl

    Harry_Redl Moderator

    Joined:
    Dec 29, 2003
    Messages:
    2,258
    Likes Received:
    134
    Occupation:
    IT Consultant
    Location:
    Czech Republic
    Hi,

    what fix level of FastBack do you use? There is 5.5.3 out now. Looked for the error message (it is FBSG7313E, not FSSG7313E) and found the only reference on japan IBM site. Says something about 5.5.2 fixpack (anyone speaking Japanese may translate it for us?)

    Harry
     
  4. Bambino

    Bambino New Member

    Joined:
    Dec 14, 2006
    Messages:
    4
    Likes Received:
    0
    Location:
    Russia
    Fastback v5.5.1.

    It very interesting, but v5.5.0 and v5.5.1 are only available for download on parthner zone of IBM site. I could not find v5.5.2 or 5.5.3, though actual documentation referenced to v5.5.3...At this moment only japanese version of ibm wiki tells about this version.
    So this is another good question.
     
  5. Harry_Redl

    Harry_Redl Moderator

    Joined:
    Dec 29, 2003
    Messages:
    2,258
    Likes Received:
    134
    Occupation:
    IT Consultant
    Location:
    Czech Republic
    Hi,

    strange thing - I do have 5.5.3.0 from local IBM rep so I did not check if it is downloadable or not - and support site really shows 5.5.1.0 as the latest. Drop me an email (harry_redl_AT_yahoo.com).

    Harry
     
  6. mjaquillard

    mjaquillard New Member

    Joined:
    Apr 2, 2009
    Messages:
    6
    Likes Received:
    0
    I ran into this exact same issue a couple of months ago on 5.5.1 - I was told that it was in fact a bug that was fixed in 5.5.2. I have not upgraded since then to verify.
     
  7. Bambino

    Bambino New Member

    Joined:
    Dec 14, 2006
    Messages:
    4
    Likes Received:
    0
    Location:
    Russia
    Local russian IBM still has no versions 5.5.2 and 5.5.3 even in internal repositories. Somebody has to explain situation with version distribution in IBM :)
     
    Last edited: Apr 20, 2009
  8. Bambino

    Bambino New Member

    Joined:
    Dec 14, 2006
    Messages:
    4
    Likes Received:
    0
    Location:
    Russia
    After deeper dive into Fastback functionality I found, that theoretically Fastback server tries to start a filtering events script FilterContinuousEventsScript.bat for further loading event to FastBack Manager every time you opening CDP restore Slider window, but in practice this script starts only after pressing restore button in CDP restore Slider window (It's very easy to check it, theoretical behaviour is discribed on pages 107-108 of TSM Fastback Installation and Users Guide - Events filtering mechanism). It looks like developers logical mistake because events cannot be loaded before start of restore process.
    Also all event are saved in file ContinuousEventsInOut.txt, but this file is always nearly empty:
    JOB127 Start[1240227663] End[1240231261] [Consistency_point|Snapshot_consistency_point]
    JOB130 Start[1240231261] End[1240234663] [Consistency_point|Snapshot_consistency_point]
    Time[1240234663]

    That's why I 've never saw green lines in timescale slider too.
     
: cdp, fastback

Share This Page