1. Community Tip: Please Give Thanks to Those Sharing Their Knowledge.
    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.
  2. Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)
    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

DSM frozen - Api error - TCP error - Java exception

Discussion in 'TSM Client' started by okriss, Jul 27, 2017.

  1. okriss

    okriss ADSM.ORG Member

    Joined:
    Nov 6, 2015
    Messages:
    61
    Likes Received:
    0
    Hi,

    I would like to ask some help!
    I have a problem with tsm client what is exist on 2008R2 and 2012r2.

    When i want to start dsm gui, it will hang on 75% checking agent port number...if i end the dsmagent.exe process, i get an error message: ANS2600S: Browser trying to establishe connection to client, received socket exception: java.netEXception: connect Address is invalid on local machine, or portis not valid on remote machine.

    After the reboot, the dsm start perfectly, i can run backup, if i start the gui again, the problem appeare.

    Telnet works; We upgraded to 6.3.1.0.2, but not helped....dsmc dont give back any message, i dont get hte prompt, just hanging...

    What could it be?

    Thanks for your help!
     
  2.  
  3. marclant

    marclant ADSM.ORG Moderator

    Joined:
    Jun 16, 2006
    Messages:
    2,486
    Likes Received:
    348
    Occupation:
    Accelerated Value Specialist for Spectrum Protect
    Location:
    Canada
  4. okriss

    okriss ADSM.ORG Member

    Joined:
    Nov 6, 2015
    Messages:
    61
    Likes Received:
    0
  5. marclant

    marclant ADSM.ORG Moderator

    Joined:
    Jun 16, 2006
    Messages:
    2,486
    Likes Received:
    348
    Occupation:
    Accelerated Value Specialist for Spectrum Protect
    Location:
    Canada
    You could also try upgrading to latest supported level (7.1 or 8.1, worse case 6.4, but only 2 months of support left).
     
  6. okriss

    okriss ADSM.ORG Member

    Joined:
    Nov 6, 2015
    Messages:
    61
    Likes Received:
    0
    HI,

    2012R2 runs with latest TSM client...8.1.0.2

    in dsierror:
    07/21/2017 22:54:36 ANS5216E Could not establish a TCP/IP connection with address ':1500'. The TCP/IP error is 'Unknown error' (errno = 10061).
    07/21/2017 22:54:36 ANS9020E Could not establish a session with a TSM server or client agent. The TSM return code is -50.

    Why give it this?
    I set the portnumber in opt file, what is not 1500...
     
  7. marclant

    marclant ADSM.ORG Moderator

    Joined:
    Jun 16, 2006
    Messages:
    2,486
    Likes Received:
    348
    Occupation:
    Accelerated Value Specialist for Spectrum Protect
    Location:
    Canada
    Looks like the port number was put instead of the IP/hostname for TCPSERVERADDRESS.
     
  8. okriss

    okriss ADSM.ORG Member

    Joined:
    Nov 6, 2015
    Messages:
    61
    Likes Received:
    0
    I minimalized the parameters... I try connect with it!

    NODENAME xxxxxxx
    TCPSERVERADDRESS {tsm server fqdn}
    TCPPORT 1501
    COMMmethod TCPIP

    Nothing happened...

    dsmj give errors, dsmerror gives errors. Everything say that the client cannot connet to the server.
    I found hotfix for this client version...Would it worth to install it?

    http://www-01.ibm.com/support/docview.wss?uid=swg24036718
     
  9. marclant

    marclant ADSM.ORG Moderator

    Joined:
    Jun 16, 2006
    Messages:
    2,486
    Likes Received:
    348
    Occupation:
    Accelerated Value Specialist for Spectrum Protect
    Location:
    Canada
    On the Spectrum Protect Server, what's the "Server TCP/IP port number" in Q STATUS, that's what you have to put for TCPPORT. Default is 1500, but that doesn't mean your server is using the default.
     

Share This Page