• Please help support our sponsors by considering their products and services.
    Our sponsors enable us to serve you with this high-speed Internet connection and fast webservers you are currently using at ADSM.ORG.
    They support this free flow of information and knowledge exchange service at no cost to you.

    Please welcome our latest sponsor Tectrade . We can show our appreciation by learning more about Tectrade Solutions
  • Community Tip: Please Give Thanks to Those Sharing Their Knowledge.

    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.

  • Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)

    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

Connection Error: Unable to establish connection -SP 8.1.2 on win 2016

combato

ADSM.ORG Member
#1
Hi Pro's,

I have the last couple of Days tried to install and configure a new IBM Spectrum Protect Server v8.1.2 on Windows Server 2016 Standard, but I get an error I don't understand.
After the installation I start the "Configuration Wizard" and try to create an instance. When typing the instance userid (local user I created that is a member of Administrators Group and DB2ADMNS) and a 10 digit and letter password I get: Connection Error: Unable to establish Connection (attached screenshot).

I have followed this steps before I started the wizard: https://www.ibm.com/support/knowled.../srv.install/t_srv_use_local_wiz-windows.html

I have tried to put the server out of our domain an put it in a workgroup but the same error is still there. I have also tried to run the wizard as local Administrator and with my own domain account as is a member of the local groups mentioned above.
I also tried to install on a Win 2012 but the same error occurs!

Any ideas what might be wrong?

/C
 

Attachments

moon-buddy

ADSM.ORG Moderator
#2
Did you try to install the base version first which is 8.1.0?

Can the instance owner login to windows without issues, and have rights to all directories that the TSM install needs?
 

combato

ADSM.ORG Member
#3
Did you try to install the base version first which is 8.1.0?

Can the instance owner login to windows without issues, and have rights to all directories that the TSM install needs?
No, I tried to install 8.1.2 from scratch. I found some notes that 8.1.2 was the first stable release for w2016.
For 8.10 I found this on IBMs system req:

"Microsoft Windows Server 2016, starting with 8.1.1.00. Restriction: Clustered environments are not supported."

The user has no problem to login and can create and access dirs. that TSM need.
 

combato

ADSM.ORG Member
#4
No, I tried to install 8.1.2 from scratch. I found some notes that 8.1.2 was the first stable release for w2016.
For 8.10 I found this on IBMs system req:

"Microsoft Windows Server 2016, starting with 8.1.1.00. Restriction: Clustered environments are not supported."

The user has no problem to login and can create and access dirs. that TSM need.
I also tried to install 8.1.1 and the same error exists. (even tried 8.1.1, and 8.1.2 on w2012 R2 with same fault)
 

marclant

ADSM.ORG Moderator
#5
Did you also do this:
https://www.ibm.com/support/knowledgecenter/SSEQVQ_8.1.2/srv.install/t_srv_upgrade_rxa-windows.html

The error you pasted at the beginning also states to check connectivity:
upload_2017-9-13_9-23-23.png

Check the RXA log too, should be in "C:\Program Files\Tivoli\TSM"

It's an older technote, but may still apply partially: http://www-01.ibm.com/support/docview.wss?uid=swg21417773


As Plan B, you may try to setup the instance manually instead of through the wizard:
https://www.ibm.com/support/knowled...1.0/srv.install/t_srv_config_man-windows.html
 

Patthecat

Active Newcomer
#6
Hi combato,

i have got two other approaches, which may lead into problem solution for your situation.

First:

please, can you turn off your firewall temporarily and run through the wizard again?

The reason for turning off the firewall: In the referred IBM-Knowlegdebase-article you mentioned (https://www.ibm.com/support/knowled.../srv.install/t_srv_use_local_wiz-windows.html), they talk from TCP-ports 137 (netbios), 139 (session service) and 445, but port 137 is a UDP-Port. Maybe, it’s a mistake in the knowlegdebase-article. Did you configure your firewall correctly? For testings you can disable your firewall temporarily. If it should work, you should set up your firewall again.

  1. UDP-Port 137 (netbios)
  2. UDP-Port 138 (datagram service)
  3. TCP-Port 139 (session service)
  4. TCP-Port 445 (SMB)

Second:

Check your administrative rights with CMD „gpresult /r

Please, check if your administrative user is not restricted by any other group-policy. Maybe you can use another administrative-account to install and then to configure TSM on windows.
 

combato

ADSM.ORG Member
#7
Did you also do this:
https://www.ibm.com/support/knowledgecenter/SSEQVQ_8.1.2/srv.install/t_srv_upgrade_rxa-windows.html

The error you pasted at the beginning also states to check connectivity:
View attachment 1339

Check the RXA log too, should be in "C:\Program Files\Tivoli\TSM"

It's an older technote, but may still apply partially: http://www-01.ibm.com/support/docview.wss?uid=swg21417773


As Plan B, you may try to setup the instance manually instead of through the wizard:
https://www.ibm.com/support/knowled...1.0/srv.install/t_srv_config_man-windows.html

The SMB2 and SMB3 protocols are enabled. The firewall (domain and private) have I set to "off"
The RXA trace log are attached. I can't find why the wizard can't connect to localhost.
 

Attachments

combato

ADSM.ORG Member
#8
Hi combato,

i have got two other approaches, which may lead into problem solution for your situation.

First:

please, can you turn off your firewall temporarily and run through the wizard again?

The reason for turning off the firewall: In the referred IBM-Knowlegdebase-article you mentioned (https://www.ibm.com/support/knowled.../srv.install/t_srv_use_local_wiz-windows.html), they talk from TCP-ports 137 (netbios), 139 (session service) and 445, but port 137 is a UDP-Port. Maybe, it’s a mistake in the knowlegdebase-article. Did you configure your firewall correctly? For testings you can disable your firewall temporarily. If it should work, you should set up your firewall again.

  1. UDP-Port 137 (netbios)
  2. UDP-Port 138 (datagram service)
  3. TCP-Port 139 (session service)
  4. TCP-Port 445 (SMB)

Second:

Check your administrative rights with CMD „gpresult /r

Please, check if your administrative user is not restricted by any other group-policy. Maybe you can use another administrative-account to install and then to configure TSM on windows.
Hi, I have earlier turned the FW off totally to try if this was the case.
I also tried to remove the server from our domain and put it in a workgroup to get rid of all central policies.

Nothing helps o_O
 

Patthecat

Active Newcomer
#10
Hi combato,

i read your first post again and maybe there is a problem with your users. You wrote:
When typing the instance userid (local user I created that is a member of Administrators Group and DB2ADMNS) and a 10 digit and letter password I get: Connection Error: Unable to establish Connection (attached screenshot).
Which user-account do you use when you walk through the wizard? I mean under which user-account are you logged in, when you try to configure the TSM-instance?

For example
You are logged in in Windows with "domain\combato" and try to configure the tsm-instance for "domain\backupinstanceuser".

Next try

Please log out (domain\combato) from Windows Server and login to Windows with your created backup-instance-user for tsm (domain\backupinstanceuser) and run the wizard again.

If this also won't work, then I think you have to deinstall tsm-server-software and try to install new under the context of your backup-instance-user.
 

combato

ADSM.ORG Member
#11
Hi combato,

i read your first post again and maybe there is a problem with your users. You wrote:

Which user-account do you use when you walk through the wizard? I mean under which user-account are you logged in, when you try to configure the TSM-instance?

For example
You are logged in in Windows with "domain\combato" and try to configure the tsm-instance for "domain\backupinstanceuser".

Next try

Please log out (domain\combato) from Windows Server and login to Windows with your created backup-instance-user for tsm (domain\backupinstanceuser) and run the wizard again.

If this also won't work, then I think you have to deinstall tsm-server-software and try to install new under the context of your backup-instance-user.
Hi,
I tried to run the wizard with the instance user I created as is a member of the local Administrator group and DB2ADMNS. I also tried to run the wizard with this account and started the wizard with "Run as Administrator". Nothing helps. Even tried a domain account with local Administrator rights and also joined a local workgroup to get rid of all domain policies. I have now setup the instance manually.

Thanks!
 

ILCattivo

ADSM.ORG Senior Member
#12
Seen this or very similar before myself when running the server config wizard a few times and it's the same old thing every time within Windows (in my experience)!

SEVERE: [127.0.0.1] CTGRI0001E The application could not establish a connection to 127.0.0.1 .
Aug 09, 2017 11:34:29 AM com.ibm.tivoli.remoteaccess.WindowsProtocol RegistryKeyContext
SEVERE: [127.0.0.1] CTGRI0011E An error occurred when accessing the remote registry or service control manager. Hint: Some errors occur due to restrictions imposed by the User Account Control (UAC) settings. Review the UAC settings of the target and disable it.

Disable 'User Access Control' completely is the best option.
 

combato

ADSM.ORG Member
#13
What user shall I use the first time I login to Spectrum Protect CLI? It was a while since last setup I did but I thought it was "admin".
Seen this or very similar before myself when running the server config wizard a few times and it's the same old thing every time within Windows (in my experience)!

SEVERE: [127.0.0.1] CTGRI0001E The application could not establish a connection to 127.0.0.1 .
Aug 09, 2017 11:34:29 AM com.ibm.tivoli.remoteaccess.WindowsProtocol RegistryKeyContext
SEVERE: [127.0.0.1] CTGRI0011E An error occurred when accessing the remote registry or service control manager. Hint: Some errors occur due to restrictions imposed by the User Account Control (UAC) settings. Review the UAC settings of the target and disable it.

Disable 'User Access Control' completely is the best option.
Have done this! :) -Thanks anyway...
 

combato

ADSM.ORG Member
#14
After I now configured everything manually I installed the client 8.1.2 (dsmadmc.exe) and tried to connect to the server. Got SSL problems:

C:\Program Files\Tivoli\TSM\baclient>dsmadmc.exe
IBM Spectrum Protect
Command Line Administrative Interface - Version 8, Release 1, Level 2.0
(c) Copyright by IBM Corporation and other(s) 1990, 2017. All Rights Reserved.

Enter your user id: admin

Enter your password: *****

ANS1592E Failed to initialize SSL protocol.
ANS8023E Unable to establish session with server.
ANS8002I Highest return code was -362.

C:\Program Files\Tivoli\TSM\baclient>

If I read the IBM solution I found this:
ANS1592E Failed to initialize SSL protocol
This error occurs on the client and indicates that the SSL connection was not established. For more information about the failure, see the client error log. The server does not accept SSL sessions on the port to which the client or server is trying to connect. Determine whether the client or server points to the correct server port (TCPPort), which can be a port number that is different from the default 1500.

Does anyone know how to disable SSL or know which port I shall use if not 1500???
 

Advertise at ADSM.ORG

If you are reading this, so are your potential customer. Advertise at ADSM.ORG right now.

UpCloud high performance VPS at $5/month

Get started with $25 in credits on Cloud Servers. You must use link below to receive the credit. Use the promo to get upto 5 month of FREE Linux VPS.

The Spectrum Protect TLA (Three-Letter Acronym): ISP or something else?

  • Every product needs a TLA, Let's call it ISP (IBM Spectrum Protect).

    Votes: 9 22.5%
  • Keep using TSM for Spectrum Protect.

    Votes: 19 47.5%
  • Let's be formal and just say Spectrum Protect

    Votes: 8 20.0%
  • Other (please comement)

    Votes: 4 10.0%

Forum statistics

Threads
31,001
Messages
131,978
Members
21,255
Latest member
pzzl321
Top