1. Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING) Click the link to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This message will disappear after you have made at least 12 posts. Thank you for your cooperation.

Backup is not encrypted - how to enable encryption

Discussion in 'TSM Security and Regulatory Compliance' started by publiclists, Sep 4, 2011.

Thread Status:
Not open for further replies.
  1. publiclists

    publiclists New Member

    Joined:
    Sep 2, 2011
    Messages:
    3
    Likes Received:
    0
    Hi,

    I am backing up linux servers with TSM 6.2. Therefore I am using a script with the dsmc i command, executed by a cronjob. Everything works fine.

    I am now trying to encrypt the backups. It seems, this does not work. I am only asked once to enter an encryption password after a reboot of the server. When using tshark to check the transferred data it is NOT encrypted. When tying to recover a file I am not asked for the encryption password.

    Are there any hints how to get a clou what could be wrong? Here are my config files (dsm.sys and inclexcl.txt)

    SErvername XXX
    COMMMethod TCPip
    TCPPort 1680
    TCPServeraddress XXX.domain.com
    ENCRYPTKey prompt
    ENCRYPTIONType AES128

    NODename YYY

    INCLExcl /opt/tivoli/tsm/client/ba/bin/inclexcl.txt

    ---

    include.encrypt /
    include /
    exclude.dir /dev
    exclude.dir /dev/shm
    exclude.dir /lib/init/rw
    exclude.dir /proc
    exclude.dir /tmp

    Thanks a lot!
     
  2.  
  3. domino

    domino Senior Member

    Joined:
    Nov 16, 2005
    Messages:
    716
    Likes Received:
    32
    Occupation:
    System Engineer
    Location:
    Germany
    The backup is running as root (or autorized user)?

    ...
    include.encrypt /
    include /
    ...

    delete (or rem) the 2nd entry

    ...
    include.encrypt /
    * include /
    ...
     
  4. publiclists

    publiclists New Member

    Joined:
    Sep 2, 2011
    Messages:
    3
    Likes Received:
    0
    Hi,

    thanks for your quick response. I think I got it - I changed the lines

    include.encrypt /
    include /

    to

    include.encrypt *
    include *

    Maybe the second line is not necessary? I just read before that you need both lines to declare what to backup in general and what to encrypt in special.
     
  5. domino

    domino Senior Member

    Joined:
    Nov 16, 2005
    Messages:
    716
    Likes Received:
    32
    Occupation:
    System Engineer
    Location:
    Germany
    use only

    include.encrypt *
     
  6. publiclists

    publiclists New Member

    Joined:
    Sep 2, 2011
    Messages:
    3
    Likes Received:
    0
    Perfect, works - thanks!
     
: encryption
Thread Status:
Not open for further replies.

Share This Page