1. Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING) Click the link to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This message will disappear after you have made at least 12 posts. Thank you for your cooperation.

ANR8779E Unable to open drive MT4.1.0.2, error number=1

Discussion in 'Tape / Media Library' started by zeebs2003, Apr 21, 2008.

  1. zeebs2003

    zeebs2003 New Member

    Joined:
    Jul 21, 2004
    Messages:
    14
    Likes Received:
    0
    hey I'm getting the following error when trying to add a drive from an EDL.
    I'm running windows 2003. The library and drives show up in device manager, but when I try to add a path I ge the following.

    04/21/2008 13:52:44 ANR2017I Administrator SCOTTZ issued command: DEFINE PATH
    LXW2KBKUP_SERVER1 LXDRIVE1 SRCTYPE=SERVER DESTTYPE=DRIVE
    LIBRARY=LXEDL1 DEVICE=mt4.1.0.2 ONLINE=YES AUTODETECT=YES
    (SESSION: 729)
    04/21/2008 13:52:44 ANR8779E Unable to open drive MT4.1.0.2, error number=1.(-
    SESSION: 729)
    04/21/2008 13:52:44 ANR8420E DEFINE PATH: An I/O error occurred while
    accessing drive LXDRIVE1.(SESSION: 729)
     
  2.  
  3. wim

    wim Senior Member

    Joined:
    Aug 14, 2007
    Messages:
    208
    Likes Received:
    2
    Hi,

    error number 1 indicates "incorrect function". It seems there is miscommunication between drive and device driver.

    Are you using the correct drivers for the library and tape drives? Check http://www-306.ibm.com/software/sysm...XHPSUNWIN.html
    If IBM tape drives are installed in the library, use the IBM tape driver, else the TSM device driver.

    Regards. Wim
     
  4. GavinR

    GavinR New Member

    Joined:
    Jun 15, 2007
    Messages:
    3
    Likes Received:
    1
    We have had the following advice from EMC (untried):

    This is a known issue on x64 Windows. If you downloaded the full LTO
    driver x64 installation package (
    ftp://ftp.software.ibm.com/storage/devdrvr/Windows/Win2003/Latest/IBMTape.x64_6184.zip ) that you have to "Install" rather than just doing an
    "Update Drivers" from Device Manager then there are a couple of
    additional steps. In the "/reg" directory of the LTO kit you have to run
    both disablecpf and disabledpf then reboot in order for the tape paths
    to appear.
    ftp://ftp.software.ibm.com/storage/devdrvr/Windows/Win2003/Latest will
    give you the binaries for the other windows versions...
     
    zeebs2003 likes this.
  5. zeebs2003

    zeebs2003 New Member

    Joined:
    Jul 21, 2004
    Messages:
    14
    Likes Received:
    0
    I got the drives added after disablecpf and disabledpf were run, but now I'm trying to label some tapes in the EDL and get the following error.

    ANR8847E No 3592-type drives are currently available in
    library LXEDL1.(SESSION: 1573, PROCESS: 24)




    04/23/2008 08:07:13 ANR2017I Administrator SCOTTZ issued command: LABEL libv
    lxedl1 search=y labels=barcode overwrite=y checkin=scrat-
    ch (SESSION: 1573)
    04/23/2008 08:07:13 ANR0984I Process 24 for LABEL LIBVOLUME started in the
    BACKGROUND at 08:07:13.(SESSION: 1573, PROCESS: 24)
    04/23/2008 08:07:13 ANR8799I LABEL LIBVOLUME: Operation for library LXEDL1
    started as process 24.(SESSION: 1573, PROCESS: 24)
    04/23/2008 08:07:13 ANR0609I LABEL LIBVOLUME started as process 24.(SESSION:
    1573, PROCESS: 24)
    04/23/2008 08:07:13 ANR0405I Session 1573 ended for administrator SCOTTZ
    (WebBrowser).(SESSION: 1573)
    04/23/2008 08:07:14 ANR8847E No 3592-type drives are currently available in
    library LXEDL1.(SESSION: 1573, PROCESS: 24)
     

Share This Page