nv-l

RESOLVED: Reinstalling TMNH - LCF Images Installed

2001-07-20 08:47:30
Subject: RESOLVED: Reinstalling TMNH - LCF Images Installed
From: Jane Curry <jane.curry AT skills-1st.co DOT uk>
To: nv-l AT lists.tivoli DOT com
Date: Fri, 20 Jul 2001 13:47:30 +0100
OK - I seem to have hacked a way around this.  The steps are:
1) Copy the TMNH CD onto disk using wcpcdrom
2) Backup and then modify the .IND file for the gateway - NETINVGW.IND - it
suffers from the same installation problem as NetView, documented in IY18735
3) Change line 13 with blah....:id:LCF:....................... such that the
end of the line reads
                            [email protected]@;Place=holder;:
rather than            [email protected]@;:
4) Line 14 may also need changing (the one with
blah....:fp:LCF:generic:reinstall.now:...)
5) The "reinstall.now" bit says to check a file of this name to determine
whether code needs installing - this is what was preventing the reinstall of
the LCF parts - I understand from one of Orb Data's hints that this usage is
now deprecated in favour of checking files in ".installed" directories
(thanks Orb!).  I changed this so that the line looked like
    blah...:fp:LCF:generic::53043:89
6) Having changed the reinstall.now bit, I found that the BIN elements didn't
think they need installing now! (I think I had removed all the .installed
files...).  So, I put line 14 exactly back as was and the whole install, LCF
and BIN parts, went through OK.
7) Before each reinstall, I went back to a database backup priot to the first
TMNH install and cleared out all TMNH files in all .installed files.

Cheers,
Jane

Jane Curry wrote:

> I'll preface this with "I know TMNH has been withdrawn, and it won't be
> supported with Framework 3.7.1, but ........."
>
> AIX 4.3.3 TMR Server with FW 3.7.1 plus patches 1 2 3 7 10.
>
> Installation of the Tivoli Manager for Network Hardware Gateway 2.2
> failed - I think it may be suffering from the same documented problem
> with installing NetView on FW 3.7.1 whereby a parameter substitution
> goes wrong and an extra space gets added to one of the variables in the
> installation script (see IY18735 for details).
>
> I think I have fixed the index file and am trying to uninstall /
> reinstall TMNH gateway.  My problem is that whatever I do, an install
> always insists that the LCF images are already installed (it was in the
> LCF area that the initial install failed).
>
> I have reverted to a database backup prior to the TMNH install and
> eliminated all traces of the product in all .installed directories
> (there weren't any entries to do with TMNH in the .installed directory
> under lcf-bundle !).  I'm reinstalling using CLI with "!" overwrite
> options for all directories (but there is no LCF directory option ??).
>
> How can I persuade a reinstall to reinstall the LCF bundle parts?
>
> Thanks,
> Jane
> --
> Tivoli Certified Enterprise Consultant & Instructor
> Skills 1st Limited, 2 Cedar Chase, Taplow, Bucks, SL6 0EU, UK
> Tel: +44 (0)1628 782565
> Copyright (c) 2001 Jane Curry <jane.curry AT skills-1st.co DOT uk>.  All 
> rights
> reserved.
>
> _________________________________________________________________________
> NV-L List information and Archives: http://www.tkg.com/nv-l

--
Tivoli Certified Enterprise Consultant & Instructor
Skills 1st Limited, 2 Cedar Chase, Taplow, Bucks, SL6 0EU, UK
Tel: +44 (0)1628 782565
Copyright (c) 2001 Jane Curry <jane.curry AT skills-1st.co DOT uk>.  All rights
reserved.


<Prev in Thread] Current Thread [Next in Thread>
  • RESOLVED: Reinstalling TMNH - LCF Images Installed, Jane Curry <=