nv-l

Re: Netview RIM problems, using Oracle DB with other that US7 NLS char set I?

1999-11-24 19:00:15
Subject: Re: Netview RIM problems, using Oracle DB with other that US7 NLS char set I?
From: sopee AT WMDATA DOT DK
To: nv-l AT lists.tivoli DOT com
Date: Thu, 25 Nov 1999 01:00:15 +0100

Hi,

Thank you for your input, I have tried to add the NLS_LANG environment var to my
Tivoli environment, with little success.

Regards,

Soren





"Smeriglio,Luca,VEVEY,FC-SIL/INF." <Luca.Smeriglio AT NESTLE DOT COM> on 
16-11-99
15:56:43

Please respond to Discussion of IBM NetView and POLYCENTER Manager on NetView
      <NV-L AT UCSBVM.UCSB DOT EDU>

To:   NV-L AT UCSBVM.UCSB DOT EDU
cc:    (bcc: Søren Bonde Pedersen/BFC-DATA)
Subject:  Re: Netview RIM problems,              using Oracle DB with other that
      US7 NLS char set I?


Hi, I have the EXACT SAME PROBLEM (ORA-01461 error)

Except that I'm configuring the TEC and not Netview.

I'm running the SqlPlus client 8.1.5 on AIX 4.3.3.
When I'm connecting to a 8.1.5 Oracle Server this error appears, but
everything works fine with a server running 8.0.4

Like you, I'm suspecting this is related to the NLS_LANG setting.
You can check your environment (and change it) with :
1/ odadmin environ get >toto.txt
2/ edit toto.txt
3/ odadmin environ set <toto.txt
4/ restart the dispatcher ( /etc/Tivoli/oserv.rc restart )

(you'll need correct TMR roles to do that)

I tried different variable settings without success unfortunately.

The good news is that Dave Scarr from Tivoli (Level2 support) is aware of
that
problem and he is already working on it.
Best thing to do (following his advice) is to open a PMR via your IBM Single
Point of Contact, and put DSTIV in the PMR ENV field.

I will keep you (and the list) updated.
For info, the Tivoli mailing-list are following that problem too.

Cheers,
Luca
               ``
              (o o)
 ----------oOO-(_)-OOo----------
         Luca Smeriglio
          Operating Systems & Networks
         NESTEC SA - Vevey Switzerland
    TEL ++41 21 924.26.53 / FAX 924.45.89
 -------------------------------



> -----Original Message-----
> From: sopee AT WMDATA DOT DK [SMTP:sopee AT WMDATA DOT DK]
> Sent: Monday, November 15, 1999 10:41 AM
> Subject:      Netview RIM problems, using Oracle DB with other that US7
> NLS char set I?
>
> I?m running Netview 5.1.1 (Framework 3.6) on AIX 4.3.2. We are currently
> working
> on making the applications in our FM center highly available. One of the
> steps
> that we are taking, besides from HACMP, is to move Netview to a DB
> platform.
>
> The Environment:
>        AIX 4.3.2
>        Oracle 8.0.5
>        Netview 5.1.1
>        Framework 3.6
>
> When I create the DB with a NLS character set, other than the default
> (US7), I
> am unable to do the conversion from the flat files to the DB using the
> ovtopoconv -R -v command. The only error description that I get is "Unable
> to
> update topology tables". There is no relevant information in the dbtrace
> and
> dblog, even when full tracing turned on. Then I tried to run a full RIM
> trace.
> The trace returns the following error codes:
>
> --------------------------------------------------------------------------
> ------------------------------------------------------------
> 00023300 [Sun Nov 14 08:02:46 1999] Trace Message - Connection ID::
> IOM Command: INSERT
> row_param: <NULL>
> rows: No. of Rows: 1
> First Row : Table Name : topoinfo Columns:
>         objid(S): 1014
>         ctime(D): 1999.11.14 02:52:49
>         mtime(D): 1999.11.14 07:54:54
>         stime(D): 1999.11.14 02:52:49
>         flags(L): 0
>         gwcnt(L): 21
>         nnmtype(L): 0
>         topm_network_ct(L): 80
>         topm_segment_ct(L): 85
>         topm_node_ct(L): 85
>         topm_interface_ct(L): 162
>         scale_x(L): 0
>         scale_y(L): 0
>         extra0(L): 0
>         extra1(L): 0
>
> SQL Command: insert into topoinfo (objid, ctime, mtime, stime, flags,
> gwcnt, nnm
> type, topm_network_ct, topm_segment_ct, topm_node_ct, topm_interface_ct,
> scale_x
> , scale_y, extra0, extra1) values (:objid, TO_DATE('1999.11.14 02:52:49',
> 'YYYY.
> MM.DD HH24:MI:SS'), TO_DATE('1999.11.14 07:54:54', 'YYYY.MM.DD
> HH24:MI:SS'), TO_
> DATE('1999.11.14 02:52:49', 'YYYY.MM.DD HH24:MI:SS'), :flags, :gwcnt,
> :nnmtype,
> :topm_network_ct, :topm_segment_ct, :topm_node_ct, :topm_interface_ct,
> :scale_x,
>  :scale_y, :extra0, :extra1)
>         ORA-01461: can bind a LONG value only for insert into a LONG
> column
>
> 00023300 [Sun Nov 14 08:02:46 1999] Trace Message - Connection ID:: The
> RDBMS se
> rver failed to parse a SQL command string.
> The operation was:  ORALIB:oexec
> The RDBMS server call's return code was:  0
> The SQL command string was:
>     <insert into topoinfo (objid, ctime, mtime, stime, flags, gwcnt,
> nnmtype, to
> pm_network_ct, topm_segment_ct, topm_node_ct, topm_interface_ct, scale_x,
> scale_
> y, extra0, extra1) values (:objid, TO_DATE('1999.11.14 02:52:49',
> 'YYYY.MM.DD HH
> 24:MI:SS'), TO_DATE('1999.11.14 07:54:54', 'YYYY.MM.DD HH24:MI:SS'),
> TO_DATE('19
> 99.11.14 02:52:49', 'YYYY.MM.DD HH24:MI:SS'), :flags, :gwcnt, :nnmtype,
> :topm_ne
> twork_ct, :topm_segment_ct, :topm_node_ct, :topm_interface_ct, :scale_x,
> :scale_
> y, :extra0, :extra1) >
> The error was at offset:  0
>
> --------------------------------------------------------------------------
> ------------------------------------------------------------
>
> As you can see in the trace above, there is an error when doing the
> insert. The
> error describes that an attempt has been made to insert a long field into
> another type of field, witch doesn?t make a lot on sense.
>
> As I mentioned there is no problem when running Oracle with the default
> NLS char
> set US7. Could the problem be related to some missing environment in the
> RIM
> setup ?
>
> Any suggestions will be appreciated.
>
> Regards
>
> S. Bonde Pedersen
> Systems Management WM-data/Denmark
>