nv-l

Re: [nv-l] ovtopmd will not start - new install

2004-07-21 03:32:25
Subject: Re: [nv-l] ovtopmd will not start - new install
From: Oliver Bruchhaeuser <oliver.bruchhaeuser AT de.ibm DOT com>
To: nv-l AT lists.us.ibm DOT com
Date: Wed, 21 Jul 2004 09:09:47 +0200

----------------------
DCF Document ID: 1168045 - IBM Tivoli NetView: ovtopmd exit code 255 - Tivoli Framework at 4.1.1 level
Problem Desc:  The following messages result from attempting to start the ovtopmd daemon in a Framework 4.1.1 environment: The messages will also be presented in response to the "ovstatus ovtopmd" command from the command line. object manager name: ovtopmd behavior: OVs_WELL_BEHAVED state: NOT_RUNNING PID: ###### last message: exit status: exit(255) Note: If the failure is during installation, the messages can be found in the /tmp/update.log.
 
Solution:  Perform the following steps to determine if the cause is one or more missing shared libraries. Missing means unavailable to ovtopmd at the time of error.
Note: references to $LIBPATH mean $LIBPATH or $LD_LIBRARY_PATH (Solaris and Linux)
1. If the error is during installation, continue problem determination at the point of failure.
2. Make sure all daemons are down, and all other NetView started processes.
3. Source the Tivoli environment.
5. echo $LIBDIR, and $LIBPATH
6. verify that $LIBDIR contains shared libraries, and verify that $LIBPATH contains $LIBDIR
7. ovstart -v ovtopmd. This should fail in the same way.
8. verify that prereq daemons are still up: ovspmd, nvsecd, ovwdb, pmd, trapd
9. run ovtopmd in the foreground from the command line, /usr/OV/bin/ovtopmd (notice this is not ovstart ovtopmd)
10. observe error messages (AIX shown, others similar):
exec(): 0509-036 Cannot load program ovtopmd because of the following errors:
0509-150 Dependent module libtmf.a(shr.o) could not be loaded.
0509-022 Cannot load module libtmf.a(shr.o).
0509-026 System error: A file or directory in the path name does not exist.
11. verify that libtmf.a (or the missing library in the messages) is not in $LIBDIR

Since $LIBDIR has been verified to contain shared libraries, and Framework has been verified to be at the 4.1.1 level, then a Framework patch installation is required to install downward compatibility libraries.

Install Tivoli Framework Patch 4.1.1-TMF-0003 in order to restore the missing libraries.
----------------------

Oliver


"Davis, Donald" <donald.davis AT firstcitizens DOT com>
Sent by: owner-nv-l AT lists.us.ibm DOT com

20.07.2004 21:20
Please respond to
nv-l

To
nv-l AT lists.us.ibm DOT com
cc
Subject
[nv-l] ovtopmd will not start - new install





Is it just me or has anyone else experienced this with a new server?

AIX 5.2 ML02 32bit

TMF 4.1.1

NetView 7.1.4

 

Pristine Install of all software.

All NetView prerequisites satisfied.

 

NetView installation fails due to ovtopmd not starting (255).

Manually executing ovtopmd from the command line yielded missing lib filesets

 

I had to manually copy the following files from the NetView CDROM into $LIBDIR

libtmf.a

librim.a

libtas.a

libdes.a

 

This file from another TMF 3.7.1 server.

libthreads.a    

 

Then, uninstnv and reinstall was successful.

 

Frustratingly yours,

Don Davis

------------------------------------------------------------------------------
This electronic mail and any files transmitted with it are confidential and are intended solely for the use of individual or entity to whom they are addressed. If you are not the intended recipient or the person responsible for delivering the electronic mail to the intended recipient, be advised that you have received this electronic mail in error and that any use, dissemination, forwarding, printing, or copying of this electronic mail is strictly prohibited. If you have received this electronic mail in error, please immediately notify the sender by return mail.
==============================================================================

<Prev in Thread] Current Thread [Next in Thread>