nv-l

RE: How to find and recognise already discovered devices!! !

2000-06-08 23:12:58
Subject: RE: How to find and recognise already discovered devices!! !
From: lclark AT us.ibm DOT com
To: nv-l AT lists.tivoli DOT com
Date: Thu, 8 Jun 2000 23:12:58 -0400
First, I don't have a Netview for NT to look at this week. If you
bring up the server configuration dialog and look, I think under
discovery options, you should see an option regarding logging.
Second, when you turn it off, nothing happens except that it
quits writing to that log. You will probably have repeats in it
after a while. Then you use the information in that log to
update \usr\ov\conf\oid_to_type. You may have to stop
and start the daemons for the changes to be recognized.

If you want the vendor and agent fields to be set correctly
at the same time, make sure you enter vendors and agents
in the oid_to_type file, and that they exactly match vendors
and agents already known to Netview. They are listed in
\usr\ov\fields\c\ovw_fields (vendors) and \usr\ov\fields\C\snmp_fields
(agents). After changes to these files it is necessary to run
the command ovw_fields (I think that's what it is on NT).
Then stop netmon, delete the nodes in that Badoids smartset
(the creation of that smartset may also be optional), close the map,
stop all daemons, start all daemons, and open the map. When the
nodes are rediscovered, they will have not only the correct oids, but
will also have the vendor and agent fields set. These fields can
be useful for making Smartsets.

Cordially,

Leslie A. Clark
IBM Global Services - Systems Mgmt & Networking
(248) 552-4968 Voicemail, Fax, Pager

---------------------- Forwarded by Leslie Clark/Southfield/IBM on
06/08/2000 11:01 PM ---------------------------

"Sharma, Sanjeev" <Sanjeev.Sharma AT usa.xerox DOT com>@tkg.com on 06/08/2000
04:34:36 PM

Please respond to IBM NetView Discussion <nv-l AT tkg DOT com>

Sent by:  owner-nv-l AT tkg DOT com


To:   IBM NetView Discussion <nv-l AT tkg DOT com>
cc:
Subject:  RE: [NV-L] How to find and recognise already discovered devices!!
      !



Hi Clark
Thanks for such a nice clarifications. Tell me one thing you mentioned
about
the creation of this badoids.log file on demand. Could you please tell me
that command or option to enable this logging.
Second what will happen on first time when netmon run without that command
or in other words we don't have anything in that file(badoids.log).
What do anyone do to filter out already discovered specific devices of his
interest.
Please help me. Thanks afor your time.

regards
sanjeev sharma
-----Original Message-----
From: lclark AT us.ibm DOT com [mailto:lclark AT us.ibm DOT com]
Sent: Thursday, June 08, 2000 3:29 PM
To: NV-L AT tkg DOT com
Subject: Re: [NV-L] How to find and recognise already discovered
devices!!!




Sanjeev, this is what we call a feature. The intent is to allow the
creation
of a Smartset based on these bogus oids, as a to-do list for you. To help
you out, they also created a log file with the real informaition in it
(badoids.log?) that is almost in the form you would use to update the
oid_to_type file. I had the same reaction you did, at first.  But they are
trying to help, really! The log may only be created on demand, as an
option on netmon, I think.

Cordially,

Leslie A. Clark
IBM Global Services - Systems Mgmt & Networking
Detroit
---------------------- Forwarded by Leslie Clark/Southfield/IBM on
06/08/2000 03:26 PM ---------------------------



"Sharma, Sanjeev" <Sanjeev.Sharma AT usa.xerox DOT com>@tkg.com on 06/08/2000
01:15:29 PM


Please respond to IBM NetView Discussion <nv-l AT tkg DOT com>

Sent by:  owner-nv-l AT tkg DOT com


To:   IBM NetView Discussion <nv-l AT tkg DOT com>
cc:

Subject:  [NV-L] How to find and recognise already discovered devices!!!
Importance:    Urgent




Hi all
I noticed one strange behaviour in NetView on WinNT4.0. If the device
sysobjID is not defined in the oid_to_type  and oid_to_sym files, Tivoli
stored those devices as a generic device with generic icons or with
connector icons.
If you select those device and go to the proerties, click on other tab, and
see Object ID value display is either
1.3.6.1.4.1.3.1.1.98
1.3.6.1.4.1.3.1.1.99.
Why did they display wrong sysobjectID of the device? It is different from
actual sysobjID of the device.

I want to search all my specific device before installing my solution with
NetView. Can you suggest me any way to do it? I am not going to search all
the devices with these two OID and than send snmp get request to each
device
to get the actual SysobjID and manipulate in my code.

I saw these two statements in oid_to_sym file:
1.3.6.1.4.1.3.1.1.98:Connector:Unknown          # IBM/NetView (symbol for
any IP forwarding node with an unknown sysObjectId)
1.3.6.1.4.1.3.1.1.99:Computer:Unknown           # IBM/NetView (symbol for
any node with an unknown sysObjectId)

Would you please give me some clue b'cos i think it is very common problem.
Thanks in advance. Looking forward to hear from you.

Sanjeev K. Sharma
Phone: (716) 231-8388
Fax:(716) 422-6651

_________________________________________________________________________
NV-L List information and Archives: http://www.tkg.com/nv-l


_________________________________________________________________________
NV-L List information and Archives: http://www.tkg.com/nv-l
_________________________________________________________________________
NV-L List information and Archives: http://www.tkg.com/nv-l