nv-l

RE: Unable to Demand Poll

2000-05-04 10:23:57
Subject: RE: Unable to Demand Poll
From: lclark AT us.ibm DOT com
To: nv-l AT lists.tivoli DOT com
Date: Thu, 4 May 2000 10:23:57 -0400
....And the most usual thing is that netmon is busy doing its startup
stuff. The window comes up with the hourglass, but no results. To
verify that it is just netmon being busy, go to a commandline and
do 'netmon -a 3' and check /usr/OV/log/netmon.trace. If netmon
is too busy, it won't dump it's ping schedule. Wait a while and try
again.

Cordially,

Leslie A. Clark
IBM Global Services - Systems Mgmt & Networking
Detroit

---------------------- Forwarded by Leslie Clark/Southfield/IBM on
05/04/2000 10:21 AM ---------------------------

James_Shanks AT tivoli DOT [email protected] on 05/03/2000 11:01:41 PM

Please respond to IBM NetView Discussion <nv-l AT tkg DOT com>

Sent by:  owner-nv-l AT tkg DOT com


To:   IBM NetView Discussion <nv-l AT tkg DOT com>
cc:
Subject:  RE: [NV-L] Unable to Demand Poll





Demand poll is a complex process and there are several places it could go
wrong,
but you have to start by telling us exactly where and how it fails.  Does
the
window open from the GUI?  That has to happen first.  If not, try running
nmdemandpoll from the command line (the man page will tell you how) and see
if
that works.  If so, then you may have an X-resource problem or you may need
to
make sure that you have issued the ulimit commands before running the GUI
to
remove any artificial limits on what your user id can do.  If the window
starts,
but nothing comes in it, then you should probably  look elsewhere.  When
you
select a node and then click "demand poll" that starts an xnmappmon
process,
which sends a trap to trapd with the name of the node in it to be demand
polled.
This trap is sent by trapd to netmon, who does the operation, and sends the
results back to xnmappmon for display.  If the window opens, can you see
the
trap in the trapd.log?   One of the things that can go wrong here is that
demand
poll will hang in the middle of a "trap storm" when traps are coming in at
a
high rate.  You might look at trapd.log to determine that, though at really
high
rates trapd will be unable to process any traps, only queue them, and you
won't
see that unless you turn on the trapd.trace (issue trapd -T from the
command
line to toggle the trace on or off).  Finally, if you see the trap, then
you
will have to turn on the netmon trace to see what netmon does when he
receives
it (netmon -M 31).

If all this makes you uncomfortable, then I would call Support and get some
help.

But I don't see that set community strings have anything to do with demand
poll.
The code most definitely does not use anything but the read string.  You
should
be able to get the same results yourself with snmpget that netmon gets when
he
does it.

James Shanks
Tivoli (NetView for UNIX and NT) L3 Support


Michael Kelly <Michael.Kelly AT sysnet-solutions DOT com> on 05/03/2000 08:29:41
PM

Please respond to IBM NetView Discussion <nv-l AT tkg DOT com>

To:   "'IBM NetView Discussion'" <nv-l AT tkg DOT com>
cc:    (bcc: James Shanks/Tivoli Systems)
Subject:  RE: [NV-L] Unable to Demand Poll




Verify the SNMP community (especially set) strings are set correctly.

On 03 May, 2000 19:12, Jean.M.SCHMIDT AT odot.state.or DOT us
[SMTP:Jean.M.SCHMIDT AT odot.state.or DOT us] wrote:
> I am running NV 5.1.0 on AIX 4.3.1.  I am not able to demand poll any
> devices on my network, therefore not able to collect any data. However, I
> can ping all of them. All daemons are running, no errors in logs, plenty
of
> free space. Any suggestions?
>
> Jean Schmidt
> ODOT Network Management
> 503 986-3245
> jean.m.schmidt AT odot.state.or DOT us
>
> _________________________________________________________________________
>
> NV-L List information (unsubscribing, policies, posting, digest version,
> searchable archives): http://www.tkg.com/nv-l


(See attached file: att1.htm)

Verify the SNMP community (especially set) strings are set correctly.

On 03 May, 2000 19:12, Jean.M.SCHMIDT AT odot.state.or DOT us [SMTP:Jean.M.SCHMIDT AT odot.state.or DOT us] wrote:
> I am running NV 5.1.0 on AIX 4.3.1.  I am not able to demand poll any
> devices on my network, therefore not able to collect any data. However, I
> can ping all of them. All daemons are running, no errors in logs, plenty of
> free space. Any suggestions?
>
> Jean Schmidt 
> ODOT Network Management
> 503 986-3245
> jean.m.schmidt AT odot.state.or DOT us
>
> _________________________________________________________________________
>
> NV-L List information (unsubscribing, policies, posting, digest version,
> searchable archives): http://www.tkg.com/nv-l

<Prev in Thread] Current Thread [Next in Thread>