1. Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING) Click the link to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This message will disappear after you have made at least 12 posts. Thank you for your cooperation.

VM restore as thin-provisioned disk?

Discussion in 'VMWare / Virtual Machine' started by Spree, Aug 22, 2012.

Thread Status:
Not open for further replies.
  1. Spree

    Spree New Member

    Joined:
    Jan 17, 2012
    Messages:
    8
    Likes Received:
    0
    Not sure if anyone tried this. I am testing full VM restore, by default, the VMDK will be restored as thick-provisioned. According to an IBM technote (http://www-01.ibm.com/support/docview.wss?uid=swg21508259) there is a testflag (VMRESTOR_DONT_FORCE_THICK) which can be specified making the VMDK restore as thin-provisioned. But I could not get this working. I am not a VMware expert and not sure if anything gone wrong.

    Environment:
    vSphere: 5.0 build 623860
    TSM server: 6.3.1.0 / Windows 2008 R2
    TSM client: 6.3.0.15 / Windows 2008 R2

    VMware transport is NBD only.

    This parameter (VMRESTOR_DONT_FORCE_THICK) could not be specified in the TSM client options file, so I suppose this is used in VM's settings. The only place that I found for specifying parameters for a VM is "Edit Settings" => "Options" tab => "Advanced" => "General" => "Configuration Parameters". I tried specifying only the parameter name (VMRESTOR_DONT_FORCE_THICK) without a value, as well as adding "true" as the value, but both didn't work. I do this before running a VM backup, but both restored as thick-provisioned disk only.

    Any suggestions? Thanks.
     
  2.  
  3. dbias1601

    dbias1601 New Member

    Joined:
    May 29, 2012
    Messages:
    32
    Likes Received:
    2
    How did you try and specify this in the dsm.opt? I think the correct syntax would be:

    TESTFLAG VMRESTOR_DONT_FORCE_THICK

    alternatively you could try:

    dsmc i -testflag=VMRESTOR_DONT_FORCE_THICK
     
    Spree likes this.
  4. Spree

    Spree New Member

    Joined:
    Jan 17, 2012
    Messages:
    8
    Likes Received:
    0
    Thanks, I think I misunderstood the technote. I will try.
     
  5. Spree

    Spree New Member

    Joined:
    Jan 17, 2012
    Messages:
    8
    Likes Received:
    0
    It seems it is not valid... but I am already using the latest client (6.3.0.15).

    ANS1036S The option 'TESTFLAG' or the value supplied for it is not valid. It was found in options file 'C:\Program Files\Tivoli\TSM\baclient\dsm.opt' at line number: 44
    The complete entry: 'TESTFLAG VMRESTOR_DONT_FORCE_THICK'
     
  6. dbias1601

    dbias1601 New Member

    Joined:
    May 29, 2012
    Messages:
    32
    Likes Received:
    2
    Perhaps attempt from the command line?

    From the command line browse to the ba client directory:

    C:\Program Files\Tivoli\TSM\baclient> dsmc backup vm 'myvm' -testflag=VMRESTOR_DONT_FORCE_THICK
     
  7. Spree

    Spree New Member

    Joined:
    Jan 17, 2012
    Messages:
    8
    Likes Received:
    0
    Not work either. Same message as above, can't understand why.
     
  8. tobi007

    tobi007 New Member

    Joined:
    Mar 6, 2009
    Messages:
    21
    Likes Received:
    0
    Location:
    Germany
    The following settings works fine to restore the vm with thin provisioned vmdk┬┤s:

    TSM-BAclient: 6.3.0.16
    vSphere 5 U1

    dsm.opt
    VMBACKUPTYPE FULLVM
    VMFULLTYPE VSTOR
    VMVSTORTRANSPORT HOTADD
    VMCHOST xyz.domain.local
    VMCUSER xyz
    VMCPW ****
    testflag VMRESTORE_DONT_FORCE_THICK

    Maybe you have to do a new backup to save attribute with information about the disk format.
     
  9. tobi007

    tobi007 New Member

    Joined:
    Mar 6, 2009
    Messages:
    21
    Likes Received:
    0
    Location:
    Germany
    You forgot an "E" in the parameter 'TESTFLAG VMRESTORE_DONT_FORCE_THICK'
    ^
     
  10. Spree

    Spree New Member

    Joined:
    Jan 17, 2012
    Messages:
    8
    Likes Received:
    0
Thread Status:
Not open for further replies.

Share This Page