• Please help support our sponsors by considering their products and services.
    Our sponsors enable us to serve you with this high-speed Internet connection and fast webservers you are currently using at ADSM.ORG.
    They support this free flow of information and knowledge exchange service at no cost to you.

    Please welcome our latest sponsor Tectrade . We can show our appreciation by learning more about Tectrade Solutions
  • Community Tip: Please Give Thanks to Those Sharing Their Knowledge.

    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.

  • Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)

    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

Upgrade from 6.1.3.3 to 6.2.2.2 - license problem

Kif

Active Newcomer
Joined
May 12, 2011
Messages
6
Reaction score
0
Points
0
Hello,

last week I performed an upgrade of TSM server from version 6.1.3.3 to 6.2.2.2
I have downloaded 6.2.2.2 version from IBM site, followed steps and successfully upgraded TSM server to latest version. The problem now is that I cannot register licenses on server.

The error I get is "ANR9638W License registration is not supported on this server".
I did the reasearch on that error and upon checking licesing files I have discovered that file adsmlicn.dll is still the old version 6.1.3.9350, the rest of the licesing files (tsmbasic.lic, tsmee.lic, dataret.lic) I have got from installation folder of 6.2.2.2 version, but the main .dll file is nowhere to be found.

If I understood correctly, I would neeed this file from version 6.2.0.0 and this file only comes in base installation of 6.2.0.0, not in interim fixes which you can donwload from IBM site. The thing is I do not have base installation of 6.2.0.0, I have base installation 6.1.3.0

So, to sum this up, am I correct to hink that acquiring this file (somehow) from base version of 6.2.0.0 will solve all my problems ?

Thank you very much in advance.

Kind regards,

Kif​
 

yuki

ADSM.ORG Member
Joined
Jun 30, 2004
Messages
79
Reaction score
3
Points
0
Location
Finland
Website
Visit site
Hi,

Installation packages downloaded from IBM's ftp site are fully functional, but licenses are not there.
You have understood correctly, you have to get installation media from IBM. If your TSM support is valid, you have access to download correct media.

After that replace adsmlicn.dll with newer one found from media.
 

Kif

Active Newcomer
Joined
May 12, 2011
Messages
6
Reaction score
0
Points
0
Thank you for confirmation.
Client has support, so we downloaded base version 6.2 from IBM site and replaced adsmlicn.dll file.
Afterwards register license command is fully functional. :)

Cheers
 

Advertise at ADSM.ORG

If you are reading this, so are your potential customer. Advertise at ADSM.ORG right now.

UpCloud high performance VPS at $5/month

Get started with $25 in credits on Cloud Servers. You must use link below to receive the credit. Use the promo to get upto 5 month of FREE Linux VPS.

The Spectrum Protect TLA (Three-Letter Acronym): ISP or something else?

  • Every product needs a TLA, Let's call it ISP (IBM Spectrum Protect).

    Votes: 18 18.4%
  • Keep using TSM for Spectrum Protect.

    Votes: 60 61.2%
  • Let's be formal and just say Spectrum Protect

    Votes: 12 12.2%
  • Other (please comement)

    Votes: 8 8.2%

Forum statistics

Threads
31,738
Messages
135,301
Members
21,739
Latest member
RGPTSM01
Top