1. Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING) Click the link to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This message will disappear after you have made at least 12 posts. Thank you for your cooperation.

Removing Cleaning Cartridges

Discussion in 'Administrative Client' started by CHOWEG, Mar 12, 2009.

  1. CHOWEG

    CHOWEG New Member

    Joined:
    Mar 12, 2009
    Messages:
    5
    Likes Received:
    0
    Occupation:
    Network Administrator
    Location:
    Calgary, Canada
    Hello,

    We are having some problems with a couple Cleaning Cartridges that were somehow entered in error or are no longer inside the tape library, currently I see:

    0004202
    000420L2 <-- This is the only real cleaning cartridge
    CLNI14L1


    When I try: Delete Volume 004202, I get the error:
    ANR2401E DELETE VOLUME: Volume 0004202 is not defined in a storage pool.
    ANS8001I Return Code 11


    The same happens when I try to delete CLNI14L1

    I am very new to TSM so any detailed help would be greatly appreciated.

    Thank you in advance.
     
  2.  
  3. toxy13

    toxy13 Senior Member

    Joined:
    Sep 24, 2003
    Messages:
    739
    Likes Received:
    12
    Occupation:
    Administrator
    Location:
    Leipzig
    maybe you should use the "checkout libvol" command not the "delete volume" command
     
  4. johansen

    johansen New Member

    Joined:
    Dec 13, 2007
    Messages:
    123
    Likes Received:
    2
    Location:
    Germany
    what libr do you have?
    normally TSM does not know about a cleaning cartridge. you have to checking/checkout cleaning cartridges via the library interface.

    if the volume does not reside in a storage pool you may just run command "checkout libv libr-name volumename remove=yes checklabel=no" and the tape should be gone.
     
  5. CHOWEG

    CHOWEG New Member

    Joined:
    Mar 12, 2009
    Messages:
    5
    Likes Received:
    0
    Occupation:
    Network Administrator
    Location:
    Calgary, Canada
    Command: Checkout libvol ltolib 0004202
    ANS8003I process number 17 started

    ANR8434I Checkout Libvolume: Operation for volume 0004202 in library ltolib started as process 17.
    ANR8942R Could not move volume 0004202 from slot-element 1057 to slot-element 769.
    ANR8437E Checkout Libvolume for volume 0004202 in library ltolib has failed

    **Edit:** Same error with the following command:
    checkout libvol ltolib 0004202 remove=yes checklabel=no
     
  6. toxy13

    toxy13 Senior Member

    Joined:
    Sep 24, 2003
    Messages:
    739
    Likes Received:
    12
    Occupation:
    Administrator
    Location:
    Leipzig
    try the option "remove=no" then, the tape will not moved from slot 1057 to the import/export slot, the tape will stay in library
     
  7. CHOWEG

    CHOWEG New Member

    Joined:
    Mar 12, 2009
    Messages:
    5
    Likes Received:
    0
    Occupation:
    Network Administrator
    Location:
    Calgary, Canada
    That worked, it removed the tapes.

    These tapes were not and will never be on the actual tape library, so with this can they be considered gone for good?

    Thank you toxy13 & johansen

    :up:
     

Share This Page