1. Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING) Click the link to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This message will disappear after you have made at least 12 posts. Thank you for your cooperation.

Remove DRM tapes

Discussion in 'TSM Server' started by krelvin, Sep 20, 2007.

  1. krelvin

    krelvin New Member

    Joined:
    Sep 13, 2002
    Messages:
    61
    Likes Received:
    2
    Occupation:
    Systems Analyst
    Location:
    Phoenix Metro AZ
    Is there a way to just clear DRM?

    > q drm

    Volume Name State Last Update Automated
    Date/Time LibName
    ---------------- ----------------- ------------------- ----------------
    653AAG Vault 01/12/06 14:02:41
    655AAG Vault 12/15/06 14:30:35
    656AAG Vault 01/16/06 14:00:56
    657AAG Vault 09/07/07 15:32:27
    675AAG Vault 09/14/07 15:50:27
    679AAG Vault 09/14/07 15:53:29

    The library they are attached to has been removed from the server and a new library has been installed and configured, but I can't clean up the devclass until all tapes in it are removed.

    I don't need the data.

    If I do a del vol 654AAG it says:

    Scratch volume 653AAG is empty but will not be deleted - volume access mode is "offsite".

    Attempting to do a DRM gives me an error:

    ANR6734E MOVE DRMEDIA: Volume 654AAG not processed: library 3583LIB not defined.

    Which is of course correct.

    Is there a way to remove it directly?
     
  2.  
  3. chad_small

    chad_small Moderator

    Joined:
    Dec 17, 2002
    Messages:
    2,205
    Likes Received:
    44
    Occupation:
    AIX/SAN/TSM
    Location:
    Gilbert, AZ
    If its scratch just update the volume to readwrite and then check it into the new library. When you do the MOVE DRM what state are you trying to move it to? What I don't get is why is it not in a vaultr state?
     
  4. krelvin

    krelvin New Member

    Joined:
    Sep 13, 2002
    Messages:
    61
    Likes Received:
    2
    Occupation:
    Systems Analyst
    Location:
    Phoenix Metro AZ
    A little background..

    Production is dual TSM servers with a shared large LTO2 library.

    Our DR site is way behind... it is a single TSM server with a small LTO1 library.

    i.e.... if we have a problem, we have a real problem.

    A second server was acquired and a large LTO2 library for the DR site. This will after is done, provide us with a similar hardware configuration as production so that if we have a problem or need to do a test, we will be able to actually do it.

    The existing DR server is up and running and connected to the old library. It only has a few hosts it backs up (secondary test servers) and won't be touched until after I get the new server up with the new library. I will then create new nodes on the new server, start new backups there and then dump the old servers info, and reconfigure it to work with the new server (as a slave) and library.

    The current DR server however has the correct configuration, schedules etc... but just the wrong library.

    To make the new server, I copied the current DR servers configuration, to the new server, brought it up, cleared out the data, nodes... etc.. I didn't think about DRM.

    I removed the old library definitions, drives, paths, added the new library, drives paths everything is cool... I can see the drives, everything works...

    However, I found that the DRM still knows about the old tapes to the old library. I will never need those tapes but I can't seem to get rid of them because they are associated with the old library which is/was never connected to this server.

    So I am looking for a way to just make them disappear. or I will have to backtrack and start the process over, this time remembering to clear them out before removing the old library definition.
     

Share This Page