• Please help support our sponsors by considering their products and services.
    Our sponsors enable us to serve you with this high-speed Internet connection and fast webservers you are currently using at ADSM.ORG.
    They support this free flow of information and knowledge exchange service at no cost to you.

    Please welcome our latest sponsor Tectrade . We can show our appreciation by learning more about Tectrade Solutions
  • Community Tip: Please Give Thanks to Those Sharing Their Knowledge.

    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.

  • Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)

    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

regular incr fails for backup with "object is in use" for a whole shared disk

#1
We backup a number of shares from various windows servers from one client, using the the path name.
This worked fine for over a year.
Now INCR for some shares falls immediately.
The server is 8.1.9.0 (was recently upgraded. Maybe the problem started then)
The client was 8.1.8.0 and I upgraded to 8.1.9.0, without any change.

The shares belong to windows servers, hosted on VMWARE VSAN. Backing up an image with "backup vm" works fine.
The disks are "dependent" on VMWARE. Independent disks on the same VSAN back up without problem.
I tried in the options file both

SNAPSHOTPROVIDERFS VSS
snapshotproviderfs none

which made no difference.

Here is the screen dump as seen on XXXX, backing up disk (share) ZZZZ to server YYYY,
---------------------------------------------------------------------------------------------------------------
dsmc
incr \\ZZZZ\d$
---------------------------------------------------------------------------------------------------------------
IBM Spectrum Protect
Command Line Backup-Archive Client Interface
Client Version 8, Release 1, Level 9.0
Client date/time: 05-01-2020 07:26:45
(c) Copyright by IBM Corporation and other(s) 1990, 2019. All Rights Reserved.

Node Name: XXXX
Session established with server YYYY: Windows
Server Version 8, Release 1, Level 9.000
Server date/time: 05-01-2020 07:26:46 Last access: 05-01-2020 07:24:41

Protect> incr \\ZZZZ\d$

Incremental backup of volume '\\ZZZZ\d$'
Using disk caching for backup of filespace \\ZZZZ\d$
ANS1228E Sending of object '\\ZZZZ\d$' failed.
ANS4987E Error processing '\\ZZZZ\d$': the object is in use by another process

ANS1802E Incremental backup of '\\ZZZZ\d$' finished with 1 failure(s)

Total number of objects inspected: 2
Total number of objects backed up: 0
Total number of objects updated: 0
Total number of objects rebound: 0
Total number of objects deleted: 0
Total number of objects expired: 0
Total number of objects failed: 1
Total number of objects encrypted: 0
Total number of subfile objects: 0
Total number of objects grew: 0
Total number of retries: 0
Total number of bytes inspected: 887,50 KB
Total number of bytes transferred: 0 B
Data transfer time: 0,00 sec
Network data transfer rate: 0,00 KB/sec
Aggregate data transfer rate: 0,00 KB/sec
Objects compressed by: 0%
Total data reduction ratio: 100.00%
Subfile objects reduced by: 0%
Elapsed processing time: 00:00:02
Protect>
 
#2
Workaround....
On XXXX the system is Spectrum Protect for Virtual Environments,but the backup uses the classic dsmc incr technology. When I try the same procedure from another server with a regular backup client installed, all works fine.
Seems to be a problem with the "awareness" of the virtual environment in the client.
 
#3
I had some time to track this somewhat more:

When I tried a 8.1.9 client file backup on a 8.1.9 server, the dsmc incr started to expire all active files of a share which is stored on vmware as a "dependent disk" !
Then I retried with a 8.1.7 client, and everything was fine.

I hope and assume Spectrum Protect people read this forum and will check this out. If not, I will submit a request to clarify this.
David de Leeuw
Ben Gurion University of the Negev
Beer Sheva
Israel
 

Advertise at ADSM.ORG

If you are reading this, so are your potential customer. Advertise at ADSM.ORG right now.

UpCloud high performance VPS at $5/month

Get started with $25 in credits on Cloud Servers. You must use link below to receive the credit. Use the promo to get upto 5 month of FREE Linux VPS.

The Spectrum Protect TLA (Three-Letter Acronym): ISP or something else?

  • Every product needs a TLA, Let's call it ISP (IBM Spectrum Protect).

    Votes: 18 19.6%
  • Keep using TSM for Spectrum Protect.

    Votes: 57 62.0%
  • Let's be formal and just say Spectrum Protect

    Votes: 10 10.9%
  • Other (please comement)

    Votes: 7 7.6%

Forum statistics

Threads
31,568
Messages
134,590
Members
21,640
Latest member
Rajarathnabharathi
Top