Prevent missed schedule


Jun 12, 2018
Reaction score
PREDATAR Control23

We are running SPVE and we are using tag based backups. We have one schedule with 4 datamover nodes associated with it. The schedule is using the asnodename option which causes all VMs to be backed up with the same node name.

Our daily backup schedule is defined with the following options:

There are about 75 VMs tagged for each datamover.
Occasionally, a VM is being backed up and it takes more than 24 hours to complete. When this happens, the schedule assigned to the datamover for that VM is missed the next night; therefore, 74 VMs miss their backup.

What options do I have to allow the long running backup to complete but ensure the other VMs assigned to that datamover don't miss their scheduled backup the next night?
PREDATAR Control23

The only to avoid missing schedules because the previous one is still running is to ensure that each schedule run to completion before the next scheduled time. So you would need to tweak the environment so that backups consistently run in less than 24 hours. Ideally, a lot less than 24 hours.

You can try tuning those parameters to allow more simultaneous backup sessions to help the backups finish sooner: vmmaxparallel, vmmaxbackupsessions, vmlimitperhost and vmlimitperdatastore. More info:

You possibly need additional data movers.

The general idea is that if more work is done in parallel, it can finish quicker. Also, there could be bottlenecks that could impact performance and make the backup run longer.
  • Like
Reactions: smp