• Please help support our sponsors by considering their products and services.
    Our sponsors enable us to serve you with this high-speed Internet connection and fast webservers you are currently using at ADSM.ORG.
    They support this free flow of information and knowledge exchange service at no cost to you.

    Please welcome our latest sponsor Tectrade . We can show our appreciation by learning more about Tectrade Solutions
  • Community Tip: Please Give Thanks to Those Sharing Their Knowledge.

    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.

  • Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)

    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

Newbie DR/migration test - Restored DB ok but fail to connect using baclient GUI

cividan

ADSM.ORG Member
#1
First, I did some reading in this forum and gathered as much information as I could and it helped me alot understanding stuff more than IBM doc most of the time.
Second, english is not my native language so be kind with me on that part.

I'm a TSM newbie and I'm doing DR/migration test for TSM 6.1, if I can sucessfully DR my original setup I will format/install w2k8r2 on the w2k3 box.

Here is my setup:
Original TSM: Physical --> win2k3 32 bit --> TSM 6.1.03 32bit--> Devclass file + Ts 3573 Tape library
DR TSM: VmWare VM--> win2k8r2 64 bit --> TSM 6.1.04 64bit--> Devclass file


Here is what I did, installed TSM in DR VM (VM-TSMLVL4), ran initial configuration wizard in standard mode, defined a node password, etc. all was fine. Installed BA client with admin command line. Initialised baclient using GUI. Connected as admin with default password, updated password and created new admin account. Defined a devclass file BDBACKUP2.


On original TSM I ran these command:

define devclass DBBACKUP2 devtype=file directory=E:\TSMLVL_DB maxcapacity=4G
backup db devclass=dbbackup2 type=full


Used FTP software to move the backup DB + dsmserv.opt + devconfig.out + volhist.out to new DR server.

On DR VM, stop tsm server1 service then command line: dsmserv.exe restore db todate=today
Got a few warning on screen about library DLL and other stuff but all completed succesfully.

I started tsm Server1 service and can connect to administrative command line (I get error when I try to change DRM file status about server not in compliance with License terms.)
Next problem appear when I launch the ba Client GUI it tries to connect to the original node VM-TSMLV4 and ask for password, I tried entering the node password that was working before and it didn't work (expected since DB was restored my logic says that node should be original node name). I tried entering the original TSM server node name: TSMLVL1 without a password or with the admin password but it doesn't work.

Problem is that on the original TSM I never entered any password to connect using the GUI, on the connection information when the GUI is connected I see:
Name: TSMLVL1
Type: windows
Version: 6.1.3.0
Archive retention: no

Authorization information
Authority level: client owner
Delete backup files: "YES"
Delete Archive files: "YES"
Deduplication: "Server Only"

Any pointer from there would be appreciated.
 

Harry_Redl

Moderator
ADSM.ORG Moderator
#2
Hi,

2cents - what can you see in the TSM server console (or dsmadmc -console) - why is the session rejected? Is it possible the server is disabled for client access? In that case use "enable sess" command.
Both node password and admin password should work.

Harry
 

cividan

ADSM.ORG Member
#3
Thanks, opening the console gave me some hint on what was going on... node not defined. When I finally had the good node name I saw access denied... I had to reset the node password using the update node tsmlvl1 NewPass
After that I was able to connect to the node using the BA client, since my dsm.opt is set with passwordaccess generate, I then ran the command update node tsmlvl1 forcepwreset=yes
node my BA client generated itself a new password to access the node.

Hi,

2cents - what can you see in the TSM server console (or dsmadmc -console) - why is the session rejected? Is it possible the server is disabled for client access? In that case use "enable sess" command.
Both node password and admin password should work.

Harry
 
Last edited:

Advertise at ADSM.ORG

If you are reading this, so are your potential customer. Advertise at ADSM.ORG right now.

UpCloud high performance VPS at $5/month

Get started with $25 in credits on Cloud Servers. You must use link below to receive the credit. Use the promo to get upto 5 month of FREE Linux VPS.

The Spectrum Protect TLA (Three-Letter Acronym): ISP or something else?

  • Every product needs a TLA, Let's call it ISP (IBM Spectrum Protect).

    Votes: 12 15.8%
  • Keep using TSM for Spectrum Protect.

    Votes: 48 63.2%
  • Let's be formal and just say Spectrum Protect

    Votes: 9 11.8%
  • Other (please comement)

    Votes: 7 9.2%

Forum statistics

Threads
31,354
Messages
133,546
Members
21,475
Latest member
sag
Top