• Please help support our sponsors by considering their products and services.
    Our sponsors enable us to serve you with this high-speed Internet connection and fast webservers you are currently using at ADSM.ORG.
    They support this free flow of information and knowledge exchange service at no cost to you.

    Please welcome our latest sponsor Tectrade . We can show our appreciation by learning more about Tectrade Solutions
  • Community Tip: Please Give Thanks to Those Sharing Their Knowledge.

    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.

  • Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)

    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

Need help with segments ?

ldmwndletsm

ADSM.ORG Senior Member
Joined
Oct 30, 2019
Messages
220
Reaction score
4
Points
0
I read the IBM document on "query content" in regards to Segment Number, but I'm a bit perplexed. Can someone offer me an explanation of segments in the below scenario ?

1. I ran an SQL select statement as: "select * from contents where volume_name='ABC123L6'" > ABC123L6_select_content.out

2. There are 3672090 blocks of entries but 3672088 unique OBJECT_ID values, so two are duplicates as discussed in 3 below.

3. Four of the blocks of entries consist of two pairs (nonconsecutive in the output file) wherein each block in the pair has identical column values with the exception of the SEGMENT. So one has '2/1' and the other has '2/2'. The FILE_NAME and OBJECT_ID is not the same between the pairs. All four blocks have 'AGGREGATED: Yes' and none reports a value for FRAGMENT.

[Question] What does SEGMENT '2/1' and '2/2' mean in this case ?

I'm confused here because I thought that a value of '2/2' would imply that the given volume contains the second piece of the file, and the first piece (1/2) would be contained on another tape, so the given file would have the last piece (2/2) spanning into this tape and the first piece (1/2) spanning out of another tape. But in this case it's not simply '2/2' by itself reported for this volume but also a '2/1' for the same FILE_NAME, BITFILE_ID, OBJECT_ID, etc. It would appear, therefore, that '2/2' doesn't have to always mean that this is the second piece, with the first piece being on a different tape. It sounds like it can sometimes instead mean that both pieces are on the same tape. That right ? If so, why does that happen ?

Maybe this has to do with aggregates, but I thought that aggregates worked wherein if a file was under a certain size then TSM would combine it with multiple files to create an aggregate versus just sending it by itself but not multiple pieces on the same tape. Maybe I need a better explanation of this. Thank you.
 

ldmwndletsm

ADSM.ORG Senior Member
Joined
Oct 30, 2019
Messages
220
Reaction score
4
Points
0
Actually, I'm even more bewildered than before because I just now ran this: "query content ABC123L6 f=d" > ABC123L6_q_content_details.out

Those two files from the earlier select contents command appear in this output each one time only, but they report:

Aggregated?: 1/2
Segment Number: 2/2
Linked: No
Fragment Number:

and

Aggregated?: 2/2
Segment Number: 2/2
Linked: No
Fragment Number:

So in the "select contents" output we have an 'AGGREGATED: Yes' for both files, and each appears twice with 'SEGMENT: 2/1' and 'SEGMENT: 2/2' respectively, but then in the "query contents f=d" output, each appears once with one having 'Aggregated?: 1/2' and 'Segment Number: 2/2' and the other having 'Aggregated?: 2/2' and 'Segment Number: 2/2'.

It seems as if 'SEGMENT' is different in the select output versus in the query output ? Can someone help me to make sense of this madness ?
 

The Spectrum Protect TLA (Three-Letter Acronym): ISP or something else?

  • Every product needs a TLA, Let's call it ISP (IBM Spectrum Protect).

    Votes: 22 19.5%
  • Keep using TSM for Spectrum Protect.

    Votes: 67 59.3%
  • Let's be formal and just say Spectrum Protect

    Votes: 15 13.3%
  • Other (please comement)

    Votes: 9 8.0%

Forum statistics

Threads
31,842
Messages
134,917
Members
21,814
Latest member
DavideGrossiTSM
Top