1. Community Tip: Please Give Thanks to Those Sharing Their Knowledge.
    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.
  2. Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)
    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

How do I setup the TSM scheduler on RHEL 7?

Discussion in 'TSM Client' started by droach, Oct 10, 2017.

  1. droach

    droach ADSM.ORG Senior Member

    Joined:
    Jan 7, 2008
    Messages:
    198
    Likes Received:
    3
    Occupation:
    I'm thinking...
    Location:
    Cut and Shoot, Texas
    I can't believe I have to post this question, but I cannot find any documentation so here goes....

    RHEL 7 does not use the inittab to start services. So, how do I configure TSM to auto start its scheduler at boot?

    I found this article for starting DSMCAD, but this does not start the scheduler.
    https://www-01.ibm.com/support/docview.wss?uid=swg21976275

    I am a Linux newbie so please be gentle.
     
  2.  
  3. droach

    droach ADSM.ORG Senior Member

    Joined:
    Jan 7, 2008
    Messages:
    198
    Likes Received:
    3
    Occupation:
    I'm thinking...
    Location:
    Cut and Shoot, Texas
    I finally figured it out. Basically, I just replaced the DSMCAD stuff with 'dsmc sched'
     
  4. RecoveryOne

    RecoveryOne ADSM.ORG Member

    Joined:
    Mar 15, 2017
    Messages:
    51
    Likes Received:
    6
  5. marclant

    marclant ADSM.ORG Moderator

    Joined:
    Jun 16, 2006
    Messages:
    2,567
    Likes Received:
    358
    Occupation:
    Accelerated Value Specialist for Spectrum Protect
    Location:
    Canada
    Or add: MANAGEDSERVICE SCHEDULER in dsm.opt and dsmcad will start the scheduler for you.
     
  6. droach

    droach ADSM.ORG Senior Member

    Joined:
    Jan 7, 2008
    Messages:
    198
    Likes Received:
    3
    Occupation:
    I'm thinking...
    Location:
    Cut and Shoot, Texas
    I tried setting 'MANAGEDSERVICEs SCHEDULE' in the dsm.sys file and starting the systemd process described in the links above. It did not start the scheduler, only starts the CAD. I don't usually use the CAD so the fix I figured out will work for me.

    Thanks guys for your replies.
     

Share This Page