• Please help support our sponsors by considering their products and services.
    Our sponsors enable us to serve you with this high-speed Internet connection and fast webservers you are currently using at ADSM.ORG.
    They support this free flow of information and knowledge exchange service at no cost to you.

    Please welcome our latest sponsor Tectrade . We can show our appreciation by learning more about Tectrade Solutions
  • Community Tip: Please Give Thanks to Those Sharing Their Knowledge.

    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.

  • Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)

    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

error VSS_E_SNAPSHOT_SET_IN_PROGRESS. 0X80042316 TSM TDP4VE for Hyper-V

RajeshR

ADSM.ORG Member
#1
Dear All,

I have a backup issue on TSM TDP4VE Hyper-V,
Error log says: ""error VSS_E_SNAPSHOT_SET_IN_PROGRESS. 0X80042316""
This is issue happened when 2 schedules conflicted, which tries to trigger backup for 2 separate VM's in same clustered volume from different nodes.
My Hyper-v is in cluster environment with 4 hosts and 2 CSV's.
When 2 schedules conflicted all other schedules following got failed with same error, Even after restarting Hyper-V hosts also manual backup r schedule backup's without conflicts getting failed.
And This looks like APAR IT15657:
This APAR got fixed in 8.1.0 and i have upgraded my TSM TDP4VE Hyper-V to 8.1.0 from 7.1.3 but still no luck and same error occurred.
After upgrade and before upgrade i have performed restart on Hyper-V host and installation is successful.
But when i tried taking IFINCR/IFULL backup for any of the VM it's still getting failed with same above error.
I have tried restoring one of the VM to a different location and with different name and it's successful when the version is 7.1.3 and 8.1.0 both versions working for restore.
Note: We are taking backup only for supported VM generations that is 2nd generation VHDX disks and we do not have any ISCSI devices attached to any of the VM's.
All VSS writers in all 4 Hyper-V hosts are stable state without any error.

Error in detail:
ANS5250E An unexpected error was encountered.
TSM function name : StartSnapshotSet()
TSM function : 'StartSnapshotSet() failed with error VSS_E_SNAPSHOT_SET_IN_PROGRESS.
0X80042316'
TSM return code : -2147212522
TSM file : ..\..\common\vm\HyperV\vsssnap.cpp (1132)
ANS1950E Backup using Microsoft volume shadow copy failed.

Issue started when 2 schedules conflicted, but after restart of hyper-v hosts one VM IFINCR backup completed successfully but i tried for another alone it's got failed again, even after many restarts of hyper-v hosts, still backup's not working.
I have tried taking backup with a different node and completely for a different domain but there also no luck.

Kindly suggest.
Thanks,
Rajesh R
 

marclant

ADSM.ORG Moderator
#2
Looks like you may need to clean-up the old snapshots. Check using "vssadmin list shadows" if you have old shadows from the previous failed backups.
And This looks like APAR IT15657:
This APAR only applies if you have iSCSI disks, do you?
 

RajeshR

ADSM.ORG Member
#3
Looks like you may need to clean-up the old snapshots. Check using "vssadmin list shadows" if you have old shadows from the previous failed backups.

This APAR only applies if you have iSCSI disks, do you?
I have checked if i have any shadows earlier
"No items found that satisfy the query." this is the output for it.
And i have also tried to move all vm's from one host and selected one development vm and moved it to this specific host and removed snapshot of this vm and tried backup, but still no luck,
 

Advertise at ADSM.ORG

If you are reading this, so are your potential customer. Advertise at ADSM.ORG right now.

UpCloud high performance VPS at $5/month

Get started with $25 in credits on Cloud Servers. You must use link below to receive the credit. Use the promo to get upto 5 month of FREE Linux VPS.

The Spectrum Protect TLA (Three-Letter Acronym): ISP or something else?

  • Every product needs a TLA, Let's call it ISP (IBM Spectrum Protect).

    Votes: 8 21.6%
  • Keep using TSM for Spectrum Protect.

    Votes: 19 51.4%
  • Let's be formal and just say Spectrum Protect

    Votes: 6 16.2%
  • Other (please comement)

    Votes: 4 10.8%

Forum statistics

Threads
30,967
Messages
131,778
Members
21,224
Latest member
alexp36
Top