1. Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING) Click the link to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This message will disappear after you have made at least 12 posts. Thank you for your cooperation.

DRM: Not tracking DB tapes & TSM Reports not showing as Vaultretrieve?

Discussion in 'Disaster Recovery Module' started by pichelman, Oct 8, 2009.

  1. pichelman

    pichelman New Member

    Joined:
    Mar 27, 2008
    Messages:
    122
    Likes Received:
    0
    Hi TSM Gurus,

    I have been losing tapes in TSM viaa DRM - I think.

    At least I have been monitoring the volhistory and have noticed my DB tapes expiring after 8 days which is completed via a command in our daily Admin scripts.
    Name: DAILY_ADMIN
    Line Number: 50
    Command: del volh t=dbb todate=-8
    Last Update by (administrator): ADMIN
    Last Update Date/Time: 02/03/2009 15:56:05

    Here is my check of the volhist DB's yesterday:

    tsm: WMNATCHTSM>q volhist t=dbb

    Date/Time: 09/30/2009 06:41:34
    Volume Type: BACKUPFULL
    Backup Series: 262
    Backup Operation: 0
    Volume Seq: 1
    Device Class: LTOCLASS1
    Volume Name: WS0188L2
    Volume Location: VAULT
    Command:

    Date/Time: 10/01/2009 12:19:11
    Volume Type: BACKUPFULL
    Backup Series: 263
    Backup Operation: 0
    Volume Seq: 1
    Device Class: LTOCLASS1
    Volume Name: WS0003L2
    Volume Location: VAULT
    Command:

    Here is a check today:

    tsm: WMNATCHTSM>q volhist t=dbb

    Date/Time: 10/01/2009 12:19:11
    Volume Type: BACKUPFULL
    Backup Series: 263
    Backup Operation: 0
    Volume Seq: 1
    Device Class: LTOCLASS1
    Volume Name: WS0003L2
    Volume Location: VAULT
    Command:

    Date/Time: 10/02/2009 07:09:21
    Volume Type: BACKUPFULL
    Backup Series: 264
    Backup Operation: 0
    Volume Seq: 1
    Device Class: LTOCLASS1
    Volume Name: WS0009L2
    Volume Location: VAULT
    Command:

    Clearly the DB's are expiring per the command in the Daily Admin script.

    But, why is DRM or the Reporting not picking up or tracking?
    Yesterday's tape here and gone --> Volume Name: WS0188L2

    tsm: WMNATCHTSM>q drm

    Volume Name State Last Update Automated
    Date/Time LibName
    ---------------- ----------------- ------------------- ----------------
    WS0002L2 Vault 10/02/2009 08:24:12
    .............


    DB's are listed at bottom of DRM query...?

    WS0018L2 Vault 10/08/2009 08:12:54
    WS0017L2 Vault 10/07/2009 11:54:17
    WS0012L2 Vault 10/06/2009 11:54:09
    WS0011L2 Vault 10/05/2009 08:20:22
    WS0009L2 Vault 10/02/2009 08:38:00
    WS0003L2 Vault 10/01/2009 12:45:18

    And here is the TSM Report:

    Tapes needed from Docusafe TSM 24 hour Report for WMNATCHTSM generated at 2009-10-08 10:30:22 on WMNATCHTSM covering 2009-10-07 10:30:22 to 2009-10-08 10:30:21
    Server name: WMNATCHTSM, platform: Windows, version: 5.5.2.0, date/time: 10/08/2009 10:30:22
    Tape Return from Offsite
    VOLUME_NAME STATE UPD_DATE VOLTYPE
    WS0161L2 VAULTRETRIEVE 2009-09-04 08:09 CopyStgPool
    WS0181L2 VAULTRETRIEVE 2009-08-21 08:47 CopyStgPool


    What am I missing?

    We have DRM setup to remove after 8 days...

    tsm: WMNATCHTSM>q drmstatus
    Session established with server WMNATCHTSM: Windows
    Server Version 5, Release 5, Level 2.0
    Server date/time: 10/08/2009 12:01:06 Last access: 10/08/2009 10:36:40


    Recovery Plan Prefix: C:\RECOVERYPLANS\
    Plan Instructions Prefix:
    Replacement Volume Postfix: @
    Primary Storage Pools:
    Copy Storage Pools:
    Not Mountable Location Name: NOTMOUNTABLE
    Courier Name: docusafe
    Vault Site Name: VAULT
    DB Backup Series Expiration Days: 8 Day(s)
    Recovery Plan File Expiration Days: 186 Day(s)
    Check Label?: Yes
    Process FILE Device Type?: No
    Command File Name:

    Hmmm...is the daily_admin script getting in the way of DRM?

    Ok - so I removed my entry in the daily_admin script to stop deleting DB tapes from volhist.
    I think this is the issue.

    Should I also leave these entries in the daily_admin script or alter them?

    Name: DAILY_ADMIN
    Line Number: 35
    Command: del volh t=STGNew todate=-90
    Last Update by (administrator): ADMIN
    Last Update Date/Time: 10/08/2009 12:04:55

    Name: DAILY_ADMIN
    Line Number: 40
    Command: del volh t=STGReuse todate=-90
    Last Update by (administrator): ADMIN
    Last Update Date/Time: 10/08/2009 12:04:55

    Name: DAILY_ADMIN
    Line Number: 45
    Command: del volh t=STGDelete todate=-90
    Last Update by (administrator): ADMIN
    Last Update Date/Time: 10/08/2009 12:04:55

    Thanks for any input.

    -SP
     
  2.  
  3. dms19

    dms19 New Member

    Joined:
    Jan 4, 2006
    Messages:
    470
    Likes Received:
    2
    Occupation:
    TSM Admin
    Location:
    In your head...
    if I understand what you are asking....the following dbb volumes should show up on tomorrow and the next days report generating the "offsite" recall list.

    WS0009L2 Vault 10/02/2009 08:38:00
    WS0003L2 Vault 10/01/2009 12:45:18

    Today is only the 8th today - 8 will still leave these as active dbb's
     
  4. pichelman

    pichelman New Member

    Joined:
    Mar 27, 2008
    Messages:
    122
    Likes Received:
    0
    Hi,

    This tape was in the volhist yesterday:

    tsm: WMNATCHTSM>q volhist t=dbb

    Date/Time: 09/30/2009 06:41:34
    Volume Type: BACKUPFULL
    Backup Series: 262
    Backup Operation: 0
    Volume Seq: 1
    Device Class: LTOCLASS1
    Volume Name: WS0188L2
    Volume Location: VAULT
    Command:

    It is not there today.

    DRM does not know about it anymore and has not put it in the vaultretrieve status.

    My daily_admin script has been deleting tapes manually and not letting DRM handle DB tapes...

    I'l wait until tomorrow and see if thsi helps...
    Any other ideas?

    Thanks!

    Scott
     
  5. dms19

    dms19 New Member

    Joined:
    Jan 4, 2006
    Messages:
    470
    Likes Received:
    2
    Occupation:
    TSM Admin
    Location:
    In your head...
    Just curious if you searched the activity log for that volume over the last 24 hrs?

    Have you done a q vol volumename or a q drm * to see if it shows in any of those places?

    Do you actually move these tapes to offsite, or do they stay in the library? Was it returned to scratch?
     
  6. fuzzballer

    fuzzballer New Member

    Joined:
    Jun 5, 2004
    Messages:
    204
    Likes Received:
    1
    Occupation:
    It Specialist/ TSM Administrator
    Location:
    Kansas
    You might try this select staement and see if it returns anything:
    Select libvolumes.volume_name from libvolumes where status= 'Private' and libvolumes.volume_name not in(select volume_name from volumes) and libvolumes.volume_name not in(select volume_name from volhistory where type in('BACKUPFULL', 'BACKUPINCR', 'DBSNAPSHOT', 'EXPORT', 'BACKUPSET'))

    If anything does show up then they can be returned for scratch
     
  7. mikeatkc

    mikeatkc Senior Member

    Joined:
    Apr 24, 2007
    Messages:
    450
    Likes Received:
    4
    Location:
    United States
    Shouldn't you allow DRM to handle your DB tapes expiration? Try the below command to see if any of the volume LAST_USE parameter is blank/empty. If it is, you need to update those volume to scratch status.

    Code:
    tsm> select * from libvolumes where status='Private'
    
     
  8. BBB

    BBB Moderator

    Joined:
    Feb 13, 2007
    Messages:
    2,076
    Likes Received:
    20
    Location:
    Brisbane, Australia
    The problem was probably using "del volhist" to delete the db backups - you shouldn't do this, just let drm handle it.

    The other del volhists for stgnew/stgdel etc are fine to leave.
     
  9. pichelman

    pichelman New Member

    Joined:
    Mar 27, 2008
    Messages:
    122
    Likes Received:
    0
    Hi Guys.

    Anyone who said DRM would handle - you were right.

    I removed the del volhist from the Daily Admin script and it is working now - DRM is tracking the DB tapes - setting to vault retrieve in the TSM reports as well.

    Thanks to all...

    -SP
     
  10. moorecj79

    moorecj79 New Member

    Joined:
    Nov 14, 2009
    Messages:
    16
    Likes Received:
    0
    Occupation:
    Server Technician
    Location:
    Melbourne, Australia
    Try the below command to see if any of the volume LAST_USE parameter is blank/empty. If it is, you need to update those volume to scratch status.

    Code:
    tsm> select * from libvolumes where status='Private'
    
    [/quote]


    I just ran this command and 120 tapes were reported. Should I be concerned?
     

Share This Page