• Please help support our sponsors by considering their products and services.
    Our sponsors enable us to serve you with this high-speed Internet connection and fast webservers you are currently using at ADSM.ORG.
    They support this free flow of information and knowledge exchange service at no cost to you.

    Please welcome our latest sponsor Tectrade . We can show our appreciation by learning more about Tectrade Solutions
  • Community Tip: Please Give Thanks to Those Sharing Their Knowledge.

    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.

  • Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)

    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

DRM - checkout issue

rees_chris

ADSM.ORG Member
#1
Hi

Environment is all AIX, TSM 6.3.2 library manager and library client. TS3500 library using standard I/O hopper (no Virtual I/O)
The library manager services about 5 library clients.

A colleague of mine emailed me this morning to ask me to look at a problem they had yesterday, and its left me baffled.

basically they do "move drmedia * wherestate=MOUNTABLE tostate=VAULT source=dbs WAIT=yes remove=bulk" and use the cmd and cmdf options.

So as expected checkouts began for all the eligble tapes

However, although the library manager checked out the tapes (eventually , there was a delay as the I/O hopper was full, which is not unusual there) , the library client never acknowledged these check outs, i.e there were no messages along the lines of

28/05/13 08:35:41 ANR6697I MOVE DRMEDIA: CHECKOUT LIBVOLUME for volume
B00923L5 in library TS3500 completed successfully.


Hence, the tapes were not sent to VAULT. Then TSM tried to use them and over a short period all of the tapes were set to unavailable as obviously the library manager couldn't mount them.

The only error on the library client was

27/05/13 10:57:46 ANR0985I Process 806 for MOVE DRMEDIA running in the
FOREGROUND completed with completion state FAILURE at
10:57:46. (SESSION: 367225, PROCESS: 806)
27/05/13 10:57:46 ANR1893E Process 806 for MOVE DRMEDIA completed with a
completion state of FAILURE. (SESSION: 367225, PROCESS:
806

The library manager shows no errors , apart from one tape it couldn't checkout because it was in use and the I/O full messages.

I've asked my colleague how often this happens as I don't think this is a one off. Today everything was fine and worked as it should.

I just wondered if anyone else has come across anything like this ??

Thanks
 
Last edited:

tsm_dude

ADSM.ORG Senior Member
#2
You should see similar on a library client;
R6696I MOVE DRMEDIA: CHECKOUT LIBVOLUME for volume G04849L4 in library LIBRARY1 starting.
ANR0408I Session 62288 started for server TSM1 (AIX) (Tcp/Ip) for library sharing.
ANR0409I Session 62288 ended for server TSM1 (AIX).
ANR6697I MOVE DRMEDIA: CHECKOUT LIBVOLUME for volume G04849L4 in library LIBRARY1 completed successfully.
ANR6683I MOVE DRMEDIA: Volume G04849L4 was moved from MOUNTABLE state to VAULT.
ANR6682I MOVE DRMEDIA command ended: 1 volumes processed.
 

rees_chris

ADSM.ORG Member
#3
Those messages are not displayed on the library client... the same has happened again this morning

so taking one volume as an example, the library client shows

29/05/13 08:14:32 ANR2753I (DBADMIN_TSMGLC2): Volume Name: B01779L5
(SESSION: 390900)
29/05/13 08:14:55 ANR6696I MOVE DRMEDIA: CHECKOUT LIBVOLUME for volume
B01779L5 in library TS3500 starting. (SESSION: 390900,
PROCESS: 856)
29/05/13 08:14:55 ANR2753I (DBADMIN_TSMGLC2):for volume B01779L5 in library
TS3500 (SESSION: 390900)


and then nothing else,,

the library manager shows

29/05/13 08:16:04 ANR8867I Processing volume B01779L5 for the CHECKOUT
command. (SESSION: 951634)
29/05/13 08:16:16 ANR8829I Remove volume B01779L5 from slot 796 of library
TS3500 at your convenience. (SESSION: 951634)
29/05/13 08:16:16 ANR8438I CHECKOUT LIBVOLUME for volume B01779L5 in library
TS3500 completed successfully. (SESSION: 951634)



But it looks like the library manager is not informing the library client that the checkout has happened...
 

Advertise at ADSM.ORG

If you are reading this, so are your potential customer. Advertise at ADSM.ORG right now.

UpCloud high performance VPS at $5/month

Get started with $25 in credits on Cloud Servers. You must use link below to receive the credit. Use the promo to get upto 5 month of FREE Linux VPS.

The Spectrum Protect TLA (Three-Letter Acronym): ISP or something else?

  • Every product needs a TLA, Let's call it ISP (IBM Spectrum Protect).

    Votes: 7 23.3%
  • Keep using TSM for Spectrum Protect.

    Votes: 16 53.3%
  • Let's be formal and just say Spectrum Protect

    Votes: 4 13.3%
  • Other (please comement)

    Votes: 3 10.0%

Forum statistics

Threads
30,889
Messages
131,422
Members
21,194
Latest member
jamesmacd40