1. Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING) Click the link to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This message will disappear after you have made at least 12 posts. Thank you for your cooperation.

Diskpool (STGP) full and migration does not work.

Discussion in 'Performance Tuning' started by digamond, Nov 7, 2012.

Thread Status:
Not open for further replies.
  1. digamond

    digamond New Member

    Joined:
    Nov 12, 2009
    Messages:
    4
    Likes Received:
    0
    Location:
    Åland
    Hi,

    I have a problem with the stgpool (diskpool).
    I Can not make any archives on clients or backups at the moment, the diskpool is full...

    Storage Device Estimated Pct Pct High Low Next Stora-
    Pool Name Class Name Capacity Util Migr Mig Mig ge Pool
    Pct Pct
    ----------- ---------- ---------- ----- ----- ---- --- -----------
    DISKPOOL DISK 60 G 100.0 0.0 5 0 TAPEPOOL

    The High was set to 90 and Low to 0
    Still did not migrate the data to the tape.
    I have now 2 tapes in lib that is filling with with pcl util on 47 and 7,5 and 1 more scratch so space should be there on tape as well.

    I tried to run the migrate command..

    tsm: ALATSM_SERVER1>migrate stgpool diskpool lowmig=0 wait=yes
    ANR4972I MIGRATE STGPOOL: Migration is not needed for the storage pool DISKPOOL.
    ANS8001I Return code 11.

    No need?

    More information regarding my Tapepool that I guess someone asks for:

    tsm: ALATSM_SERVER1>q stgp diskpool f=d

    Storage Pool Name: DISKPOOL
    Storage Pool Type: Primary
    Device Class Name: DISK
    Estimated Capacity: 60 G
    Space Trigger Util: 100.0
    Pct Util: 100.0
    Pct Migr: 0.0
    Pct Logical: 100.0
    High Mig Pct: 5
    Low Mig Pct: 0
    Migration Delay: 0
    Migration Continue: Yes
    Migration Processes: 1
    Reclamation Processes:
    Next Storage Pool: TAPEPOOL
    Reclaim Storage Pool:
    Maximum Size Threshold: No Limit
    Access: Read/Write
    Description:
    Overflow Location:
    Cache Migrated Files?: Yes
    Collocate?:
    Reclamation Threshold:
    Offsite Reclamation Limit:
    Maximum Scratch Volumes Allowed:
    Number of Scratch Volumes Used:
    Delay Period for Volume Reuse:
    Migration in Progress?: No
    Amount Migrated (MB): 0.00
    Elapsed Migration Time (seconds): 0
    Reclamation in Progress?:
    Last Update by (administrator): ADMIN
    Last Update Date/Time: 11/07/2012 10:30:33
    Storage Pool Data Format: Native
    Copy Storage Pool(s):
    Active Data Pool(s):
    Continue Copy on Error?: Yes
    CRC Data: No
    Reclamation Type:
    Overwrite Data when Deleted:


    Anyone out there that had this problem or someone that has a solution to help me out moving the data from diskpool to tape?
     
  2.  
  3. Jeroen

    Jeroen Senior Member

    Joined:
    Oct 2, 2002
    Messages:
    356
    Likes Received:
    12
    Occupation:
    AIX + storage administrator
    Location:
    netherlands
    Cache Migrated Files?: Yes

    from the "h q stg"
    The Pct Util value includes cached data on disk volumes.
    Therefore, when cache is enabled and migration occurs, the Pct
    Util value remains the same because the migrated data remains
    on the volume as cached data. The Pct Util value decreases only
    when the cached data expires or when the space that cached
    files occupy needs to be used for noncached files.

    So TSM keeps a copy of migrated files on the diskpool in case they are required for a restore. As soon as it needs the space for new backups it will discard some cached files.
    The "Pct Migr: 0.0" is the value that matters for storage pool migrations
     
  4. digamond

    digamond New Member

    Joined:
    Nov 12, 2009
    Messages:
    4
    Likes Received:
    0
    Location:
    Åland
    I just did a test now and change Cache Migrated Files?: Yes to Cache Migrated Files?: No and run q proc...

    tsm: ALATSM_SERVER1>q proc

    Process Process Description Status
    Number
    -------- -------------------- -------------------------------------------------
    11 Migration Disk Storage Pool DISKPOOL, Moved Files: 0, Moved
    Bytes: 0, Unreadable Files: 0, Unreadable Bytes:
    0. Current Physical File (bytes): 67,133,440
    Waiting for mount of output volume QQ1888 (2
    seconds).

    So it seems now it starts to migrate again.. Dont know if we need the cache function at all since all is on tape anyways and the ex month archive will fill our diskpool in short time.. (only 60GB diskpool).
    Will close this thread since I think this is solved for now.
     
Thread Status:
Not open for further replies.

Share This Page