• Please help support our sponsors by considering their products and services.
    Our sponsors enable us to serve you with this high-speed Internet connection and fast webservers you are currently using at ADSM.ORG.
    They support this free flow of information and knowledge exchange service at no cost to you.

    Please welcome our latest sponsor Tectrade . We can show our appreciation by learning more about Tectrade Solutions
  • Community Tip: Please Give Thanks to Those Sharing Their Knowledge.

    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.

  • Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)

    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

Disable cache + empty disk pool (pct util = 0%!)

nicflatterie

Active Newcomer
Joined
Dec 3, 2008
Messages
5
Reaction score
1
Points
0
Greetings, a client of mine as a TSM on which cache was set to yes for the primary disk pool. All is well but the client does not understand that the "pct util" is not equal to 0% after migration occurs. I am tired of this, and want to turn off cache. But...

- change cache to no
- migrate files (lo=0 to migrate them all and migdelay = 0 so not wait)

now how do I empty the disk volumes? I do not want the cached files in there anymore. I searched quite a lot and cannot seem to find that... Is my only option to flush the volumes and create new ones?

Thanks, Nic.
 

moon-buddy

ADSM.ORG Moderator
Joined
Aug 24, 2005
Messages
7,033
Reaction score
404
Points
0
Location
Somewhere in the US
Greetings, a client of mine as a TSM on which cache was set to yes for the primary disk pool. All is well but the client does not understand that the "pct util" is not equal to 0% after migration occurs. I am tired of this, and want to turn off cache. But...

- change cache to no
- migrate files (lo=0 to migrate them all and migdelay = 0 so not wait)

now how do I empty the disk volumes? I do not want the cached files in there anymore. I searched quite a lot and cannot seem to find that... Is my only option to flush the volumes and create new ones?

Thanks, Nic.
Add hi=0 and all of the data on disk will be moved over to the backup (not offsite pool but next defined pool) online tape pool.

Reset back to hi=70, lo=40 or something else as you wish after the migration.
 

nicflatterie

Active Newcomer
Joined
Dec 3, 2008
Messages
5
Reaction score
1
Points
0
nope!

Tried that. The cached files are still in there so my volumes are not 0%...
 

rore

ADSM.ORG Senior Member
Joined
Nov 27, 2005
Messages
642
Reaction score
15
Points
0
Location
Montreal, CA

lidra

ADSM.ORG Member
Joined
Oct 19, 2006
Messages
34
Reaction score
1
Points
0
Location
Auckland / NZ
Website
Visit site
Run Expire Inventory. If you have an administrative schedule that runs expiration only for a defined time (ex 2 hours) then expiration didnt get to them yet (might never get there).

The objects that are in the storage pool are a copy of what was already migrated to the next storage pool (tape). Because of that the objects will not be migrated a second time, and migration will not touch them.

I would believe expire Inventory should empty the space on that storage pool. Another thing would be to leave them as is, as the server should overwrite them in time when new objects come into the storage pool.

Cheers,

Lidra
 

lidra

ADSM.ORG Member
Joined
Oct 19, 2006
Messages
34
Reaction score
1
Points
0
Location
Auckland / NZ
Website
Visit site
Hi
Try backing up just some files on a node who backups to your disk pool. Then run migration (migrate stgpool).

The migration process shold get rid of the cache files as the pool is not cached enabled anymore.

Rudy

EDIT just found this http://www-01.ibm.com/support/docvi...ol&uid=swg21198169&loc=en_US&cs=utf-8&lang=en
and this
http://www-01.ibm.com/support/docvi...ol&uid=swg21322468&loc=en_US&cs=utf-8&lang=en
Ok, I was wrong, expiration doesn't delete them.
It doesnt make sense for me why not.....but you learn something new every day.

Cheers,

Lidra
 

BBB

ADSM.ORG Moderator
Joined
Feb 13, 2007
Messages
2,076
Reaction score
20
Points
0
Location
Brisbane, Australia
You have to either delete the stgpool vols ... or fill them up with something else to overwrite the cached copies.

(or the cached copies will gradually expire over time when that file is expired from tsm - could be a long time though!)
 

rore

ADSM.ORG Senior Member
Joined
Nov 27, 2005
Messages
642
Reaction score
15
Points
0
Location
Montreal, CA

nicflatterie

Active Newcomer
Joined
Dec 3, 2008
Messages
5
Reaction score
1
Points
0
My solution

I solve this situation finally. I migrated all to tape, deleted all disk volumes with discard=yes and recreated them, making sure the cache parameter was now set to no.

The client is now convinced that migration worked. Remember this all started with a client that had a poor understanding of TSM's internal workings and would not trust my word on it.

Thanks for all the replies!
 

Kramer

ADSM.ORG Member
Joined
Mar 14, 2005
Messages
38
Reaction score
2
Points
0
Location
Canberra, Australia
Website
Visit site
You should have been able to flush the disk pools by first migrating all the current data...
MIGRATE STG backup_storage_pool LO=0
Then using something like this for each volume in the disk stg pool to remove the cached files...
MOVE DATA X:\BACKUP_STG_POOL_VOLUME1.DSM WAIT=NO
 

Patthecat

Active Newcomer
Joined
Jul 11, 2017
Messages
7
Reaction score
2
Points
0
Hi guys,

I had this problem with 7.1.7.


The situation
The situation was, that you had stg_pool cached option = yes and set to no, but nothing happens.
The migrate stg poolname lowmig=0 - command says: ANR4924I MIGRATE STGPOOL: Migration is not needed for the storage pool.

The solution/Workaround:
Look up and notice, what the next-pool of the disk-pool is.
Now go to the private volumes of the disk-pool, you would like to empty.
Select every volume and "move data to another storage pool", this must be the old "next-pool"
You will see, that migration happens in a few minutes and every single volume will have a utilization of 0%.

Reason:
I think, that every cached copy is in the next pool and so, TSM has nothing to move!

Now you can delete the volumes from the storage-pool, if you want.

kind regards
Pat
 

[email protected]

ADSM.ORG Member
Joined
Jun 10, 2011
Messages
18
Reaction score
1
Points
0
You should have been able to flush the disk pools by first migrating all the current data...
MIGRATE STG backup_storage_pool LO=0
Then using something like this for each volume in the disk stg pool to remove the cached files...
MOVE DATA X:\BACKUP_STG_POOL_VOLUME1.DSM WAIT=NO

YES. This is the solution. Thanks a lot Kramer. (12 years later, still useful)
 

Advertise at ADSM.ORG

If you are reading this, so are your potential customer. Advertise at ADSM.ORG right now.

UpCloud high performance VPS at $5/month

Get started with $25 in credits on Cloud Servers. You must use link below to receive the credit. Use the promo to get upto 5 month of FREE Linux VPS.

The Spectrum Protect TLA (Three-Letter Acronym): ISP or something else?

  • Every product needs a TLA, Let's call it ISP (IBM Spectrum Protect).

    Votes: 19 18.6%
  • Keep using TSM for Spectrum Protect.

    Votes: 61 59.8%
  • Let's be formal and just say Spectrum Protect

    Votes: 13 12.7%
  • Other (please comement)

    Votes: 9 8.8%

Forum statistics

Threads
31,798
Messages
135,581
Members
21,775
Latest member
oscar
Top