• Please help support our sponsors by considering their products and services.
    Our sponsors enable us to serve you with this high-speed Internet connection and fast webservers you are currently using at ADSM.ORG.
    They support this free flow of information and knowledge exchange service at no cost to you.

    Please welcome our latest sponsor Tectrade . We can show our appreciation by learning more about Tectrade Solutions
  • Community Tip: Please Give Thanks to Those Sharing Their Knowledge.

    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.

  • Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)

    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

Delete Azure cloud stgpool

kslztc

ADSM.ORG Member
#1
Hi,

We have an testlab, that we was testing tiering to Azure cloud stgpools, using tiering rules.
This turned out to work very well, untill an Administrator deleted the storage blob in Azure...

Since its only a test lab, we want to simply destroy the data at the Cloud pool, but have failed to do so...

We have done the following:
delete stgpool AZURE (says there is still data in the container)
audit container stgpool=AZURE action=markdamaged
deleted the tiering rule
Changed the copy grp to only store 30 days of data, since all over 30 days will be synced to Azure


Isnt there a way, to delete the stgpool in ISP, since we cant access it anymore?
We are aware, that all data that is stored in Azure, will be lost.
 

kslztc

ADSM.ORG Member
#3
Hi,

Yup i tried that, but it seems that the containers are not getting marked as damaged.
output from q container stgpool=AZURE format=detailed


Container: 9b57760150c111/100030007-000000000000b19e.ccf
Storage Pool Name: AZURE
Container Type: Cloud
State:
Free Space(MB):
Maximum Size(MB):
Approx. Date Last Written: 6/22/19, 15:09:02
Approx. Date Last Audit:
Cloud Type: AZURE
Cloud URL: https://domain.blob.core.windows.net
Cloud Object Size (MB): 2
Space Utilized (MB): 2
Data Extent Count: 1,955
 

kslztc

ADSM.ORG Member
#5
Run the following commands:

audit container stgpool=AZURE action=markdamaged
audit container stgpool=AZURE action=removedamaged

Is that what you are looking for?
 

marclant

ADSM.ORG Moderator
#6
Yes, that should have worked as long as both processed finished successfully and that the first one finished before you issue the second command. However, you will only be able to delete the stgpool after the reuse delay has elapsed if it's not zero.

Did you update the stgpool with access=destroyed prior to the 2 audit commands?

And after the 2 audits, it will take a little while for background processes to actually delete the containers. Once all the containers are gone, then you should be able to delete the pool.
 

kslztc

ADSM.ORG Member
#7
Hi,

It actually started deleting the containers now (or it seems so)


TSM01> q process 42823
Storage pool AZURE, Damaged Objects Deleted: 8183163, Damaged Objects Skipped: 0.


I dont seem to have an option, to update the stgpool to access destroyed
 

Advertise at ADSM.ORG

If you are reading this, so are your potential customer. Advertise at ADSM.ORG right now.

UpCloud high performance VPS at $5/month

Get started with $25 in credits on Cloud Servers. You must use link below to receive the credit. Use the promo to get upto 5 month of FREE Linux VPS.

The Spectrum Protect TLA (Three-Letter Acronym): ISP or something else?

  • Every product needs a TLA, Let's call it ISP (IBM Spectrum Protect).

    Votes: 16 18.8%
  • Keep using TSM for Spectrum Protect.

    Votes: 52 61.2%
  • Let's be formal and just say Spectrum Protect

    Votes: 10 11.8%
  • Other (please comement)

    Votes: 7 8.2%

Forum statistics

Threads
31,451
Messages
133,985
Members
21,549
Latest member
idhelmyy
Top