• Please help support our sponsors by considering their products and services.
    Our sponsors enable us to serve you with this high-speed Internet connection and fast webservers you are currently using at ADSM.ORG.
    They support this free flow of information and knowledge exchange service at no cost to you.

    Please welcome our latest sponsor Tectrade . We can show our appreciation by learning more about Tectrade Solutions
  • Community Tip: Please Give Thanks to Those Sharing Their Knowledge.

    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.

  • Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)

    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

Database moved, backups won't run

sandragon

ADSM.ORG Member
Joined
Aug 26, 2014
Messages
52
Reaction score
0
Points
0
Our TSM Server had over 40 DB volumes defined. On IBM's suggested we moved to a smaller number of volumes. This... did not go as planned.

We're on TSM 6.3.5 running on AIX 7.1. Sunday night we disabled all access to the server with a 'disable ses' command, then ran a full backup. We followed the instructions from IBM (which have been mirrored here in several threads) to delete the old instance of the DB, run the DB restore from the commandline. The Restore took about 5.5 hours. Since then, things have been horribly wrong and IBM doesn't seem to have an answer.

Backups that started during our scheduled window... are still sitting there as if they just started. The most any session has transferred is 2.1MB. We usually move 15TB in a night. Expiration will not run. Any attempt to start an expiration process spawns nothing. However, you can't re-run the command as 'an expiration thread is already in progress'. Cancel expiration doesn't stop this either.

Licence audits have also been frozen since 10am yesterday.

Our Arch Log size has remained static and the active log is empty. I've got 4000 sessions standing open in 'run' status.

The only thing that works right now is tape operations. Tape to tape copies, direct to tape backups of the DB, and Lanfree seem to work.

Anyone seen this? Any ideas?
 

bigred15

ADSM.ORG Senior Member
Joined
May 30, 2011
Messages
59
Reaction score
3
Points
0
Location
Melbourne, Australia
Escalate further within IBM if the current support team have no answers.

The active log being empty is concerning - is there anything in db2diag log file? Also worth verifying db2 cfg values (db2 get db cfg for db TSMDB1)
 

sandragon

ADSM.ORG Member
Joined
Aug 26, 2014
Messages
52
Reaction score
0
Points
0
I've escalated further within IBM, yes. The DB2 diag file is indeed filled with entries. I've sent the contents off to IBM as well as my act log for the past 48 hours and various show commands they requested upon the escalation.
 

sandragon

ADSM.ORG Member
Joined
Aug 26, 2014
Messages
52
Reaction score
0
Points
0
Well, it appears that when the database restore was completed, DB2 took a look at the indices and flagged our Backup Objects index as bad. So we're stuck waiting for it to rebuild.
 

Advertise at ADSM.ORG

If you are reading this, so are your potential customer. Advertise at ADSM.ORG right now.

UpCloud high performance VPS at $5/month

Get started with $25 in credits on Cloud Servers. You must use link below to receive the credit. Use the promo to get upto 5 month of FREE Linux VPS.

The Spectrum Protect TLA (Three-Letter Acronym): ISP or something else?

  • Every product needs a TLA, Let's call it ISP (IBM Spectrum Protect).

    Votes: 18 18.2%
  • Keep using TSM for Spectrum Protect.

    Votes: 61 61.6%
  • Let's be formal and just say Spectrum Protect

    Votes: 12 12.1%
  • Other (please comement)

    Votes: 8 8.1%

Forum statistics

Threads
31,753
Messages
135,377
Members
21,748
Latest member
fabiont
Top