• Please help support our sponsors by considering their products and services.
    Our sponsors enable us to serve you with this high-speed Internet connection and fast webservers you are currently using at ADSM.ORG.
    They support this free flow of information and knowledge exchange service at no cost to you.

    Please welcome our latest sponsor Tectrade . We can show our appreciation by learning more about Tectrade Solutions
  • Community Tip: Please Give Thanks to Those Sharing Their Knowledge.

    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.

  • Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)

    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

Bkp problem!

EduardoRio

ADSM.ORG Member
#1
Hi there!
I have a new issue to solve.
Q event shows one of my servers (node/client) as "missed" for any backup task.
Q act show that "sessions" are opened and closed almost at the same time.
My infra team told that nothing changed.
At the server client looks as running indeed.
Some advice?
Thanks!!
Eduardo
 

marclant

ADSM.ORG Moderator
#2
When a schedule is missed, you have to check the client. Make sure the scheduler is running, if it's not, that explains it, start it. If it is running, then check the dsmerror.log and dsmsched.log for indications as to why the schedule didn't run.
 

EduardoRio

ADSM.ORG Member
#3
After looking at inside the client, many questions arise:
1) there are 6 services; 2 alive; 4 starts and get down few seconds after.
2) dsmsched.log - does not show problems at first sight;
3)dsmerror.log - show a lot of possible problems:
  • Node exceded max number of mounting points;
  • TCP/IP error - connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.' (errno = 10060);
  • 29/11/2018 16:21:41 ANS1035S Opt file 'E:\TSM\dsm_SEPETIBA_FULLW_QUORUM.opt' cannot be found/read.
PS: in fact , I cannot found this opt file(?)

Below a example of opt file:
NODENAME TAMOIOS_INCRD
PASSWORDAccess Generate
TCPSERVERADDRESS 192.168.18.88
TCPWINDOWSIZE 256
TCPPort 1500
COMMmethod TCPip
TCPBUFFSIZE 256
CHANGINGRETRIES 2
TXNBYTELIMIT 2097152
TCPNODELAY YES
ERRORLOGName "C:\Program Files\Tivoli\TSM\baclient\dsmerror_TAMOIOS_INCRD.log"
ERRORLOGMax 1 G
SCHEDLOGName "C:\Program Files\Tivoli\TSM\baclient\dsmsched_TAMOIOS_INCRD.log"
SCHEDLOGMax 1 G
I really don't know how to fix that...
 

moon-buddy

ADSM.ORG Moderator
#4
What is maximum number of sessions set on the TSM Server?

To find out: q options and look for max sessions - set to to a high number like 1000 - would not hurt the TSM server.

Can the node "see" the TSM server?

To find out: from the node ping the TSM server and see if a telnet session can see the TSM server from the TCP Port used by the TSM server and node; from the node: telnet <TSM_server_IP> 1500 (or whatever TCP Port you are using)

Are you on a Cluster setup? If you are, check the quorum setup which is normally of a shared drive like E:
 
Last edited:

EduardoRio

ADSM.ORG Member
#5
Hi! Thanks buddy!

What is maximum number of sessions set on the TSM Server?

It was 100, I've set it up to 1000

Can the node "see" the TSM server?

I think so. I don't have the credential to connect with this server. BTW, from the TSM server telnet does not connect with the client on port 1500. I'll call my infra team to chck this out.


Are you on a Cluster setup? If you are, check the quorum setup which is normally of a shared drive like E:
Yes
 

EduardoRio

ADSM.ORG Member
#6
Hi,
After some tries I've realized that the 3 out of 5 services on the client server node does not working properly.
The 2 that still working seems to be for quorum task, and they a running smoothly.

That said, I think that I haven't network communications problems...

The other 3 are set to backing up SQL on FULL and Incremental daily basis.

On that server I've tried to start the service, they came on and got off few seconds after.
Looking on the Win Log, it seems that some kind of configuration file(.opt, I think) could not be found. I realy can't find this files on that server. And, since nothing got changed on that machine I became very confused. However, the file could had been corrupted on the disk(?)

So... Any help are very welcomed!!
Thanks again !!!
Eduardo
 

marclant

ADSM.ORG Moderator
#7
You can get more information for each service. From a command prompt, change to "c:\program files\tivoli\tsm\baclient".

Issue this command to get the list of services:
dsmcutil list
1549563603725.png

Then for each service in the list, issue:
dsmc query /name:"service name".
1549563668834.png

From that info, you'll be able to figure out which option file is for which node, if it's a cluster node or not, etc.
 

marclant

ADSM.ORG Moderator
#9
I don't need to see the results. It's just to help you sort out what node and option file belongs to which service and where their respective log files are located. That should help you determine which services need to be either fixed or removed.
 

Advertise at ADSM.ORG

If you are reading this, so are your potential customer. Advertise at ADSM.ORG right now.

UpCloud high performance VPS at $5/month

Get started with $25 in credits on Cloud Servers. You must use link below to receive the credit. Use the promo to get upto 5 month of FREE Linux VPS.

The Spectrum Protect TLA (Three-Letter Acronym): ISP or something else?

  • Every product needs a TLA, Let's call it ISP (IBM Spectrum Protect).

    Votes: 10 14.1%
  • Keep using TSM for Spectrum Protect.

    Votes: 46 64.8%
  • Let's be formal and just say Spectrum Protect

    Votes: 9 12.7%
  • Other (please comement)

    Votes: 6 8.5%

Forum statistics

Threads
31,267
Messages
133,179
Members
21,405
Latest member
churu1k
Top