• Please help support our sponsors by considering their products and services.
    Our sponsors enable us to serve you with this high-speed Internet connection and fast webservers you are currently using at ADSM.ORG.
    They support this free flow of information and knowledge exchange service at no cost to you.

    Please welcome our latest sponsor Tectrade . We can show our appreciation by learning more about Tectrade Solutions
  • Community Tip: Please Give Thanks to Those Sharing Their Knowledge.

    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.

  • Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)

    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

BKI9008E error on a machine used for restoring a tdp backup

benoit16

ADSM.ORG Member
Joined
Sep 16, 2016
Messages
24
Reaction score
0
Points
0
Hello,

I am trying to perform a restore on a server.
I have installed TSM and TDP.

When I try to genereate the bki, I have the following error.
# backint -p /var/tmp/initRestoreXXX.utl -f password

Data Protection for SAP(R)

Interface between BR*Tools and Tivoli Storage Manager
- Version 7, Release 1, Modification 3.0 for Linux x86_64 -
Build: 710 compiled on Jun 16 2015
(c) Copyright IBM Corporation, 1996, 2015, All Rights Reserved.

BKI9008E: This product requires at least version 7.1.3.0 of TSM API to be installed.
BKI0020I: End of program at: Tue 29 Nov 2016 11:41:26 AM CET.
BKI0021I: Elapsed time: 00 sec.
BKI0024I: Return code is: 2.

This is the TSM version that I have installed:
# backint -version

Data Protection for SAP(R)

Interface between BR*Tools and Tivoli Storage Manager
- Version 7, Release 1, Modification 3.0 for Linux x86_64 -
Build: 710 compiled on Jun 16 2015
(c) Copyright IBM Corporation, 1996, 2015, All Rights Reserved.

Could you help me in diagnosing why it does not work?

Thanks
 

marclant

ADSM.ORG Moderator
Joined
Jun 16, 2006
Messages
3,639
Reaction score
591
Points
0
Location
Canada
Website
www-947.ibm.com
This is the TSM version that I have installed:
# backint -version

Data Protection for SAP(R)

Interface between BR*Tools and Tivoli Storage Manager
- Version 7, Release 1, Modification 3.0 for Linux x86_64 -
That's the version of TDP.
BKI9008E: This product requires at least version 7.1.3.0 of TSM API to be installed.
The error you are getting talks about the API (ships with the baclient, not with TDP). Use "rpm -q TIVsm*" the check the TSM API version.

You can download the latest baclient, which includes the API here:
http://www-01.ibm.com/support/docview.wss?rs=663&uid=swg21239415
 

balirake

ADSM.ORG Member
Joined
Mar 29, 2016
Messages
19
Reaction score
1
Points
0
Please make sure that the BA Client Version at the Target Server (where you are restoring) is at minimum 7.1.3.0.

Upgrade it if required to resolve the issue.
 

Advertise at ADSM.ORG

If you are reading this, so are your potential customer. Advertise at ADSM.ORG right now.

UpCloud high performance VPS at $5/month

Get started with $25 in credits on Cloud Servers. You must use link below to receive the credit. Use the promo to get upto 5 month of FREE Linux VPS.

The Spectrum Protect TLA (Three-Letter Acronym): ISP or something else?

  • Every product needs a TLA, Let's call it ISP (IBM Spectrum Protect).

    Votes: 19 19.0%
  • Keep using TSM for Spectrum Protect.

    Votes: 61 61.0%
  • Let's be formal and just say Spectrum Protect

    Votes: 12 12.0%
  • Other (please comement)

    Votes: 8 8.0%

Forum statistics

Threads
31,774
Messages
135,487
Members
21,762
Latest member
Rambug
Top