• Please help support our sponsors by considering their products and services.
    Our sponsors enable us to serve you with this high-speed Internet connection and fast webservers you are currently using at ADSM.ORG.
    They support this free flow of information and knowledge exchange service at no cost to you.

    Please welcome our latest sponsor Tectrade . We can show our appreciation by learning more about Tectrade Solutions
  • Community Tip: Please Give Thanks to Those Sharing Their Knowledge.

    If you receive helpful answer on this forum, please show thanks to the poster by clicking "LIKE" link for the answer that you found helpful.

  • Community Tip: Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING)

    Click the link above to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This notice will disappear after you have made at least 3 posts.

ANR8840E Unable to open device xxx with error number 2 and PVRRC 2843

Zoleeadmin

ADSM.ORG Member
Joined
Mar 6, 2008
Messages
15
Reaction score
1
Points
0
Hi All,

I have installed TSM 7.1.6 on Windows server 2012 R2. HP StoreOnce B5100 VTL is connected with IBM-TS 3500 Virtual Tape Library Emulation and IBM LTO3 Virtual Tape Drives to the backup server.
I see the devices in the Windows Device Manager, however the type of the Medium Changers are 'Unknown'.

I tried to define path on TSM and get the following error:

ANR8840E Unable to open device LB70.0.0.3 with error number 2 and PVRRC 2843. (SESSION: 1)
ANR8529E DEFINE PATH: Unable to open library DL_3584_CP104DB01_DC1 by using an open system call.

IBM TSM device driver is installed.

Could you please help me what could be the reason?

Many Thanks,
Regards,
Zoltan
 

Zoleeadmin

ADSM.ORG Member
Joined
Mar 6, 2008
Messages
15
Reaction score
1
Points
0
Hello Sias,

I have created IBM-TS3500 VTL with IBM-LTO3 Tape Drives. This should be supported. (03584L32)
The TSMDLST see all devices, for Library example:

TSM Name ID LUN Bus Port SSN WWN TSM Type Driver Device Identifier
-----------------------------------------------------------------------------------------------------------------------------
lb0.0.0.1 0 0 0 1 9361120128 5001438024775CAF LIBRARY n/a IBM 03584L32 4.02

I installed the default IBM Device Driver package which included in the TSM server Installation kit. I rolled back to 7.1.0 but the issue is still the same.

Shall I install additional Device Driver?

Please advice.
Thank you an regards,
Zoltan
 

Zoleeadmin

ADSM.ORG Member
Joined
Mar 6, 2008
Messages
15
Reaction score
1
Points
0
This
Hello Sias,

I have created IBM-TS3500 VTL with IBM-LTO3 Tape Drives. This should be supported. (03584L32)
The TSMDLST see all devices, for Library example:

TSM Name ID LUN Bus Port SSN WWN TSM Type Driver Device Identifier
-----------------------------------------------------------------------------------------------------------------------------
lb0.0.0.1 0 0 0 1 9361120128 5001438024775CAF LIBRARY n/a IBM 03584L32 4.02

I installed the default IBM Device Driver package which included in the TSM server Installation kit. I rolled back to 7.1.0 but the issue is still the same.

Shall I install additional Device Driver?

Please advice.
Thank you an regards,
Zoltan

This VTL is supported according to the IBM link:
http://www-01.ibm.com/support/docview.wss?rs=663&uid=swg21599235

HPE StoreOnce Backup System Software version 3.13.0 has been validated with TSM 7.1.3 with the following emulation modes.
  • Library emulation - IBM 03584L32 Library- Firmware : 4.02
  • Drive emulation - IBM ULTRIUM-TD3 - Firmware : 8711
--> TSM recognize it correctly according to the tsmdlst:

TSM Name ID LUN Bus Port SSN WWN TSM Type Driver Device Identifier Symbolic Name
-------------------------------------------------------------------------------------------------------------------------------------------------
lb0.0.0.1 0 0 0 1 9361120128 5001438024775CAF LIBRARY n/a IBM 03584L32 4.02 n/a
mt1.0.0.1 1 0 0 1 9361120002 5001438024775DE1 LTO IBM IBM ULTRIUM-TD3 8711 \\.\Tape0

However the driver for the medium chnager is not detected and I see it as "Unknown medium changer" in the windows device manager.

What kind of device driver is required here?

Thanks and regards,
Zoltan
 

Zoleeadmin

ADSM.ORG Member
Joined
Mar 6, 2008
Messages
15
Reaction score
1
Points
0
I have fixed the issue. Downloaded the IBM Tape Device driver and installed it manually. After that Windows could detect all Medium Changers in the correct form and I could configure TSM pathes. :)

Good day to All! ;-)
Zoltan
 

RajeshR

ADSM.ORG Senior Member
Joined
May 11, 2016
Messages
78
Reaction score
9
Points
0
I have fixed the issue. Downloaded the IBM Tape Device driver and installed it manually. After that Windows could detect all Medium Changers in the correct form and I could configure TSM pathes. :)

Good day to All! ;-)
Zoltan
Hello I got the same issue but after installing it manually, my medium changer still showing it as unknown device and couldn't able to access.
any suggestions
 

Advertise at ADSM.ORG

If you are reading this, so are your potential customer. Advertise at ADSM.ORG right now.

DigitalOcean $100 Credit

Support ADSM.ORG and get DigitalOcean FREE credit. DigitalOcean currently offer a $100, 60-day Free Credit for new accounts. Sign-up here:

DigitalOcean Referral Badge

The Spectrum Protect TLA (Three-Letter Acronym): ISP or something else?

  • Every product needs a TLA, Let's call it ISP (IBM Spectrum Protect).

    Votes: 20 18.7%
  • Keep using TSM for Spectrum Protect.

    Votes: 65 60.7%
  • Let's be formal and just say Spectrum Protect

    Votes: 13 12.1%
  • Other (please comement)

    Votes: 9 8.4%

Forum statistics

Threads
31,897
Messages
135,988
Members
21,783
Latest member
london
Top