1. Warning: This is not a support forum. Please do not post any questions here !!
    This forum is for your publishing HOWTOs or sharing unofficial documentation for various parts of TSM. Please do not post questions here - All question posting will be deleted.
    Repeated violators of forum rules will be banned.

  2. Forum Rules (PLEASE CLICK HERE TO READ BEFORE POSTING) Click the link to access ADSM.ORG Acceptable Use Policy and forum rules which should be observed when using this website. Violators may be banned from this website. This message will disappear after you have made at least 12 posts. Thank you for your cooperation.

ANR1425W - Scratch volume xxxxx is empty but will not be deleted

Discussion in 'TSM Documentation,Tips and Tricks' started by bostonlean, Aug 13, 2012.

  1. bostonlean

    bostonlean Member

    Apr 25, 2008
    Likes Received:
    TSM admin, NAS admin, AIX SA
    columbia sc
    So I came across this issue last week, searched the forums relentlessly and found lots of problems, but no final answers. Here was the situation:

    I had volumes in an overflow pool that had a reuse delay of 1 day. Once the delay had passed the volumes stayed in a pending state. I tried the following to resolve:
    removed the offsite location name and replaced with ""
    checked them in as libvol (but they had to be checked in as private as they would not checkin as scratch due to pending state)
    tried to move media on them

    no matter what I did it seemed like the volume state in the media table was inconsistent with this error, like it was getting its state from 2 different tables. (actlog showed mountablenotinlib after I had checked it in and a q media showed it as mountableinlib)

    I opened a PMR with IBM, got bounced around a bit, but finally got the answer

    There is an undocumented command called repair volseg. It resolved orphaned segments on volumes. It worked. Here is how I fixed it:

    repair volseg NT0000 (volume name must be in caps) - this is what you will see in the actlog - ANR0195W Attempting to remove extraneous database entries
    for volume NT0000. (SESSION: 44427)
    08/10/12 23:23:08 ANR0196I Removal of extraneous database entries for volume
    NT0000 was successful. (SESSION: 44427)

    then i ran a checkout libvol (because i had previously checked them in)
    then i ran a move media wherestate=mountablenotinlib wherestatus=empty (the repair volseg changed it from pending to empty)
    then a checkin status=scratch search=bulk

    ran perfectly

    Hope this helps someone else

Share This Page