Results 1 to 9 of 9
  1. #1
    Member
    Join Date
    Feb 2005
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Dear Tachies,



    I am facing the following error with RMAN backup with TDP for oracle in one of the My cluster Node.

    My Env:

    TDP for oracle with 5.2.1

    TSM 5.3 with LANFREE

    Client AIX with Oracle 9iR2

    I am able to take the lanfree backup from cluster nodes.

    But I am getting the following error for with rman in one of the server.

    Error Details:

    RMAN> 2> 3> 4> 5> 6> 7> 8> 9> 10>

    RMAN-00571: ================================================== =========

    RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============

    RMAN-00571: ================================================== =========

    RMAN-03009: failure of allocate command on t2 channel at 07/05/2005 12:56:36

    ORA-19554: error allocating device, device type: SBT_TAPE, device name:

    ORA-27000: skgfqsbi: failed to initialize storage subsystem (SBT) layer

    IBM AIX RISC System/6000 Error: 106: Reserved errno was encountered

    Additional information: 7011

    ORA-19511: Error received from media manager layer, error text:

    SBT error = 7011, errno = 106, sbtopen: system error



    Please suggest me any help for this prob.



    Rgds

    Sanku












  2. #2
    Senior Member cheffern's Avatar
    Join Date
    Mar 2005
    Location
    Massachusetts, USA
    Posts
    1,004
    Thanks
    0
    Thanked 4 Times in 4 Posts

    Default

    Anything with the SBT layer is usually indicative of an issue with the Oracle relinking.

    Have you relinked Oracle after the TDP library install?

  3. #3
    Senior Member
    Join Date
    Apr 2005
    Location
    Michigan
    Posts
    1,359
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Default

    Yep, that is the answer. Relink your Oracle libraries. Also ensure your tdpo.conf file states you want to use Lanfree option. When in doubt, view your environment with the "showenv" variable. Oh For the likes of me, since is midnight on a Tues, I cannot think of the command.



    Steve
    Steven Gabriel
    Principal -SGSolutions Inc.
    http://www.sgsolutionsinc.com

  4. #4
    Member
    Join Date
    Feb 2005
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Dear Friends,



    I have relinked the Oracle libraries through "relink all " command, After the relinkg still i am facing same prblem.

    My all configuration file are correct(dsm.opt,dsm.sys &tdpo.opt).



    Kindly provide some suggetions on this. Advanced apprications to them.



    Rgds

    Sanku

  5. #5
    Senior Member
    Join Date
    Apr 2005
    Location
    Michigan
    Posts
    1,359
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Default

    Send me your RMAN configuration script
    Steven Gabriel
    Principal -SGSolutions Inc.
    http://www.sgsolutionsinc.com

  6. #6
    Member
    Join Date
    Feb 2005
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Thanks for your support.



    My rman script:

    rman log=/backup/logs/level0_backup.log target / <<EOF

    configure retention policy to recovery window of 7 days;

    configure backup optimization on;

    configure controlfile autobackup on;

    configure maxsetsize to unlimited;

    run{

    allocate channel t1 type 'sbt_tape' parms

    'ENV=(TDPO_OPTFILE=/usr/tivoli/tsm/client/oracle/bin64/tdpo.opt)';

    backup incremental level 0

    filesperset 10

    format 'test1_df_%t_%s_%p_%u'

    tag 'test1_dbf_level_0_weekly'

    (database include current controlfile);

    release channel t1;

    }



    CROSSCHECK BACKUP;

    LIST BACKUP OF DATABASE;

    REPORT UNRECOVERABLE;

    REPORT SCHEMA;

    REPORT NEED BACKUP;

    REPORT OBSOLETE;

    quit

    EOF



    Rgds

    Sanku


  7. #7
    Senior Member
    Join Date
    Apr 2005
    Location
    Michigan
    Posts
    1,359
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Default

    Here is a discrepancy

    allocate channel t1 type 'sbt_tape' parms

    Versus the following error

    RMAN-03009: failure of allocate command on t2 channel at 07/05/2005 12:56:36



    You have "channel differences"



    Also where is your TDP dsm.opt file, it should be in Oracle's working directory.



    Steven
    Steven Gabriel
    Principal -SGSolutions Inc.
    http://www.sgsolutionsinc.com

  8. #8
    Newcomer
    Join Date
    Aug 2005
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    I have problem that looks very similar.

    AIX 5.3L 64 bit , Oracle 9i 9.20, TSM 5.3 with tdpo



    /u01/app/oracle/920/lib/libobk.a is linked to /usr/lib/libobk64.a, which is in turn linked to the libobk64.a in the TDPO installation.

    tsm/client/oracle/bin64/dsm.opt contains servername as per dsm.sys.

    tsm/client/oracle/bin64/tdpo.opt contains dsm.opt location, log location and nodename.

    tsm/client/api/bin64/dsm.sys is linked to tsm/client/baclient/bin/dsm.sys, which contains a server stanza for the TDPO.



    Password is set and the node is registered.

    I have done a relink all.



    Receiving this when attempting a very simple RMAN backup script:



    RMAN> run {

    2> allocate channel t1 type 'sbt_tape' parms

    'ENV=(TDPO_OPTFILE=/usr/tivoli/tsm/client/oracle/bin64/tdpo.opt)';

    3> backup filesperset 5 format 'dt_%t_%s_%p' (database);

    4> }



    RMAN-00571: RMAN-03009: failure of allocate command on t1 channel at 08/02/2005 19:12:58

    ORA-19554: error allocating device, device type: SBT_TAPE, device name:

    ORA-27000: skgfqsbi: failed to initialize storage subsystem (SBT) layer

    IBM AIX RISC System/6000 Error: 106: Reserved errno was encountered

    Additional information: 7011

    ORA-19511: Error received from media manager layer, error text:

    SBT error = 7011, errno = 106, sbtopen: system error



    Any ideas?



    Rhys.

  9. #9
    Senior Member nezih's Avatar
    Join Date
    Oct 2002
    Location
    istanbul
    Posts
    765
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Default

    hey rhysm,

    give chmod 777 to libobk64.a on /usr/tivoli/tsm/client/oracle/bin64 directory and try again...
    destruction is not negative! you must destroy to build...

Similar Threads

  1. SQL Plugin for TSM?
    By CHund in forum Backup / Archive Discussion
    Replies: 5
    Last Post: 08-19-2005, 10:57 AM
  2. Couple of Queries for TSM Experts
    By bobbyasr2000 in forum Disaster Recovery Module
    Replies: 1
    Last Post: 07-07-2005, 05:22 PM
  3. Replies: 0
    Last Post: 07-07-2005, 06:14 AM
  4. Replies: 0
    Last Post: 07-07-2005, 06:11 AM
  5. Migration from TSM 5.1.6 to TSM 5.2.0
    By nilsont in forum TSM Server
    Replies: 0
    Last Post: 07-28-2003, 02:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •