Hi. I have some serious problem with a OS X 10.5.8 server. TSM can't take a backup of the server.
I've tried the following versions of TSM 6.1.<all versions> -> 6.2.3 and my error seems to occour with all versions.

The following occours if I try to run a incremental backup from the GUI:
1) It start to look for diffrences so it know what to backup,
2) Starts to take a backup of new/modified objects
3) then, random, it just stops.
Once it took a 70GB backup but now it wont take anything.

I've tried to run dsmc i from the command line:
xserv2:~ admin$ sudo dsmc i
Password:
< I type in root password >
IBM Tivoli Storage Manager
Command Line Backup-Archive Client Interface
Client Version 6, Release 2, Level 4.0
Client date/time: 11/28/2012 09:19:47
(c) Copyright by IBM Corporation and other(s) 1990, 2011. All Rights Reserved.

Node Name: <NODENAME>
Session established with server <SERVER>: Windows
Server Version 6, Release 2, Level 3.0
Server date/time: 11/28/2012 09:16:47 Last access: 11/27/2012 22:35:36

Incremental backup of volume '/'

*** set a breakpoint in malloc_error_break to debug
dsmc(3523,0xb0285000) malloc: *** error for object 0xa8e600: incorrect checksum for freed object - object was probably modified after being freed.
*** set a breakpoint in malloc_error_break to debug
Abort trap
I've followed the session from a admin console and the session is alive until the abort trap.

I've tailed a tracelog...
xserv2:~ admin$ sudo tail -f /private/var/root/tsmtrace.log
psLocalToUcs(wchar_t, wchar_t) input buffer is empty.
psLocalToUcs(wchar_t, wchar_t) input buffer is empty.
psUcsToLocal(wchar_t, wchar_t) input buffer is empty.
psUcsToLocal(wchar_t, wchar_t) input buffer is empty.
Server='RBACKUP2', len=32
psLocalToUcs(wchar_t, wchar_t) input buffer is empty.
psLocalToUcs(wchar_t, wchar_t) input buffer is empty.
psLocalToUcs(wchar_t, wchar_t) input buffer is empty.
psLocalToUcs(wchar_t, wchar_t) input buffer is empty.
psLocalToUcs(wchar_t, wchar_t) input buffer is empty.
...as well as the dsmerror.log
xserv2:~ admin$ sudo tail -f /Library/Logs/tivoli/tsm/dsmerror.log
11/28/2012 09:23:11 ANS0361I DIAG: Block header invalid, possible memory overwrite. Addr 0x8cd408, File mempool.cpp, Line 644
11/28/2012 09:23:11 ANS0361I DIAG: Block header invalid, possible memory overwrite. Addr 0xaea608, File fileio.cpp, Line 3506
11/28/2012 09:23:11 ANS0361I DIAG: Block header invalid, possible memory overwrite. Addr 0x8bd208, File fileio.cpp, Line 3506
11/28/2012 09:23:11 ANS0361I DIAG: B/A Txn Consumer thread, fatal error, signal 11
I found this APAR but it applies to OS X 10.6, not 10.5
http://www-01.ibm.com/support/docvie...id=swg21616691

Any idea what might cause this?