Wow its been about 3 years since being on this forum. Good to be back in TSM world. I bowed out just after 6.1 release and am now back configuring a multi instance environment with 6.3 on Linux. Anyways long story short, we are working with TSM for VE. I have successfully got this working on one cluster. We are specifying the VMHOST option and running multiple schedules per proxy. I went to duplicate settings to a different cluster and we are getting some weird hangs. Some of the VM's will backup while others will just han, here is an example:

root@tsmvmp01:/opt/tivoli/tsm/client/ba/bin # dsmc backup vm vma -asnodename=vc11_vmp01 -optfile=dsm_dm1.opt
IBM Tivoli Storage Manager
Command Line Backup-Archive Client Interface
Client Version 6, Release 3, Level 0.5
Client date/time: 10/05/2012 09:02:27
(c) Copyright by IBM Corporation and other(s) 1990, 2012. All Rights Reserved.

Node Name: VC11_VMP01_DM1
Session established with server TSMDB01: Linux/x86_64
Server Version 6, Release 3, Level 2.0
Server date/time: 10/05/2012 09:02:27 Last access: 10/05/2012 08:59:28

Accessing as node: VC11_VMP01
2012-10-05T09:02:30.132-05:00 [7F91C3899720 info 'Default'] Initialized channel manager
2012-10-05T09:02:30.132-05:00 [7F91C3899720 info 'Default'] Current working directory: /opt/tivoli/tsm/client/ba/bin
2012-10-05T09:02:30.132-05:00 [7F91C3899720 trivia 'Default'] buffer is 'NPTL 2.12'
2012-10-05T09:02:30.132-05:00 [7F91C3899720 verbose 'ThreadPool'] Thread info: Min Io, Max Io, Min Task, Max Task, Max Thread, Keepalive, exit idle, idle secs, max fds: 2, 21, 2, 10, 31, 4, true, 600
2012-10-05T09:02:30.132-05:00 [7F91C3899720 trivia 'ThreadPool'] Thread pool launched
Full BACKUP VM of virtual machines 'vma'.



Backup VM command started. Total number of virtual machines to process: 1
Deleted directory /tmp/vmware-root/564d0003-3136-ad88-98ac-44468e2efbf3-vm-46/hotadd

The snapshot gets created in Vcenter.
Create virtual machine snapshot
vma
Completed
root
vcenter11
10/5/2012 3:01:39 AM
10/5/2012 3:01:39 AM
10/5/2012 3:01:41 AM

The weird part is while one VM will backup another wont and they are on the same host.

Any cases with IBM I have opened lately regarding TSM for VE or HADR, the knowledge seems pretty limited, thanks for help in advance.