Results 1 to 1 of 1
  1. #1
    Join Date
    Apr 2008
    columbia sc
    Thanked 6 Times in 1 Post

    Default ANR1425W - Scratch volume xxxxx is empty but will not be deleted

    So I came across this issue last week, searched the forums relentlessly and found lots of problems, but no final answers. Here was the situation:

    I had volumes in an overflow pool that had a reuse delay of 1 day. Once the delay had passed the volumes stayed in a pending state. I tried the following to resolve:
    removed the offsite location name and replaced with ""
    checked them in as libvol (but they had to be checked in as private as they would not checkin as scratch due to pending state)
    tried to move media on them

    no matter what I did it seemed like the volume state in the media table was inconsistent with this error, like it was getting its state from 2 different tables. (actlog showed mountablenotinlib after I had checked it in and a q media showed it as mountableinlib)

    I opened a PMR with IBM, got bounced around a bit, but finally got the answer

    There is an undocumented command called repair volseg. It resolved orphaned segments on volumes. It worked. Here is how I fixed it:

    repair volseg NT0000 (volume name must be in caps) - this is what you will see in the actlog - ANR0195W Attempting to remove extraneous database entries
    for volume NT0000. (SESSION: 44427)
    08/10/12 23:23:08 ANR0196I Removal of extraneous database entries for volume
    NT0000 was successful. (SESSION: 44427)

    then i ran a checkout libvol (because i had previously checked them in)
    then i ran a move media wherestate=mountablenotinlib wherestatus=empty (the repair volseg changed it from pending to empty)
    then a checkin status=scratch search=bulk

    ran perfectly

    Hope this helps someone else

  2. The Following 6 Users Say Thank You to bostonlean For This Useful Post:

    anilbalwada (10-16-2012),jabalraj (10-01-2014), moon-buddy (08-13-2012), oguri (08-14-2012),rallingham  (08-13-2012),Trident  (08-14-2012)

Similar Threads

  1. Replies: 2
    Last Post: 03-30-2011, 08:59 AM
  2. ANR8351E - Mount request for volume XXXXX has timed out.
    By jssanche in forum Tape / Media Library
    Replies: 8
    Last Post: 11-13-2009, 01:02 AM
  3. Replies: 4
    Last Post: 09-13-2007, 03:35 AM
  4. How to change empty volume to scratch.
    By ranjancom2000 in forum Tape / Media Library
    Replies: 3
    Last Post: 08-02-2006, 11:15 AM
  5. Replies: 2
    Last Post: 06-17-2005, 12:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts