Results 1 to 12 of 12
  1. #1
    Member LanSchroeder's Avatar
    Join Date
    Nov 2007
    Location
    Wisconsin
    Posts
    51
    Thanks
    1
    Thanked 1 Time in 1 Post

    Default Could not determine media type! Dell ML6000 Tape Library

    Hey guys, I just moved my TSM server to new hardware running Windows 2008 R2 64bit and i'm getting this error when trying to pull or push data to tapes...

    ANR9999D_0521343731 NtpOpen(pvrntp.c:1296) Thread<36>: Could not determine media type, rc = 1

    Everything i read says its a driver issue with the tape drives. Every driver i find for this is not working. Can someone point me in the right direction where i could find the correct driver?

    Specs.
    Win2008 R2 64bit
    Dell ML6020
    4 LTO4 Fiber tape drives

  2. #2
    Member
    Join Date
    Jun 2004
    Location
    Kansas
    Posts
    204
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    What is the brand of drive and what driver are you using?

  3. #3
    Member
    Join Date
    Jun 2004
    Location
    Kansas
    Posts
    204
    Thanks
    0
    Thanked 0 Times in 0 Posts

  4. #4
    Member LanSchroeder's Avatar
    Join Date
    Nov 2007
    Location
    Wisconsin
    Posts
    51
    Thanks
    1
    Thanked 1 Time in 1 Post

    Default

    I tried that link i found before and it doesn't work for me. It leads me to IBM's dead end page.

    Its a Dell brand unit but the Dell and IBM drivers are pretty much the same. Before on the old server it was using a dell based driver.

  5. #5
    Member
    Join Date
    Jun 2004
    Location
    Kansas
    Posts
    204
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    For me in Windows 2008 R2 I have to use the TSM driver unless the tape drive is an IBM drive in order to make it work correctly. You can always try it and see.

  6. #6
    Member
    Join Date
    Jun 2004
    Location
    Kansas
    Posts
    204
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Here is the information from the link above:
    Problem(Abstract)When the data is being backed up to a Tape Library/Drive, the following error is received during a write operation:
    ANR9999D_0521343731 NtpOpen(pvrntp.c:1296) Thread<36>: Could not determine media type, rc = 1

    SymptomThe label and checkin functions of the TSM Server work fine without any issues.

    CauseWrong Drivers for the Library / Drives. Microsoft drivers were installed for the IBM LTO Drive.

    Resolving the problemPlease verify that you are using the correct drivers for the device, you can review the following links for more info on which drivers are needed:

    IBM Tivoli Storage Manager Supported Devices for AIX HPUX SUN WIN
    http://www-01.ibm.com/software/sysmg...XHPSUNWIN.html

    IBM Tivoli Storage Manager Supported Devices for Linux
    http://www-01.ibm.com/software/sysmg...for_Linux.html

  7. #7
    Member LanSchroeder's Avatar
    Join Date
    Nov 2007
    Location
    Wisconsin
    Posts
    51
    Thanks
    1
    Thanked 1 Time in 1 Post

    Default

    I still cannot seem to find the correct spot i need. I have a IBM Ultrium-TD4 LTO4 tape drive. Is it in a bundle package somewhere?
    Right now the server defaults to some Microsoft driver which is causing this error.

  8. #8
    Member
    Join Date
    Jun 2004
    Location
    Kansas
    Posts
    204
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    http://www-933.ibm.com/support/fixcentral/

    Go here and following the prompts:
    Storage Systems
    Tape Systems
    Tape and device drivers and software
    Tape device drivers

  9. #9
    Member
    Join Date
    Jun 2004
    Location
    Kansas
    Posts
    204
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    If the normal installation doesn't work properly here is IBM's recommended installation process:
    First: ( Do not reboot when prompted but reboot at the end of the uninstall)
    The latest "IBM Tape Device Drivers Installation and User's Guide"
    recommends the following steps if upgrading the IBM driver and a
    previous driver had been applied to devices:

    Device Removal or Disable Procedure
    If you need to remove a device, or if you are altering the hardware
    configuration, you will need to uninstall or disable the device first:

    * 1. Right-click My Computer, select Manage to open the Computer
    * * Management Console, and click Device Manager.
    *2. Right-click the TotalStorage or Magstar device you wish to
    * * uninstall and select Uninstall .... If you wish to disable the
    * * device without uninstalling it, you may select Disable.
    *3. You are prompted to confirm the uninstallation. Click OK.
    *4. In Device Manager, under System devices, right click Changer Bus
    * * Enumerator and select Uninstall.
    *5. In Device Manager, under System devices, right click Tape Bus
    * * Enumerator and select Uninstall.

    * NOTE: This removal procedure removes the device from the device tree,
    * * * *but it does not uninstall the device driver files from your hard disk.

    Uninstalling the Device Drivers

    To uninstall the device drivers from the system, which includes deleting
    the system files and deallocating other system resources, complete the
    following:

    * 1. Complete the steps under Device Removal or Disable Procedure to
    * * remove the tape and medium changer devices.
    *2. Double-click uninst.exe in the driver package.

    * Note: This removes all the files in the system directories that were
    * * * *created during the installation of the device driver. It doesexit
    * * * *not delete the .zip file or the files that were extracted from
    * * * *the .zip file. If you desire to remove these files, you need to
    * * * *delete them manually.

    * 3. Reboot the system


    Installation:
    1. Once the system has rebooted open a DOS prompt.
    2. Move to the driver directory which is currently C :\TSM INSTALL FILES\TAPE LIBRARY DRIVERS
    3. Run install_execlusive.exe to install the drivers
    4. REBOOT
    5. Installation is done

  10. #10
    Member LanSchroeder's Avatar
    Join Date
    Nov 2007
    Location
    Wisconsin
    Posts
    51
    Thanks
    1
    Thanked 1 Time in 1 Post

    Default

    Ok i did that process but it the in the device manager it has every tape drive "Cannot initialize device driver for this hardware"

  11. #11
    Member
    Join Date
    Jun 2004
    Location
    Kansas
    Posts
    204
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    What is the library using for a driver?

  12. #12
    Member LanSchroeder's Avatar
    Join Date
    Nov 2007
    Location
    Wisconsin
    Posts
    51
    Thanks
    1
    Thanked 1 Time in 1 Post

    Default

    I tried a few different driver packages using that method and none seemed to work.

    It is using IBM Tivoli Storage Manager for Medium Changers. I never had any issues moving around tapes in the library just when pushing or pulling data to the tapes.

    I decided to pull the rip cord for today on this and i'm going back to the old server for the time being. Clearly i need to do some more testing and maybe opening a PMR with IBM. Thanks for the help with everything so far fuzzballer! I'm sure i'll be using this knowledge in the future!

Similar Threads

  1. Could not determine media type RC=1 TS3200
    By AjM in forum Tape / Media Library
    Replies: 2
    Last Post: 06-28-2011, 05:04 PM
  2. Dell ML6000 Library and TSM 5.4.2 Windows
    By ttercero in forum Tape / Media Library
    Replies: 4
    Last Post: 12-29-2008, 11:34 PM
  3. Dell ML6000 Library BarCode Label
    By ttercero in forum Tape / Media Library
    Replies: 1
    Last Post: 09-03-2008, 05:03 PM
  4. How can I determine media type?
    By MartyM in forum Tape / Media Library
    Replies: 7
    Last Post: 08-25-2008, 02:09 AM
  5. Could not determine media type
    By budwiser in forum TSM Server
    Replies: 0
    Last Post: 03-02-2005, 12:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •