Results 1 to 7 of 7
  1. #1
    Newcomer
    Join Date
    Jun 2011
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question Mixing TSM + NDMP operations in the same 3584/TS3500 library

    Hi to you all,

    We have completed a setup of NDMP backup to our TS3500 library containing 6 drives: 4 LTO3 and 2 LTO4. The basic idea is very simple: LTO3 drives are used for normal TSM operations (file backups of 200 servers). LTO4 drives are dedicated to NDMP backups of our netApp NAS. We didn't partition our library. LTO4 drives are defined to TSM as remote drives. LTO3 drives are defined as normal SCSI drives.

    Here is the problem. At the beginning of NDMP implementation and testing, we used LTO3 tapes for test purposes and everything works fine. Trouble is: we bought LTO4 tapes and checked them in as scratch. When doing new NDMP backups to LTO4 drives, TSM keeps using LTO3 tapes instead or priorizing LTO4 one... Why? My expectations were that TSM knows there are LTO4 tapes in the library and would use them in LTO4 drives... How can we force TSM to use LTO4 tapes for NDMP operations...

    Any hint?

  2. #2
    Member
    Join Date
    Apr 2005
    Posts
    12
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Default

    If you checkin both LTO3 and LTO 4 tapes into the same library there is no way to force the LTO4 scratch tapes to be used. What you need to do is enable ALMS on your library and make a new library partition with your LTO4 drives and tapes. You have to purchase an ALMS license to do this.

  3. #3
    Moderator mikeymac's Avatar
    Join Date
    Jun 2003
    Location
    Syracuse, NY
    Posts
    896
    Thanks
    9
    Thanked 12 Times in 12 Posts

    Default

    Are the backups going to a storage pool that is defined with an LTO-4 device class?

  4. #4
    Newcomer
    Join Date
    Jun 2011
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Yes. TSM management de tapes mounts and unmounts but the netApp box is doing the data movement over FC.

  5. #5
    Member Mikey D's Avatar
    Join Date
    Mar 2007
    Location
    Southeast Michigan
    Posts
    268
    Thanks
    0
    Thanked 5 Times in 5 Posts

    Default

    Like Mikeymac said

    You need to have separate device classes for your storage pools if you'd like to force one pool to use 4's versus 3's. You would have to hard set the drive format to ULTRIUM4C or ULTRIUM3C depending on your pool.

    The pool should be separate already since it's an NDMP pool so shouldn't be hard to change over

    Otherwise if you don't want that option then partition the library and perform all the other steps that'll go along with it.

  6. #6
    Newcomer
    Join Date
    Jun 2011
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    I have defined a DEVCLASS of type NAS for these drives. In that situation, there is no way to set the format of the drives. Also, labeling new scratch LTO4 tapes is problematic: the label command can't label tapes because there is no drives available directly to TSM to mount the tape and format it. Setting the library to use the AUTOLABEL to YES doesn't help either. Yesterday, I checkin LTO4 tapes with bar code but un labeled. When the NDMP backup started, TSM mounted the tapes but generated an error saying it could not read the label...

  7. #7
    Member Mikey D's Avatar
    Join Date
    Mar 2007
    Location
    Southeast Michigan
    Posts
    268
    Thanks
    0
    Thanked 5 Times in 5 Posts

    Default

    Yeah that is a bit of an issue, it's been so long since I've done anything with NDMP I must admit I didn't think about that. Here's an idea, I thought you could do a library manager/client relationship and use NDMP? If that was an option you could still have your separate device class but then you could have the LTO4 drives in the same library as your regular one so you could label them.

    I know you can define paths for datamovers so this should work, this is how we setup our last NDMP setup a few years back at my old company.

    Outside of that you're looking at having to partition them

Similar Threads

  1. Mixing LT02 and LT04 in same library
    By LarryB in forum Tape / Media Library
    Replies: 9
    Last Post: 02-14-2011, 01:06 AM
  2. Multiple TSM Servers with single IBM 3584 (TS3500)
    By jharris in forum VTL - Virtual Tape Library
    Replies: 6
    Last Post: 08-19-2010, 10:52 AM
  3. Six LTO3 Tape Drives for Sale (3584\TS3500)
    By gyuzik in forum Trading Post - For Computer and Data Storage Related Hardware/Software Sale or Want to Buy
    Replies: 6
    Last Post: 04-12-2009, 03:38 PM
  4. Mixing 3592 and LTO 3 drives in same library
    By bigmonkey30 in forum Tape / Media Library
    Replies: 1
    Last Post: 04-13-2007, 06:37 PM
  5. Replacing a 3584 with a TS3500
    By Stephan in forum Tape / Media Library
    Replies: 6
    Last Post: 02-08-2007, 09:47 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •