Results 1 to 4 of 4
  1. #1
    Newcomer
    Join Date
    Mar 2011
    Location
    New Zealand
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Recover TSM 6.2.1 database from tape

    Hi Guys,

    I am totally new to TSM so need some expert help.

    I am trying to recover a TSM server (windows) onto new hardware. Got the tape (LTO3) that has the DBBackup. So this is what I have done so far:

    1. Created a new server with a tape drive attached. (will connect library once I get the database back)
    2. Installed TSM 6.2.1
    3. Initialiazed the server
    4. Configured the tape drive to use TSM device drivers

    Now I need to restore the database. This is the command I tried:

    dsmserv -k Server1 restore db devclass=LTOCLASS1 volumenames="XXXXX" commit=yes

    The command fails with error: ANR2020E RESTORE DB: Invalid parameter - DEVCLASS

    I have checked in the devcnfg.out file for devclass value and it is LTOCLASS1

    What is it that I am doing wrong? I urgently need to get this working.

    All your help is greatly appreciated.

    Regards
    DG
    Last edited by dineshgoundar; 03-20-2011 at 06:18 PM. Reason: More details

  2. #2
    Moderator Harry_Redl's Avatar
    Join Date
    Dec 2003
    Location
    Czech Republic
    Posts
    2,201
    Thanks
    3
    Thanked 97 Times in 96 Posts

    Default

    Hi,

    way you used was for TSM 5.x - in 6.x things changed - you need volhist.out file (no chance restoring the DB without it).
    Check the syntax of the "dsmserv restore db" command here:
    http://publib.boulder.ibm.com/infoce...re_db_pit.html

    Harry

  3. #3
    Newcomer
    Join Date
    Mar 2011
    Location
    New Zealand
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Hi Harry_Redl

    Thanks for the reply. I have gone through the link you sent me. So do I need to have the device configuration file as well. I am using different hardware though.

  4. #4
    Member
    Join Date
    Mar 2008
    Location
    Minden
    Posts
    169
    Thanks
    1
    Thanked 2 Times in 2 Posts

    Default

    The most importent File you need are volhist.out and devconfig.out.
    if you have new Hardware run, Path to Tivoli\tsm\console\tsmdlst.exe to see witch lb,mt your new server use.
    you can edit the devconfig file with that entrys.

    the best way for me is to backup the DB to a devclass file.
    If you have access to this from both servers.

    Make sure that your Instanz user is owner of the DB directorys,
    and member of the groups DB2admns, db2users.
    If you start restore db, the new Db directorys are should be empty.
    Or stop Db2 and run dsmserv.exe remove Db on the new Server before.
    Sorry for my english.

    regards
    michael

Similar Threads

  1. How to take TSM Database backup to tape
    By helmsdeep in forum Backup / Archive Discussion
    Replies: 9
    Last Post: 11-03-2010, 11:34 PM
  2. Database recover!
    By kyle007 in forum TSM Operation
    Replies: 3
    Last Post: 06-28-2010, 12:52 PM
  3. TSM: 5.5.2: Bad Tape - need to recover
    By pichelman in forum TSM Server
    Replies: 19
    Last Post: 03-18-2010, 04:22 PM
  4. TSM database backup on one tape???
    By dpomatto in forum TSM Server
    Replies: 2
    Last Post: 06-10-2008, 01:54 PM
  5. Restore files on tape but not in TSM database
    By marten.edelbrink in forum Restore / Recovery Discussion
    Replies: 10
    Last Post: 06-20-2007, 08:59 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •