Hello Team,

An informational post here to help anybody else coming up against this in the future - it is something I've encountered a couple of times now when attempting to install the TSM FastBack client onto a Windows system.

In a nutshell, what looks like a successful client installation isn't, and backups fail as a result with a relatively obscure error. What should be a simple pre-req check in the FastBack installation package hasn't been implemented or isn't currently alerting. In this post, I discuss the error scenario, how to identify it, and a couple of ways to resolve it.

To all intents and purposes a TSM FastBack Client installation appears to complete successfully - the installation asks for a reboot at the end and, when restarted, the client connects successfully to the FastBack Server which can correctly identify its volumes and schedule a backup. Textbook stuff.

However, any attempts to backup of one of the client volumes appears to stall and ultimately fail - the Server's Snapshot Monitor reports an Aborted backup due to:

FBSS7011E VSS freeze failed on [client name]
FBSS7005E VSS reporting an error on [client name]
FBSS7027E System error. Fault [1:0x00001500]. Process ended
In the Application Event Log on the FastBack Client side we see the following alert:

Volume Shadow Copy Service error: A critical component required by the Volume Shadow Copy service is not registered. This might happened if an error occurred during Windows setup or during installation of a Shadow Copy provider. The error returned from CoCreateInstance on class with CLSID {ffdde664-2e31-4d97-bdb6-fd9e6a318920} and Name SW_PROV is [0x80040154].
At this point, the key thing to verify is whether the XR_VSS service is correctly installed - you can check for its existence in the Services applet. If it's not showing here, then it's likely that it hasn't been able to register properly. The main cause that I've seen is that the Distributed Transaction Coordinator service isn't running and/or is disabled - commonly this gets locked down in corporate standard OS builds. Simple re-enable this service and re-install the TSM FastBack client or manually register the service with the following command:

Code:
C:\PROGRA~1\Tivoli\TSM\FastBack\client\REGIST~1.VBS -register XR_VSS C:\PROGRA~1\Tivoli\TSM\FastBack\client\FASTBA~1.DLL FastBack_VSS
The XR_VSS service should now appear in the client's Services listing and subsequent backup attempts should be successful (or at least not fail because of this error...).

HTH,
__________
David Mc
London, UK