Results 1 to 4 of 4
  1. #1
    Newcomer
    Join Date
    Feb 2010
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default NetWorker: recover to different client does not work

    Hello everybody,

    I hope someone could help me out with this problem:

    I try to recover data from clientA:/directoryA/ to clientB:/directoryB/.
    Both clients are SunOS 5.10 with NetWorker client 7.2 (NetWorker Server also 7.2).

    First I tried it with the GUI (from the server, clientA and clientB). I marked the folder (which contains about 30 subfolders), changed source and target client and the target directory and startet the recover (about 280 GB).

    Output after some minutes:

    Volumes needed (all on-line):
    D01320 at CentricStore1
    D01324 at CentricStore1
    D01323 at CentricStore1
    D01322 at CentricStore1
    D01321 at CentricStore1
    D01325 at CentricStore1
    D01326 at CentricStore1
    D01327 at CentricStore1
    D01328 at CentricStore1
    D01329 at CentricStore1
    D01330 at CentricStore1
    D01331 at CentricStore1
    D01332 at CentricStore1
    D01333 at CentricStore1
    D01334 at CentricStore1
    D01338 at CentricStore1
    D01340 at CentricStore1
    D01341 at CentricStore1
    D01345 at CentricStore1
    Initiating remote recover to clientB from server NWserver, this may take a while...
    Recover completion time: (some minutes)

    So, nothing happend. No data was recovered and even no tape requested.
    I tried that several times with some different results:

    When the target client is the same as the source client, the recover starts without problems and immediately.
    With target clientC it is the same as with clientB.
    With only some subdirectories marked, the recover works. But not with all (with some smaller direcotories it works, with a 60 GB subdirectory not - see output above).

    By using CLI command I got this output:

    root@oi4130# recover -c clientA -i R -R clientB -d /directoryB/ /directoryA/
    recover: Using NWserver as server for clientA
    recover: Current working directory is /directoryA/
    recover> recover
    Initiating remote recover to clientB from server NWserver, this may take a while...
    recover: recover: Using NWserver as server for clientA
    recover: Nothing to recover
    recover: nsrexec exited with code 254
    recover: Remote recover to "clientB" failed Recover completion time: ... recover> quit

    Does anyone has an idea what the problem could be?!?!

    Kind regards,
    Maaak

  2. #2
    Newcomer
    Join Date
    May 2008
    Location
    Europe
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Thumbs up

    Login to the client where you want the data restored to. {Target}
    In your case login to client B.

    Recover -c clientA {source}
    select files
    begin recovery

    If you try and do it from the backup server you can restore the data TO the backup server!

    Ensure that all network communication is clear and in theory it should all work.
    Good luck

  3. #3
    Newcomer
    Join Date
    Feb 2010
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Now it works. I forgot the add command in the recover shell.
    Curiously it also works with the NetWorker GUI now altough I did no changes since the last (unsuccessful) try...

    Thanks a lot so far!

  4. #4
    Newcomer
    Join Date
    Aug 2010
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Post

    Quote Originally Posted by Maaak View Post
    Hello everybody,

    I hope someone could help me out with this problem:

    I try to recover data from clientA:/directoryA/ to clientB:/directoryB/.
    Both clients are SunOS 5.10 with NetWorker client 7.2 (NetWorker Server also 7.2).

    First I tried it with the GUI (from the server, clientA and clientB). I marked the folder (which contains about 30 subfolders), changed source and target client and the target directory and startet the recover (about 280 GB).

    Output after some minutes:

    Volumes needed (all on-line):
    D01320 at CentricStore1
    D01324 at CentricStore1
    D01323 at CentricStore1
    D01322 at CentricStore1
    D01321 at CentricStore1
    D01325 at CentricStore1
    D01326 at CentricStore1
    D01327 at CentricStore1
    D01328 at CentricStore1
    D01329 at CentricStore1
    D01330 at CentricStore1
    D01331 at CentricStore1
    D01332 at CentricStore1
    D01333 at CentricStore1
    D01334 at CentricStore1
    D01338 at CentricStore1
    D01340 at CentricStore1
    D01341 at CentricStore1
    D01345 at CentricStore1
    Initiating remote recover to clientB from server NWserver, this may take a while...
    Recover completion time: (some minutes)

    So, nothing happend. No data was recovered and even no tape requested.
    I tried that several times with some different results:

    When the target client is the same as the source client, the recover starts without problems and immediately.
    With target clientC it is the same as with clientB.
    With only some subdirectories marked, the recover works. But not with all (with some smaller direcotories it works, with a 60 GB subdirectory not - see output above).

    By using CLI command I got this output:

    root@oi4130# recover -c clientA -i R -R clientB -d /directoryB/ /directoryA/
    recover: Using NWserver as server for clientA
    recover: Current working directory is /directoryA/
    recover> recover
    Initiating remote recover to clientB from server NWserver, this may take a while...
    recover: recover: Using NWserver as server for clientA
    recover: Nothing to recover
    recover: nsrexec exited with code 254
    recover: Remote recover to "clientB" failed Recover completion time: ... recover> quit

    Does anyone has an idea what the problem could be?!?!

    Kind regards,
    Maaak
    Thanks for you information i newly join and your post help me.

Similar Threads

  1. Password doesn't work in Web Client
    By JonRoenick in forum Web GUI
    Replies: 2
    Last Post: 11-25-2008, 04:10 PM
  2. client optionset doen't work
    By TSMRONALD in forum TSM Installation, Upgrade and Configuration
    Replies: 3
    Last Post: 07-07-2008, 04:00 PM
  3. Looking for TSM admin job to work remotely(work from home)
    By reddy in forum Storage Management Jobs
    Replies: 0
    Last Post: 03-17-2006, 05:03 PM
  4. Journaling, NT, Client 5.1.6.0 - Does/Can It Work
    By Nicko in forum Backup / Archive Discussion
    Replies: 2
    Last Post: 12-20-2005, 03:50 AM
  5. recover without TSM client
    By jdefontenay in forum Backup / Archive Discussion
    Replies: 0
    Last Post: 09-14-2004, 04:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •