Results 1 to 2 of 2
  1. #1
    Member
    Join Date
    Jan 2005
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default Lin_tape and Control Point Failover

    Greetings. I have a RHEL 4 box running TSM 5.4.3.0 using lin_tape(d) 1.23.0 and ibmatl 6.7.5.0 to access a shared 3584 library managed by another TSM server. I've added the appropriate options line to /etc/modprobe.conf to implement tape path and control point failover, and while the tape path failover looks fine:

    cat /proc/scsi/IBMtape
    lin_tape version: 1.23.0
    lin_tape major number: 253
    Attached Tape Devices:
    Number model SN HBA FO Path
    0 03592J1A 000001234567 qla2xxx Primary
    1 03592J1A 000002345678 qla2xxx Primary
    2 03592J1A 000003456789 qla2xxx Primary
    3 03592J1A 000004567890 qla2xxx Primary
    4 03592J1A 000001234567 qla2xxx Alternate
    5 03592J1A 000002345678 qla2xxx Alternate
    6 03592J1A 000003456789 qla2xxx Alternate
    7 03592J1A 000004567890 qla2xxx Alternate

    the control point failover does not:

    cat /proc/scsi/IBMchanger
    lin_tape version: 1.23.0
    lin_tape major number: 253
    Attached Tape Devices:
    Number model SN HBA FO Path
    0 03584L22 0000000A12345678 qla2xxx NA
    1 03584L22 0000000A12345678 qla2xxx NA

    It sees both paths to the library, but does not set them up as a Primary-Alternate pair like I expected or as the docs say it should. The 3584 library does have the failover path feature code installed. Is this what I should be seeing since this server is not the library manager, or should I see the Primary-Alternate failover paths anyway, or does it even matter if it's set up Primary-Alternate or not since it shows both paths to the library control point? I am planning to migrate the library manager function to this TSM server, but am hesitant to do so until I have this control point failover question resolved. Any insight is appreciated.

    Regards,

    Dmarsee

  2. #2
    Moderator moon-buddy's Avatar
    Join Date
    Aug 2005
    Location
    Somewhere in the US
    Posts
    5,950
    Thanks
    4
    Thanked 235 Times in 230 Posts

    Default

    I believe that what you are seeing is correct since as you said "since this server is not the library manager".
    Ed

Similar Threads

  1. Linux/Lin_Tape/Sandiscovery
    By janecb in forum TSM Installation, Upgrade and Configuration
    Replies: 2
    Last Post: 02-14-2013, 03:42 AM
  2. lin_tape on SLES 11 does not build
    By RJNeilly in forum Tape / Media Library
    Replies: 1
    Last Post: 10-14-2009, 05:54 PM
  3. Control Path Failover on EMC VTL
    By Sunhillow in forum VTL - Virtual Tape Library
    Replies: 0
    Last Post: 01-29-2008, 09:08 AM
  4. Control Path failover
    By rchoudarapu in forum Tape / Media Library
    Replies: 0
    Last Post: 10-29-2007, 08:44 AM
  5. 3584 failover of a library control path
    By vreinen in forum Tape / Media Library
    Replies: 0
    Last Post: 05-16-2003, 06:11 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •