Results 1 to 10 of 10
  1. #1
    Newcomer
    Join Date
    Jun 2009
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default ANS0299E Scheduler cannot be started manually

    This is the error message I'm getting.

    "ANS0299E Scheduler cannot be started manually because the value of MANAGEDSERVICES option is SCHEDULE".

    I've searched the forums, and the IBM site and neither shed any light on the issue I'm having. (Also I'm not trying to manually start the client scheduler service to cause this).

    The dsm.opt file is configured as:

    MANAGEDSERVICES SCHEDULE WEBCLIENT

    The dsmcad TSM Client Acceptor service is set to automatic, whilst the TSM schedule service is set to manual. We never try and set the TSM schedule service on the client to automatic or start it, as the schedule is controlled from the TSM server - which has succeeded in the past.

    We're at a loss while all of sudden it is not working. We can ping the TSM server from the client, and when we do a "QUERY SESSION" from the dsmc command line on the client we get a return of:

    tsm> query session
    Session established with server ABCD5678_SERVER1: Windows
    Server Version 5, Release 5, Level 1.0
    Server date/time: 07/21/2009 17:38:27 Last access: 07/21/2009 16:56:26

    TSM Server Connection Information

    Server Name.............: ABCD5678_SERVER1
    Server Type.............: Windows
    Archive Retain Protect..: "No"
    Server Version..........: Ver. 5, Rel. 5, Lev. 1.0
    Last Access Date........: 07/21/2009 16:56:26
    Delete Backup Files.....: "No"
    Delete Archive Files....: "Yes"

    Node Name...............: ABCD1234
    User Name...............:

    If I could provide any further information I'd be glad to. Thanks if anyone can help.

  2. #2
    Senior Member
    Join Date
    Feb 2003
    Location
    Charlotte, NC
    Posts
    288
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default

    Don't set the scheduler service to automatic nor start it. The Client Acceptor starts and stops that service as needed. Only the Client Acceptor needs to be auto/started.

  3. #3
    Newcomer
    Join Date
    Jun 2009
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    I believe that's what I said in my original post

    "The dsmcad TSM Client Acceptor service is set to automatic, whilst the TSM schedule service is set to manual. We never try and set the TSM schedule service on the client to automatic or start it, as the schedule is controlled from the TSM server - which has succeeded in the past." the

    The backup succeeds when you run an incremental from the client backup-archive command line.

  4. #4
    Senior Member
    Join Date
    Feb 2003
    Location
    Charlotte, NC
    Posts
    288
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default

    Sorry, had too many things going and misread that part. That's the cause of the error you posted...

    Have you restarted the Client Acceptor? If you do, then check the dsmsched.log about 10 minutes later and see if you have a schedule banner pulled from server. If not, then check dsmerror.log and see if any new messages show up there. Also, has the node's password changed recently? I've seen where the encrypted password in the Windows registry doesn't update correctly after a change. You'll usually have to delete and recreate the TSM services to get that fixed.

  5. #5
    Newcomer
    Join Date
    Jun 2009
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Thank you very much indeed for taking the time to read and respond, I really appreciate it.

    I had tried restarting the Client Acceptor, but I did it again just now, and I do get the banner in the dsmsched.log:

    07/22/2009 15:42:12 Scheduler has been started by Dsmcad.
    07/22/2009 15:42:12 TSM Backup-Archive Client Version 5, Release 5, Level 1.0
    07/22/2009 15:42:12 Querying server for next scheduled event.
    07/22/2009 15:42:12 Node Name: ABCD1234
    07/22/2009 15:42:16 Session established with server ABCD5678_SERVER1: Windows
    07/22/2009 15:42:16 Server Version 5, Release 5, Level 1.0
    07/22/2009 15:42:16 Server date/time: 07/22/2009 15:42:16 Last access: 07/22/2009 15:42:10


    07/22/2009 15:42:16 --- SCHEDULEREC QUERY BEGIN
    07/22/2009 15:42:21 --- SCHEDULEREC QUERY END
    07/22/2009 15:42:21 Next operation scheduled:
    07/22/2009 15:42:21 ------------------------------------------------------------
    07/22/2009 15:42:21 Schedule Name: DAILY
    07/22/2009 15:42:21 Action: Incremental
    07/22/2009 15:42:21 Objects:

    07/22/2009 15:42:21 Options:
    07/22/2009 15:42:21 Server Window Start: 21:30:00 on 07/22/2009
    07/22/2009 15:42:21 ------------------------------------------------------------
    07/22/2009 15:42:21 Scheduler has been stopped.


    We haven't changed the password since install, but to cover all bases I have uninstalled The TSM client and services (with dsmcutil rem /name:"<service name>" command and reinstalled them.

    Let's see if the schedule runs tonight. Will update the thread anyway.
    Last edited by mmeridius; 07-22-2009 at 12:18 PM. Reason: bad grammar

  6. #6
    Moderator moon-buddy's Avatar
    Join Date
    Aug 2005
    Location
    Somewhere in the US
    Posts
    5,951
    Thanks
    4
    Thanked 235 Times in 230 Posts

    Default

    Quote Originally Posted by mmeridius View Post
    The dsm.opt file is configured as:

    MANAGEDSERVICES SCHEDULE WEBCLIENT
    Should be: MANAGEDSERVICES WEBCLIENT SCHEDULE
    Ed

  7. #7
    Newcomer
    Join Date
    Jun 2009
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Have tried MANAGEDSERVICES WEBCLIENT SCHEDULE as well as MANAGEDSERVICES SCHEDULE WEBCLIENT in the dsm.opt.

    Doesn't make any difference unfortunately. And according to IBM either way around is correct:

    http://publib.boulder.ibm.com/infoce...ns30000207.htm

    Task
    Specify that the CAD manages both the Web client and the scheduler.
    managedservices schedule webclient
    Note:
    The order in which these values are specified is not important.

  8. #8
    Moderator moon-buddy's Avatar
    Join Date
    Aug 2005
    Location
    Somewhere in the US
    Posts
    5,951
    Thanks
    4
    Thanked 235 Times in 230 Posts

    Default

    Quote Originally Posted by mmeridius View Post
    Have tried MANAGEDSERVICES WEBCLIENT SCHEDULE as well as MANAGEDSERVICES SCHEDULE WEBCLIENT in the dsm.opt.

    Doesn't make any difference unfortunately. And according to IBM either way around is correct:

    http://publib.boulder.ibm.com/infoce...ns30000207.htm

    Task
    Specify that the CAD manages both the Web client and the scheduler.
    managedservices schedule webclient
    Note:
    The order in which these values are specified is not important.
    Not from my experience...
    Ed

  9. #9
    Newcomer
    Join Date
    Jun 2009
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    reset password. dsm.opt read:

    MANAGEDSERVICES WEBCLIENT SCHEDULE

    No luck. Backup missed schedule again. No messages in dsmsched.log dsmerror.log

    Thanks for your suggestions all the same

  10. #10
    Senior Member
    Join Date
    Feb 2003
    Location
    Charlotte, NC
    Posts
    288
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default

    Do you see anything in the actlog on TSM Server at the time the schedule is supposed to run? Looks like it was 21:30:00 from the banner - anything from 21:30-22:00 relevant in actlog?

Similar Threads

  1. manually eject
    By madunix in forum Tape / Media Library
    Replies: 5
    Last Post: 08-07-2008, 11:26 AM
  2. Check out tapes manually.
    By khawts in forum Tape / Media Library
    Replies: 5
    Last Post: 09-18-2007, 05:51 PM
  3. Getting started with SYSBACK
    By rugenl in forum Restore / Recovery Discussion
    Replies: 0
    Last Post: 11-10-2006, 10:42 AM
  4. Need help getting started
    By Dave09 in forum Training and Certification
    Replies: 4
    Last Post: 02-06-2006, 10:13 AM
  5. Problem with the TSM Client Acceptor Service (ANS0299E)
    By hansbauj in forum Backup / Archive Discussion
    Replies: 4
    Last Post: 09-29-2004, 08:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •