Results 1 to 7 of 7
  1. #1
    Member
    Join Date
    Sep 2005
    Location
    Wellington, New Zealand
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question Backup data skipping disk pool

    Hi,

    I'm having a problem with client backups going straight to tape instead of disk pools first. And they shouldn't!

    The clients are defined to use a management class (XCH_MC) that specifies a diskpool (DISKPOOL2) as a copy destination. DISKPOOL2 has a tape pool called TAPEPOOL2 as it's next destination. Whenever I run a backup from any of the clients the data appears to go straight to the tape pool. i.e. I see the BA Client waiting for media, and the actlog shows a tape being mounted. I've run queries to see what volumes contain client data and it's always the tapepool.

    We do run scheduled migrations from DISKPOOL2 to TAPEPOOl2 buy they always say "There is no data to migrate"

    I can't see any evidence of the disk pool ever being used.

    I have another chain from clients to DISKPOOL1 to TAPEPOOL1 and that works just fine. Can't find any errors client or server side.

    Anyone have any ideas? It's clogging up tape drives unnecessarily. Thanks in advance!!

    Here's the detail on my stgpool:

    tsm: WNMGTSM01_SERVER1>q stgpo diskpool2 f=d

    Storage Pool Name: DISKPOOL2
    Storage Pool Type: Primary
    Device Class Name: DISK
    Estimated Capacity: 500 G
    Space Trigger Util: 0.0
    Pct Util: 0.0
    Pct Migr: 0.0
    Pct Logical: 100.0
    High Mig Pct: 90
    Low Mig Pct: 70
    Migration Delay: 0
    Migration Continue: Yes
    Migration Processes: 2
    Reclamation Processes:
    Next Storage Pool: TAPEPOOL2
    Reclaim Storage Pool:
    Maximum Size Threshold: No Limit
    Access: Read/Write
    Description: Pri.Disk StoragePool for Oracle-Exchange Backup
    Overflow Location:
    Cache Migrated Files?: No
    Collocate?:
    Reclamation Threshold:
    Offsite Reclamation Limit:
    Maximum Scratch Volumes Allowed:
    Number of Scratch Volumes Used:
    Delay Period for Volume Reuse:
    Migration in Progress?: No
    Amount Migrated (MB): 0.00
    Elapsed Migration Time (seconds): 0
    Reclamation in Progress?:
    Last Update by (administrator): ADMIN
    Last Update Date/Time: 06-12-2007 13:10:33
    Storage Pool Data Format: Native
    Copy Storage Pool(s):
    Active Data Pool(s):
    Continue Copy on Error?: Yes
    CRC Data: No
    Reclamation Type:
    Overwrite Data when Deleted:
    Last edited by littlepunk; 12-10-2008 at 11:28 PM.

  2. #2
    Senior Member
    Join Date
    Jul 2008
    Location
    Birmingham, UK
    Posts
    537
    Thanks
    0
    Thanked 5 Times in 4 Posts

    Default

    Hi

    are the diskpool volumes definetly online..

    do "q vol stgpool=diskpool2"

    can you post the output of "q copygroup f=d" for the relevant copygroup.

    Cheers

  3. #3
    Member Mikey D's Avatar
    Join Date
    Mar 2007
    Location
    Southeast Michigan
    Posts
    272
    Thanks
    0
    Thanked 5 Times in 5 Posts

    Default

    Can you post the other management classes and their associated bu and archive copygroups.

    There's a design flaw in TSM where if you have other management classes that go direct to tape and they happen to be in a higher alpha order (i.e. XCH_MC then ZCH_MC) the it will use the ZCH_MC for any directory structures and they would be sent direct to tape.

    You can work around this two ways, either specify DIRMC for the nodes or just make a higher alpha order mgmt class that goes direct to disk so the directories get stored where they should.

  4. #4
    Member
    Join Date
    Sep 2008
    Posts
    21
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    I think you may have forgotten to define a volume for the storage pool.

    Does: 'q vol stgpool=diskpool2' return any results? If not, this is the problem and you should look at 'help define volume'.

  5. #5
    Member
    Join Date
    Sep 2005
    Location
    Wellington, New Zealand
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    I definitely have a stgpool that's online. Below is some further details on the stgpool, copygroups and the specific mgmt class involved.

    -------------------------------

    tsm: WNMGTSM01_SERVER1>q vol stgpool=diskpool2
    Session established with server WNMGTSM01_SERVER1: Windows
    Server Version 5, Release 5, Level 0.3
    Server date/time: 12-12-2008 08:34:45 Last access: 11-12-2008 16:15:56


    Volume Name Storage Device Estimated Pct Volume
    Pool Name Class Name Capacity Util Status
    ------------------------ ----------- ---------- --------- ----- --------
    S:\DP_DB\VOL01.DSM DISKPOOL2 DISK 250,000.0 0.0 On-Line
    T:\DP_DB\VOL02.DSM DISKPOOL2 DISK 250,000.0 0.0 On-Line



    tsm: WNMGTSM01_SERVER1>q copygr wnprdxch

    Policy Policy Mgmt Copy Versions Versions Retain Retain
    Domain Set Name Class Group Data Data Extra Only
    Name Name Name Exists Deleted Versions Version
    --------- --------- --------- --------- -------- -------- -------- -------
    WNPRDXCH ACTIVE XCH_MC STANDARD No Limit No Limit 35 35
    WNPRDXCH ACTIVE XCH_MONT- STANDARD 13 13 370 370
    HLY_MC
    WNPRDXCH ACTIVE XCH_YEAR- STANDARD 21 21 7,320 7,320
    LY_MC
    WNPRDXCH WNPRDXCH XCH_MC STANDARD No Limit No Limit 35 35
    WNPRDXCH WNPRDXCH XCH_MONT- STANDARD 13 13 370 370
    HLY_MC
    WNPRDXCH WNPRDXCH XCH_YEAR- STANDARD 21 21 7,320 7,320
    LY_MC


    tsm: WNMGTSM01_SERVER1>q copygr wnprdxch active xch_mc f=d

    Policy Domain Name: WNPRDXCH
    Policy Set Name: ACTIVE
    Mgmt Class Name: XCH_MC
    Copy Group Name: STANDARD
    Copy Group Type: Backup
    Versions Data Exists: No Limit
    Versions Data Deleted: No Limit
    Retain Extra Versions: 35
    Retain Only Version: 35
    Copy Mode: Modified
    Copy Serialization: Shared Static
    Copy Frequency: 0
    Copy Destination: DISKPOOL2
    Table of Contents (TOC) Destination:
    Last Update by (administrator): ADMIN
    Last Update Date/Time: 30-05-2007 12:19:43
    Managing profile:
    Changes Pending: No

  6. #6
    Member Mikey D's Avatar
    Join Date
    Mar 2007
    Location
    Southeast Michigan
    Posts
    272
    Thanks
    0
    Thanked 5 Times in 5 Posts

    Default

    What's the copy group info for XCH_MONTHLY_MC and XCH_YEARLY_MC?

    You've probably already checked this to but do the disk volumes show in a read/write status as well?

  7. #7
    Member
    Join Date
    Sep 2005
    Location
    Wellington, New Zealand
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Talking

    Hooray!! Solved. Thanks Mikey D.

    The storage group was online, disks were ok, but the actual disk volumes where not. Missed that in my checking.

    Thanks all! Always great to bounce problems off others.

Similar Threads

  1. how to move data from disk pool to specific tape vaolum
    By dexter1972 in forum Backup / Archive Discussion
    Replies: 5
    Last Post: 10-01-2008, 04:47 PM
  2. Disk Pool To File Library - Data Moves Right Away?
    By sunking in forum Backup / Archive Discussion
    Replies: 5
    Last Post: 04-23-2008, 08:52 AM
  3. Active Data Pool on Disk - File Device ???
    By bonobos in forum TSM Server
    Replies: 5
    Last Post: 12-06-2007, 12:04 PM
  4. Image backup - big data disk but small disk pool
    By MIKA in forum Backup / Archive Discussion
    Replies: 5
    Last Post: 10-04-2007, 12:20 PM
  5. Replies: 11
    Last Post: 11-19-2006, 03:39 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •