Results 1 to 12 of 12
  1. #1
    Member
    Join Date
    Jan 2005
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default EMC CDL Implementation Help..

    Hello,

    I am assisting with the implementation of an EMC CDL (4700 I believe), and I can't find any documentation on how to implement this into a TSM enviornment.

    Here is the TSM enviornment:

    TSM v5.4.3, running on Windows 2003
    EMC disk storage
    Dell server


    EMC setup the CDL to emulate an IBM 3584 with LTO3 drives. We are using the IBM device drivers for the changer, and the Windows native LTO driver for the drives. We were able to define the library and drives to TSM, but when we tried to backup some data to the drives we recieved the following errors:

    06/27/2008 17:02:29 ANR8337I LTO volume VT0001L3 mounted in drive MT0.3.0.2
    (mt0.3.0.2). (SESSION: 63)
    06/27/2008 17:02:29 ANR8468I LTO volume VT0001L3 dismounted from drive
    MT0.3.0.2 (mt0.3.0.2) in library LB0.0.0.2. (SESSION: 63)
    06/27/2008 17:02:29 ANR9999D pvrntp.c(1222): ThreadId <63> Could not determine
    media type, rc = 1 (SESSION: 63)
    06/27/2008 17:02:29 ANR9999D ThreadId <63> issued message 9999 from: (SESSION:
    63)
    06/27/2008 17:02:29 ANR9999D ThreadId <63> 1061896D outDiagf()+16d (SESSION:
    63)
    06/27/2008 17:02:29 ANR9999D ThreadId <63> 106FA3AA NtpOpen()+98a (SESSION:
    63)
    06/27/2008 17:02:29 ANR9999D ThreadId <63> 10703808 LtoOpen()+288 (SESSION:
    63)
    06/27/2008 17:02:29 ANR9999D ThreadId <63> 103C0450 PvrDestroyAgent()+500
    (SESSION: 63)
    06/27/2008 17:02:29 ANR9999D ThreadId <63> 10007B54 startThread()+b4
    (SESSION: 63)
    06/27/2008 17:02:29 ANR9999D ThreadId <63> 7C349565 endthreadex()+a0
    (SESSION: 63)
    06/27/2008 17:02:29 ANR9999D ThreadId <63> 77E64829 GetModuleHandleA()+df
    (SESSION: 63)
    06/27/2008 17:02:29 ANR1404W Scratch volume mount request denied - mount
    failed. (SESSION: 63)

    Anyone have any ideas? We have a PMR open with IBM and EMC.

    Thanks for any help!!

  2. #2
    Senior Member THE_WIPET's Avatar
    Join Date
    May 2006
    Location
    Montreal
    Posts
    562
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default

    Hey MTM...

    We just implement an EDL with TSM on windows... And yes it's hard to have info from EMC on how to implement it in TSM... I think it's there biggest flaw. The only difference it's with you our OS it's Win2k3 X64..

    1- Make sure that capacity on demand is disable on the VTL(wierd thing can happen with TSM)
    2- You needs to disable Remote storage on you server if it's not done
    3- Persistent binding must be activate with your HBA
    4- You need to intall the IBM TSM LTO drivers... I think it's really important to use the TSM drivers for the drive and not the windows NATIVE!
    5- Look at this tread...
    http://www.adsm.org/forum/showthread.php?t=13615
    i solve my problem with TSM.. but it's X64... but you can ask EMC/IBM if this could help.


    Hop this can help you

  3. #3
    Member
    Join Date
    Jan 2005
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    Thanks for the info.

    We tried to load the TSM drivers, but everytime we tried, it crashed (forcced re-boot) of the server.

    The only doc we had, said to use the OS native device drivers for the tape drives. But I will look at the link you posted.

  4. #4
    Senior Member THE_WIPET's Avatar
    Join Date
    May 2006
    Location
    Montreal
    Posts
    562
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default

    It's wierd they say to use the windows native drivers with TSM.. I always had the impression that with TSM,, you need the TSM drivers not the native especially in windows.

    What is you EDL.. 4700 never heard of it!.. does't it use the clarion or the symetrix?

  5. #5
    Senior Member
    Join Date
    Apr 2005
    Location
    Michigan
    Posts
    1,359
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Default

    Agreed
    And Wipet - this is a Clariion Device - a Falconstor front end.
    Steven Gabriel
    Principal -SGSolutions Inc.
    http://www.sgsolutionsinc.com

  6. #6
    Member
    Join Date
    Jan 2005
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    This is from the documentation that EMC sent us:

    For LTO drive support in Windows TSM installations, use the native operating system LTO device driver, not the TSM device driver for the drives.

  7. #7
    Senior Member
    Join Date
    Apr 2005
    Location
    Michigan
    Posts
    1,359
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Default

    Id still go with the IBM drivers - this leads you to using RSM which will create "generic" devices which you do not want. When in doubt - make a phone call
    Steven Gabriel
    Principal -SGSolutions Inc.
    http://www.sgsolutionsinc.com

  8. #8
    Senior Member THE_WIPET's Avatar
    Join Date
    May 2006
    Location
    Montreal
    Posts
    562
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default

    Sgabriel: thanks for the input... I was looking for an equivalent of the 4700 in the line of product of EMC on there sites (4106,4206,4406 or the 6000 series...)... cause our EDL is a 4106

  9. #9
    Member
    Join Date
    Jan 2005
    Posts
    22
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    sgabriel62,
    Thanks for the reply. But, just a quick overview of our expirence so far with Drivers:

    Driver used/result
    IBM Device Drivers:
    We were able to define the library, but not the drives to TSM

    Combo IBM Driver for Library, Windows LTO for Drives
    Able to define library and drives, but recieved I/O errors when trying to use drives (label libvol worked fine)

    TSM Device Driver
    Crashed server (forced reboot) when we tried to apply the driver to any of the drives.

    We have talked to both IBM, and EMC, here is a recap:

    IBM:
    Use the IBM device drivers for everything

    EMC, person #1:
    Use the IBM drivers for the changer and Windows LTO for the drives

    EMC, person #2:
    Use the IBM drivers for the changer, and TSM Drivers for the drives.

    So, I am at a loss..

  10. #10
    Senior Member
    Join Date
    Apr 2005
    Location
    Michigan
    Posts
    1,359
    Thanks
    0
    Thanked 2 Times in 2 Posts

    Default

    Go with what IBM and EMC #2 says - try the IBM device drivers -
    Others with EMC CDL hopefully will chime in
    Steven Gabriel
    Principal -SGSolutions Inc.
    http://www.sgsolutionsinc.com

  11. #11
    Member
    Join Date
    Mar 2006
    Location
    Wisconsin
    Posts
    11
    Thanks
    0
    Thanked 1 Time in 1 Post

    Default Disable Control Path Failover and Data Path Failover

    I've been working with TSM & EMC's CDL/EDLs for a few years now and know exactly what you're talking about with not being able to define the drive paths. We're emulating the IBM 3584 libraries w/ LTO2 drives. Because the libraries/drives are native IBM devices to the OS, you'll want to use the IBM device driver for both the libraries and the drives.

    To define the tape paths, you'll need disable the Control Path Failover and Data Path Failover. The IBM device driver package includes 2 reg files for this (reg\DisableCPF.reg & reg\DisableDPF). I had to open up a support call w/ IBM & EMC for this one last year and got the impression it was the first they had heard of it. This all started when we upgraded to the IBM device driver v6.1.2.8.

  12. #12
    Senior Member Jeff_Jeske's Avatar
    Join Date
    Jul 2006
    Location
    Stevens Point, WI
    Posts
    485
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Default

    We are an EMC shop with 720 falconstore CDL. We defined IBM 3584 libraries and use IBM drivers. It comes up as an IBM 3584 tape library version 6.0.8.2. We are using IBM drivers for the drives ..... IBM ULT 3580--TD2 SCSI.

    We have ours defined as LTO2 but it doesn't really matter what you call them because performance will be the same.
    Last edited by Jeff_Jeske; 07-08-2008 at 03:55 PM.

Similar Threads

  1. EMC-CDL Storage Pool Migration
    By proistok in forum Tape / Media Library
    Replies: 2
    Last Post: 02-14-2008, 04:39 PM
  2. CDL (DL 4200) 3494 emulation
    By denisl in forum Tape / Media Library
    Replies: 1
    Last Post: 07-16-2007, 06:17 PM
  3. EMC CDL / DL setup
    By denisl in forum Tape / Media Library
    Replies: 1
    Last Post: 05-30-2007, 01:08 PM
  4. Sepaton VS CDL any pluses or Negatives
    By rmcc82196 in forum Tape / Media Library
    Replies: 0
    Last Post: 03-12-2007, 10:27 AM
  5. Sysback implementation
    By mrbiji in forum Backup / Archive Discussion
    Replies: 1
    Last Post: 10-20-2006, 04:07 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •