Results 1 to 2 of 2
  1. #1
    Newcomer
    Join Date
    Apr 2007
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Post zfs snapshot and snapshotroot

    Hello,
    I'm trying to use option -snapshotroot on a zfs filesystem, tsm client is 5.5.0. 0 and solaris version Solaris 10 8/07.I have a zfs filesystem gipsy/data, mounted on /gipsy/data and create a zfs snapshot.
    # zfs snapshot gipsy/data@backup

    I run a incremental backup
    # dsmc inc /gipsy/data -snapshotroot=/gipsy/data/.zfs/snapshot/backup

    This backup the files in root directory /gipsy/data/, but it doesn't do a recursive backup of directories under /gipsy/data.
    How to fix this? With option -subdir=yes

    I change the command to:
    # dsmc inc /gipsy/data/* -subdir=yes -snapshotroot=/gipsy/data/.zfs/snapshot/backup

    Gives me result
    ANS7527E The (-SNAPSHOTROOT) option is not valid in conjunction with 10 file specifications.

    I have tried a few other things on the same topic, but can't backup a directory structure using snapshotroot and zfs.

    Any ideas or workarounds welcome. Mounting zfs snapshot on a "real" directory?

    Regards

    Lennart
    Last edited by norrby; 03-31-2008 at 12:22 PM.

  2. #2

Similar Threads

  1. Anyone using ZFS with TSM?
    By tburton in forum Solaris
    Replies: 11
    Last Post: 11-14-2009, 05:51 AM
  2. DB Snapshot.
    By khawts in forum TDP/Application Layer Backup
    Replies: 2
    Last Post: 11-07-2007, 12:32 PM
  3. snapshotroot on remote system
    By dustyp in forum Backup / Archive Discussion
    Replies: 0
    Last Post: 12-27-2006, 03:07 PM
  4. Snapshot Agent will not go away
    By astrotrain in forum TSM Client
    Replies: 2
    Last Post: 06-14-2006, 04:17 PM
  5. Backup a Snapshot with other OS
    By hstaal in forum Backup / Archive Discussion
    Replies: 0
    Last Post: 05-09-2006, 10:16 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •