Results 1 to 3 of 3
  1. #1
    Member
    Join Date
    Nov 2003
    Posts
    18
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default ANR0208W Partial write detected on recovery log errors

    EDIT: missed the (probably) more important top line of the output at the top - not sure how the path to the dsmserv.opt file got set as D:\\ when it's supposed to be c:\Program Files\Tivoli\tsm\server1

    We recently suffered a RAID problem on our TSM server (Win2k with 5.2.0.2 still on it).

    I've been able to restore the RAID set and get the machine booted and recognizing all the logical volumes on the server. However, the TSM server service will not start - starts, then stops immediately.

    Running dsmserv from the command line produces:

    ANR0905W Options file D:\\dsmserv.opt not found.

    <snip>

    ANR0990I Server restart-recovery in progress.
    ANR0212E Unable to read disk definition file dsmserv.dsk

    Checking for it, that file is there with the following:

    #dsk_comment#page_shadow_token:1080305130108
    C:\PROGRAM FILES\TIVOLI\TSM\SERVER1\LOG1.DSM
    C:\PROGRAM FILES\TIVOLI\TSM\SERVER1\DB1.DSM
    D:\LOG.DSM
    J:\DB0.DSM

    I've tried some suggestions found elsewhere - deleting that top line, recreating a new file with just the D: and J: entries (those are the only ones that matter, I think). No luck.

    Something I'm missing...?

    TIA,
    mike
    Last edited by sweater; 03-05-2008 at 05:40 PM. Reason: Able to resolve at least part of the issue...

  2. #2
    Member
    Join Date
    Nov 2003
    Posts
    18
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    OK - was able to resolve the .opt errors by editing the path to TSM server in the registry. Apparently that gets updated when things don't start right...

    Anyhow - now we're at this point:

    ANR0208W Partial write detected on recovery log volume D:\LOG.DSM, logical page 15872 (physical page 14080)
    ANR9999D logseq.c(758 ): ThreadId<0> Error 3 reading 64 pages from page0, offset 256

    And it still doesn't start. I'm confused by the error description that IBM gives:
    http://publib.boulder.ibm.com/infoce...anrcmsg117.htm

    "User response
    See accompanying messages for information about the volume in error."

    Is this an issue where I should be trying to create a new log for server1? And if so, how?

    - mike

  3. #3
    Senior Member Jeff_Jeske's Avatar
    Join Date
    Jul 2006
    Location
    Stevens Point, WI
    Posts
    485
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Default

    EDIT .... had the same problem.... DBRestore fixed issue.
    Last edited by Jeff_Jeske; 03-27-2008 at 01:36 PM.

Similar Threads

  1. Replies: 2
    Last Post: 02-03-2008, 11:11 AM
  2. Unable to run dsmserv format command
    By mighty in forum TSM Server
    Replies: 1
    Last Post: 06-27-2007, 08:42 AM
  3. dsmserv.dsk
    By tdp_ora in forum Disaster Recovery Module
    Replies: 3
    Last Post: 10-12-2005, 05:22 PM
  4. Replies: 1
    Last Post: 06-21-2004, 05:17 PM
  5. TSM Won't start, lost dsmserv.dsk now have ANR0259E
    By pbf00t in forum Backup / Archive Discussion
    Replies: 0
    Last Post: 06-18-2004, 04:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •